Stopping nouveau driver?

How do folks,

How do I stop or disable the “nouveau driver”?

I’ve installed the Nvidia driver but the nouveau driver is still in control.




I’m new to Linux so easy speak please.

when you post you should let us know which version of OpenSuSE your using it may make a difference.

you can go t yast2 and software management and do a search for nouveau and unistall it.

You can blacklist it in /etc/modprobe.d/50-blacklist.conf … ie add an entry at the end of that file:

blacklist nouveau

there is also a chance that kms may still try to load the nouveau driver, so you may also need to disable kms. I suspect the need to condcut that course of action my be openSUSE version specific, and I do not know enough to say which version, if any.


OpenSuse 12.3 64 bit
PNY 9400GT 1 Gb Pcie

ok how did you install the nvidia drivers?

you can go to yast2 software repositories >click on add repositories button >then community > scroll down the list and select nvidia and add it.

the you can just install the correct nvidia driver for your card and it should automatically blacklist nouveau for you.
good luck :slight_smile:

I downloaded it.
figured how to get to runlevel 3 and installed it that way.

But what happens is that the left side of the screen is not visible.
I have to adjust resolution to 800 by 600


Try the method I mentioned think it will work better for you.

Nvidia can be touchy but once set up it works pretty well.
make sure your using the right nvidia driver for your card also.