Stopped at booting while waiting for start job

Hello to everyone,

First, thanks to all of you for keeping open this space.

Well, I am on an openSuse Leap 15.5, with root partition encrypted, and hibernation activated. It happens that during. normal usage of the of the PC I did the available updates (do not remember which ones) and then send the computer to hibernation. Later, it never woke up. I saw an entry in the booting screen saying:

“A start job is running for /dev/mapper/vg1-swap”,

and the time running in parentheses.

I have googled some time and I found that I should comment the swap entry in crypttap and fstab, and then I should create a new swap. I commented the entry in fstab, but there is nothing related to swap in crypttab, and I do not know explicitly what to write for creating the new swap, since I do not know its devise name or anything else.

I took some shoots that I am attaching to this post. Thanks again for any possible contribution and for reading this.


The problem is that resume is handled from the initrd, but your encrypted swap is not being handled until after the initrd is completed.

I don’t know if this helps – from the man page for dracut:

       --add-device <device>
           Bring up <device> in initramfs, <device> should be the device name.
           This can be useful in hostonly mode for resume support when your
           swap is on LVM or an encrypted partition. [NB --device can be used
           for compatibility with earlier releases]

Thanks. It seems promising. I will try it as I go back to my desktop, though it will be just tomorrow.



Welcome to the openSUSE forums.

Please be aware that not everybody will browse to unknown commercial sites for looking at images. We have for this.

Thanks. I did not know indeed about that option. Initially I tried to upload them directly in the post, but the page refused it because of me being a newbe. Now it seems that they are too big. I would have to take them again.


I do not know what you want to show, but when it is just computer code (and not screen shots), you better copy/paste into the post.

And please then include the line with the prompt/command before the ouput and the line with the new prompt within the copy sweep. And use the Prefomated text (button </> from the post composer tool bar.

1 Like

I see. I’ll take that into account. However, in this moment I’d not know how to do it, since I have not a graphical interface.

OK, I understand. some redirect output to e.g. an USB stick, to post it from another system.

But indeed, a photo could be all that is left.

Hi nrickert,

I’ve reading from the man page of dracut, but I’ve not yet clear how to follow your suggestion. Could you please give me a little bit more detailed explanation?

Thnks, and bests,

I don’t have any experience with this. I normally don’t hibernate.

I did run into that situation of being stuck while booting. So I hit ‘e’ at the grub prompt, and changed the “resume=whatever” to “noresume” which got the boot to complete. Then I made that change permanent.

If you actually want hibernate to work, then maybe try:

dracut -f --add-device /dev/mapper/vg1-swap

You would have to do that as root. And you would have to redo it whenever the “initrd” is rebuilt. There probably a permanent configuration change that can be made so that it is automatic, but I haven’t looked into that since I don’t use hibernation.

I see. Thanks.
I did it. First, it put a warning saying that += “ ” should have surrounding white spaces, that the file should be fixed upon bad behavior; then
it put a warning preventing running in hostonly mode in a container; then, it says that cannot find a module directory, and lastly that —no-kernel was not specified.

Still, I tried to run the system, but it did no go… :sob: Any other idea.


As previously indicated I don’t have any experience with this. Maybe someone else will step in with a suggestion.

Sure. Thanks a lot. Perhaps I’ll do the same you did, and see later if I can fix permanent from inside.
Still, @nrickert, is it fine that crypttab doesn’t have an entry for the swap?

What resulted when you tried using nrickert’s suggestion?

I don’t know the answer for that, because I don’t know how your system is setup. Based on the device name for swap, I’m guessing that it is part of an LVM.

Here, I just use a single LVM with volumes for root, home, swap. So there’s a “crypttab” entry for the LVM (or, actually, the private volume assigned to the LVM), but no individual entry for root, home or swap.

Hi, @mrmazda,

Are you talking about his first suggestion…? It just stoped in the same part. But I didn’t do what he suggested to do in grub. I’ll try it later.



Thanks. I solved it by following the instructions state here:

I am not quite sure about which is the difference between @nrickert suggestion and this, if it was just a matter of permissions, but it worked now.

Thanks again.


I had a similar issue. The resolution was to remove zswap from the kernel modules.
Here is some information
You will probably have to backout and remove the zswap and retry

I think you need to disable thus

echo 0 > /sys/module/zswap/enabled

Or something similar. I don’t have access to the system I did this on any more
swap evicts pages from compressed cache on an LRU basis to the backing swap
device when the compressed pool reaches its size limit. This requirement had
been identified in prior community discussions.

Zswap is disabled by default but can be enabled at boot time by setting
the “enabled” attribute to 1 at boot time. ie: zswap.enabled=1. Zswap
can also be enabled and disabled at runtime using the sysfs interface.
An example command to enable zswap at runtime, assuming sysfs is mounted
at /sys, is:

echo 1 > /sys/module/zswap//enabled

Well, thanks.

However, now, without implementing your suggestion, i can hibernate from time to time, but perhaps my problem is in the size of the swap partition. I activated hipper threads in the “bios” and hibernation seems to be working better.

I guess that it might had been the instructions on SUSE web page that resolved my main problem. If I continue having problems with hibernation in later occasions, then i’ll try your suggestion. Thanks.