Stop Suspend/Standby on Lid Close

I didn’t seem to have this problem in OpenSUSE 12.2 at all. I upgraded from 12.2 to 12.3 and now whenever I close the laptop lid it goes into suspend/standby. I got so frustrated that I wiped out the install and clean installed it but I still have the problem.

It’s an older Dell Inspiron 1501 Laptop I’m using as a server for learning purposes. The laptop is old and makes a perfect machine for tinkering around with various CLI commands. However, I’d prefer to keep the lid on it closed so it doesn’t take up space.

I’m using a minimal environment, simply a sever command line interface. No GUI at all short of Yast’s pseudo-gui interface. There’s no option in the BIOS to turn of ACPI or APM functions.

I’ve tried various searches on google but either the config files they say to mention aren’t there or they say to log into Gnome, which I don’t have installed.

Can anyone help?

On 2013-03-14 10:46, zombiefox wrote:

> Can anyone help?

laptop-mode tools, perhaps.


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

I didn’t actually have the laptop-mode tools package installed. I found a package called ‘patterns-openSUSE-laptop’ in yast and removed it. Restarted and now the problem is fixed. Thanks, that pointed me in the right direction.

On 2013-03-14 20:36, zombiefox wrote:
>
> I didn’t actually have the laptop-mode tools package installed. I found
> a package called ‘patterns-openSUSE-laptop’ in yast and removed it.
> Restarted and now the problem is fixed. Thanks, that pointed me in the
> right direction.

Ok :slight_smile:

Though my idea was that you install laptop-mode tools, then configure
the package, it has a lot of settings you can find useful.

For example, when you close the lid of a laptop it is advisable to at
least power-off the display, because otherwise heat builds up too much.


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))