Stop Krunner from showing mails


I am having a little problem with my KDE installation. After a short venture into kmail I recently uninstalled it since I realised that i prefer thunderbird instead. But even though i have uninstalled kmail I cant get Krunner to stop searching and finding mails I downloaded while I was using kmail. This is a bit annoying. Does anyone know how to stop krunner from searching for email?

Hello and weelcome here.

Would you please be so kind to start questions/problems with telling which version of openSUSE you use. This to avoid getting advice based on assumptions.

Of course. I am running openSUSE 13.2 :slight_smile:

I do not see the “of course” :frowning:

Apart from you apparently not taking the advice to always tell what you have and use at the start of a question asked very serious, the worse problem is that nobody came here to help you.

Personaly I am running openSUSE 13.1, and KDE 4.11, but with KDE-PIM (Kontakt, Kmail. Kaddessbook, tec.) from KDE 3.5. So I can not be of much help I am afraid.

Maybe this post bumps you thread a bit up to be noticed by others.

Well, you can disable the “Desktop Search” plugin in KRunner’s settings (click on the “spanner” icon in its window), but this will prevent KRunner from showing anything that’s indexed by baloo, like files and contacts too.

Or uninstall baloo-pim to prevent your mails from even being indexed (you might have to remove the current index manually though, it’s in ~/.local/share/baloo/email/).
If you don’t want to use KDEPIM at all, you could even uninstall akonadi-runtime.

Btw, if you don’t use KMail but KRunner shows mails, you must have used KMail before and the mails are still there. So you maybe should just remove them, normally they are stored in ~/.local/share/local-mail/. Then they wouldn’t be displayed any more in KRunner as well of course.


It seems like I was a bit unclear. The ofcourse was meant as a response your question “Would you please be so kind to start questions/problems with telling which version of openSUSE you use”, I did take your response seriously :).


Thanks for your help! I deleted some of the files in ~/.local/share/baloo/email/ and ~/.local/share/local-mail/ and it seems to have worked ^^

I applogize for being a bit rude to you. You indeed worded it as you explain it here.
The case is that it seems to be a general disease not to mention what one is using. I have to ask this several times a day in the hope that such esential information is added to the thread before many people reject such a thread because they think it is waste of time helping in a thread were even basic thingss have to be asked before the picture is complete. >:(