Still Problems with BCM4318 and OpenSuSE 11.0

Hi,

My FS laptop has a BCM4318 wireless card. I’ve tried to get it working first by installing the firmware, and them by following the steps from the “primer”, but with no success :frowning:

The router uses WPA encryption.

Here’s some info:

sasa@sunflower:~> uname -a
Linux sunflower 2.6.25.5-1.1-pae #1 SMP 2008-06-07 01:55:22 +0200 i686 athlon i386 GNU/Linux

sasa@sunflower:~> /sbin/lspci | grep Wireless
08:0a.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

sasa@sunflower:~> /sbin/lspci -n | grep “08:0a.0”
08:0a.0 0280: 14e4:4318 (rev 02)

sasa@sunflower:~> /bin/dmesg | grep -n “b43”
415:b43-phy0: Broadcom 4318 WLAN found
447:input: b43-phy0 as /devices/virtual/input/input8
448:b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
449:Registered led device: b43-phy0::tx
450:Registered led device: b43-phy0::rx
451:Registered led device: b43-phy0::radio
452:b43-phy0: Radio hardware status changed to DISABLED

sasa@sunflower:~> /bin/dmesg | grep -n “wlan0”
453:ADDRCONF(NETDEV_UP): wlan0: link is not ready

This is the first point where something is wrong, as far as I can tell. The card is there, the firmware is there, but it fails to activate the link? Not sure if I should post more lines from dmesg?

Here’s more info:

sasa@sunflower:~> /usr/sbin/iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

No ESSID, though I’ve defined it using YaST (Network Devices/Network Settings recognizes the card but says “Not connected”) and added a connection through the applet (the gear turns and turns, but no connection is made and no error is reported on screen).

Predictably, the scan returns no results:

sasa@sunflower:~> /usr/sbin/iwlist wlan0 scan
wlan0 No scan results

What am I doing wrong?

Thanks.

Take care,
Leannonn

Hi,

Tried to add essid (genzard), channel (6), key (s:my_wpa_key) and ap (auto), manually with iwconfig. Now it says:

sasa@sunflower:~> sudo /usr/sbin/iwconfig wlan0
wlan0 IEEE 802.11g ESSID:“genzard”
Mode:Managed Frequency:2.437 GHz Access Point: Invalid
Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:4B33-6C65-4230-724E-6333-7333-6833-344D-45
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Take care,
Leannonn

quick question, do you have a wireless switch ? I only ask as i saw this

452:b43-phy0: Radio hardware status changed to DISABLED

Andy

> 452:b43-phy0: Radio hardware status changed to DISABLED

This message means that your radio enable switch is turned off! Until you set it
on, your device will not work.

Larry

Hi,

Thanks, for the replies.

Yes - there is a switch/button for turning wireless on/off on the laptop. The problem is nothing happens when I press it :frowning: Or almost nothing - the HDD light flickers a bit and that’s it. As if it tries to start/read something, but fails…

The wireless router is up & running - I can connect to it (at to the internet) from the other computer.

Take care,
Leannonn

Hi,

How do I do that? Just with the on/off button, or can it be done with some command? How do I see (a log?) what happens when I press the on/off switch for the wireless?

Take care,
Leannonn

Switch it on with the on/off button. When SuSE starts it should then see that the device can be activated for use. Basically,the on/off switch is there to provide power to the device,much like switching on your tv before using it ( unless it is on stand-by :wink: )

Andy

Hi,

It’s a button - it doesn’t have the ON (or OFF) position exactly, and pressing it does nothing until the computer/OS is up and running. As I said earlier, if I press it when it’s already up, then the HDD LED flickers for a moment, but the Wireless LED stays off at all times :frowning:

It worked fine under WinXP - the wireless LED stayed off during booting; after logging in I would press the button and it would turn the Wireless LED on.

Am I looking at incorrect driver/firmware? Is ndiswrapper my only way out?

Thanks :slight_smile:

Take care,
Leannonn

Hi,

OK. here’s what /var/log/messages has to say about me pressing the Wireless button:

Oct 29 09:15:01 sunflower kernel: atkbd.c: Unknown key pressed (translated set 2, code 0x6d on isa0060/serio0).

So, basically, the wireless button is not “linked” to the action of turning the wireless card on, right? I have to define that action somehow?

Take care,
Leannonn

Hmm, according to all the bumph, your device should be working. Try pressing the wireless on/off button when you are booting up,see if that works

Andy

Hi,

No :frowning: Still the same “Unknown key” lines in the log each time I press the button…

Take care,
Leannonn

Hi,

Found this module which should do the trick of turning the wireless on: SourceForge.net: fsaa1655g - FSC Amilo A1655G WLAN switch. I’ll give it a try and I’ll let you know what happened…

Take care,
Leannonn

Hi,

Yes, the module did the trick. I’m now able to turn the card on (instructions for installation and usage: fsaa1655g - Fujitsu Siemens Amilo A1655G, L1310G WLAN switch for Linux).

I had to install the kernel-source and kernel-syms and update the kernel itself to match the source version (2.6.25.5-1.1-pae -> 2.6.25.18-0.2-default) before installing the module itself.

Thanks a lot for all your help rotfl!

Take care,
Aleksandar

Cool, Glad you got it sorted,now Enjoy :slight_smile:

Andy
p.s. as you see, if you had informed us of all the hardware(i.e. laptop make/model) maybe we could have sorted this quicker :wink:

Hi,

But it was quick! You said that nothing else was wrong and that was immense help! Pointed me in the right direction and it turned out that was all I needed :slight_smile:

Thanks, again lol!

Take care,
Leannonn

P.S. I did say it was a FS laptop, and I did put the model in the tags :wink:

Ahh! the tags, never look at them personally.Never mind,alls well that ends well

Andy

hey i’ve just installed 11.0. I have never used any linux before. But i am having the same problem, but i don’t have an on or off switch.

my model of laptop is a gateway mx 7118

info: (as obtained using instructions from primer)

08:07.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless Lan Controller (rev 02)

08:07.0 0280: 14e4:4318 (rev 02)

b43-phy0: Broadcom 4318 WLAN found
phy0: Selected rate controll algorithm ‘pid’
Broadcom 43xx driver loaded Features: PMLR, Firmware-ID: FW13]

wlan0 IEEE 802.11g ESSID: “”
ModeManaged Channel:0 Access Point: Not-Associated
Tx-Power=0 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 MIssed beacon:0

wlan0 Interface doesn’t support scanning : Network is down

i should mention that i’m trying to log on to a ssid signal, not an essid.

I’ll be trying to figure this out while in class.

welcome to the OpenSuse forums;

when you have a topic, you will find it much better to start a new post:

it is easier for folks to find; and follow;

so try making a new post with all the details; you may well get more folks reading it;

and be keen to help you;

best wishes

oh i got it working now i went through all the lines of code in dmesg | less
and found a website to help me

if anyone is having trouble still try:

b43 - Linux Wireless

after a restart everything is working fine now.

Hi, I’d like to say thanks to leannonn for the useful informations. Now I’m able to use my wireless card even with opensuse.

I’d like to add some little more commands that may be useful for other people having my same problems during the installation of the module.

  1. Go to Yast and install the modules:
    kernel-source
    kernel-syms

2)Download the file fsaa1655g-kernel-2.6.26.tar.bz2 at fsaa1655g - Fujitsu Siemens Amilo A1655G, L1310G WLAN switch for Linux

  1. Extract the file

  2. Go to terminal and go to the extracted folder and digit:

make
make install
sudo modprobe fsaa1655g

  1. Now for some Opensuse users a problem will occur. Even with “sudo” the modprobe command can’t be used. To solve this inconvenient you can add modprobe as a command that can run with sudo, but It’s not always a good thing change the safety settings of opensuse. The easyest way is to give the command:

su

then insert the root password and give

modprobe fsaa1655g

now the wifi would works fine!

  1. I’ve tried also to use the command echo 1 > /proc/fsaa1655g/radio to turn on the wifi card and echo 0 > /proc/fsaa1655g/radio
    to turn it off but it doesn’t work. If you have the same problem you can solve it doing:

*to turn on the card:
su
modprobe fsaa1655g

  • to turn it off:
    su
    modprobe -r fsaa1655g

Maybe some linux expert would say that It’s not the best way, but It works, so for me It’s an excellent solution. Notice that with those commands you can turn the card on/off “on demand”.

I hope that also my post will be useful.

Bye!

Simone