Still feeling my way with TW & btrfs; does my fstab look ok pls?


Lappy with ~250 GB SSD, 8 GB RAM, & oS TW on it only for ~ 1 1/2 months [ie, new to it, & me]. As per subject line, i still feel i’m on my training wheels with TW, & am hence trying to learn lots, fast.

Here’s blkid for starters:

linux-763v:~> **sudo blkid**
[sudo] password for root:  
/dev/sda1: PARTLABEL="primary" PARTUUID="snipped"
/dev/sda2: UUID="snipped" TYPE="vfat" PARTLABEL="primary" PARTUUID="snipped"
/dev/sda3: LABEL="root" UUID="snipped" UUID_SUB="snipped" TYPE="btrfs" PTTY
PE="dos" PARTLABEL="primary" PARTUUID="snipped"                                                  
/dev/sda4: UUID="snipped" TYPE="crypto_LUKS" PARTLABEL="primary" PARTUUID="snipped"                 
/dev/sda5: UUID="snipped" TYPE="crypto_LUKS" PARTLABEL="primary" PARTUUID="snipped"
/dev/mapper/cr_ata-SAMSUNG_SSD_PM810_2.5__256GB_S0N4NEAZB01960-part4: UUID="snipped" TYPE="swap"
/dev/mapper/cr_ata-SAMSUNG_SSD_PM810_2.5__256GB_S0N4NEAZB01960-part5: UUID="snipped" TYPE="ext4"

I’ve already edited /etc/sysctl.conf to add:

# Sharply reduce swap inclination

# Improve cache management

…& so finally here’s my fstab:

/dev/mapper/cr_ata-SAMSUNG_SSD_PM810_2.5__256GB_S0N4NEAZB01960-part4 swap swap defaults 0 0UUID=snipped / btrfs noatime 0 0
UUID=snipped /boot/grub2/i386-pc btrfs noatime,subvol=@/boot/grub2/i386-pc 0 0
UUID=snipped /boot/grub2/x86_64-efi btrfs noatime,subvol=@/boot/grub2/x86_64-efi 0 0
UUID=snipped /opt btrfs noatime,subvol=@/opt 0 0
UUID=snipped /srv btrfs noatime,subvol=@/srv 0 0
UUID=snipped /usr/local btrfs noatime,subvol=@/usr/local 0 0
UUID=snipped /var/cache btrfs noatime,subvol=@/var/cache 0 0
UUID=snipped /var/crash btrfs noatime,subvol=@/var/crash 0 0
UUID=snipped /var/lib/libvirt/images btrfs noatime,subvol=@/var/lib/libvirt/images 0 0
UUID=snipped /var/lib/machines btrfs noatime,subvol=@/var/lib/machines 0 0
UUID=snipped /var/lib/mailman btrfs noatime,subvol=@/var/lib/mailman 0 0
UUID=snipped /var/lib/mariadb btrfs noatime,subvol=@/var/lib/mariadb 0 0
UUID=snipped /var/lib/mysql btrfs noatime,subvol=@/var/lib/mysql 0 0
UUID=snipped /var/lib/named btrfs noatime,subvol=@/var/lib/named 0 0
UUID=snipped /var/lib/pgsql btrfs noatime,subvol=@/var/lib/pgsql 0 0
UUID=snipped /var/log btrfs noatime,subvol=@/var/log 0 0
UUID=snipped /var/opt btrfs noatime,subvol=@/var/opt 0 0
UUID=snipped /var/spool btrfs noatime,subvol=@/var/spool 0 0
UUID=snipped /var/tmp btrfs noatime,subvol=@/var/tmp 0 0
UUID=snipped /.snapshots btrfs noatime,subvol=@/.snapshots 0 0
UUID=snipped /boot/efi            vfat       noatime,umask=0002,utf8=true 0 0
/dev/mapper/cr_ata-SAMSUNG_SSD_PM810_2.5__256GB_S0N4NEAZB01960-part5 /home                ext4       noatime,acl,nofail    0 2
#tmpfs                /tmp                 tmpfs      noatime,size=25%      0 0
tmpfs                /tmp                 tmpfs      noatime,size=256m      0 0

Whilst i’d greatly value all comments on that file, i do have these specific questions:

  1. How can i create the label "home
    " for my /home partition? YaST Partitioner wouldn’t even give me the option, & though KDE Partition Manager did, it then ignored the change i made. In contrast, YaST happily let me add label “root” to /. 1. Are the current /tmp tmpfs
    settings ok / should they be improved? I note that my Tower’s Maui [32 GB RAM, & i run [i]substantially more programs simultaneously on Tower compared to Lappy] line is more complex:
tmpfs    /tmp    tmpfs   defaults,noatime,size=2G,mode=1777 0       0

Thank you in anticipation.

Why noatime? Show the output from the command mount to see what is actually being used, the defaults offer optimizations for ssd’s already…

First, I normally do not worry about the correctness of /etc/fstab as created by the installer. Why should I?

Second, I did not check for Tumblweed, but YaST > System > Partitioner is able to set a Volume Label on a file system. I do not know why you can not find that, but talking about GUI programs is always much more difficult then using them.
I see, that the file system you mount on /home is ext4. Thus you can use tune2fs to set a Volume Label to an ext2/3/4 file system. See

man tune2fs

It would something like

tune2fs -L <label> /dev/mapper/cr_ata-SAMSUNG_SSD_PM810_2.5__256GB_S0N4NEAZB01960-part5

Edit:. I now get the idea that something is encrypted there. I have no idea how tune2fs handles this. And it may be the reason why YaST does not show it as a possibility.

linux-763v:~> mountsysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
devtmpfs on /dev type devtmpfs (rw,nosuid,size=3944128k,nr_inodes=986032,mode=755)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/unified type cgroup2 (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/rdma type cgroup (rw,nosuid,nodev,noexec,relatime,rdma)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
/dev/sda3 on / type btrfs (rw,noatime,ssd,space_cache,subvolid=728,subvol=/@/.snapshots/423/snapshot)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=26,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=960)
mqueue on /dev/mqueue type mqueue (rw,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
tmpfs on /tmp type tmpfs (rw,noatime,size=262144k)
/dev/sda3 on /opt type btrfs (rw,noatime,ssd,space_cache,subvolid=262,subvol=/@/opt)
/dev/sda2 on /boot/efi type vfat (rw,noatime,fmask=0002,dmask=0002,allow_utime=0020,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro)
/dev/sda3 on /var/spool type btrfs (rw,noatime,ssd,space_cache,subvolid=276,subvol=/@/var/spool)
/dev/sda3 on /boot/grub2/x86_64-efi type btrfs (rw,noatime,ssd,space_cache,subvolid=261,subvol=/@/boot/grub2/x86_64-efi)
/dev/sda3 on /var/crash type btrfs (rw,noatime,ssd,space_cache,subvolid=266,subvol=/@/var/crash)
/dev/sda3 on /var/lib/mysql type btrfs (rw,noatime,ssd,space_cache,subvolid=271,subvol=/@/var/lib/mysql)
/dev/sda3 on /var/lib/named type btrfs (rw,noatime,ssd,space_cache,subvolid=272,subvol=/@/var/lib/named)
/dev/sda3 on /var/lib/mariadb type btrfs (rw,noatime,ssd,space_cache,subvolid=270,subvol=/@/var/lib/mariadb)
/dev/sda3 on /var/cache type btrfs (rw,noatime,ssd,space_cache,subvolid=265,subvol=/@/var/cache)
/dev/sda3 on /var/log type btrfs (rw,noatime,ssd,space_cache,subvolid=274,subvol=/@/var/log)
/dev/sda3 on /srv type btrfs (rw,noatime,ssd,space_cache,subvolid=263,subvol=/@/srv)
/dev/sda3 on /var/tmp type btrfs (rw,noatime,ssd,space_cache,subvolid=277,subvol=/@/var/tmp)
/dev/sda3 on /var/lib/mailman type btrfs (rw,noatime,ssd,space_cache,subvolid=269,subvol=/@/var/lib/mailman)
/dev/sda3 on /var/opt type btrfs (rw,noatime,ssd,space_cache,subvolid=275,subvol=/@/var/opt)
/dev/sda3 on /var/lib/machines type btrfs (rw,noatime,ssd,space_cache,subvolid=268,subvol=/@/var/lib/machines)
/dev/sda3 on /var/lib/libvirt/images type btrfs (rw,noatime,ssd,space_cache,subvolid=267,subvol=/@/var/lib/libvirt/images)
/dev/sda3 on /.snapshots type btrfs (rw,noatime,ssd,space_cache,subvolid=258,subvol=/@/.snapshots)
/dev/sda3 on /boot/grub2/i386-pc type btrfs (rw,noatime,ssd,space_cache,subvolid=260,subvol=/@/boot/grub2/i386-pc)
/dev/sda3 on /var/lib/pgsql type btrfs (rw,noatime,ssd,space_cache,subvolid=273,subvol=/@/var/lib/pgsql)
/dev/sda3 on /usr/local type btrfs (rw,noatime,ssd,space_cache,subvolid=264,subvol=/@/usr/local)
/dev/mapper/cr_ata-SAMSUNG_SSD_PM810_2.5__256GB_S0N4NEAZB01960-part5 on /home type ext4 (rw,noatime,data=ordered)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=790320k,mode=700,uid=1000,gid=100)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=100)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)

I agree, but in my case fstab also contains some mods i made… hence my asking for expert overview. Had i made no edits i’d have not wasted my & readers’ time posting.

I can’t find it because it is not there. YaST Partitioner certainly did let me set a volume label for root [btrfs, not encrypted] & so i did], but then when i tried the identical process for *home *[ext4, encrypted], the YaST GUI window that opened was different to that which had appeared for root, & did not include a field to insert a label.

Interesting, thank you, i shall have a look at that.

EDIT: Oh, groan, just saw your edit. Guess i won’t look into it after all. So, seems like i have to do without a label for home; pity .

Mark that am not sure about this, but it struck me because you do not see it in YaST (and you apparently know where it normally is) and there seems to be encryption (which you did not confirm) and by some brain wave I saw a possible connection.

Did you have it on those Ms with encryption?*


Mind you, i have now remembered that with them both, i was not able to add the labels from the running systems, given the partitions were mounted & i lacked enough confidence in my own abilities to attempt to do it by unmounting said partitions whilst still in the running system]. So back then, i believe, i booted into a Live USB, & then used its gparted/KPartitionManager to affix my labels, then rebooted normally. That process worked well.

I’m half-inclined to try that now, for Lappy’s TW, but i’m nervous because TW’s /home encryption is quite different i think to Mint’s/Maui’s eCryptFS /home encryption — ie, i hope i’m not about to destroy my Tumbleweed .

Is that bad? The reason i did it is that, having come to openSUSE from the *buntu-derivative side of the hill, over many years there’s been multiple SSD-tuning “How To” type websites advising that using this is good for minimising superfluous writes to the drive & so maximising the SSD’s possible life. I claim zero expertise in this; i was merely influenced by all those sites & so that’s what i put into my previous Mint’s & current Maui’s fstabs.

If that’s bad with openSUSE then of course i shall remove it… i’m just still trying to learn & get my TW “right”.

Oh rats, something went wrong with my earlier paste. This is what the first 2 lines should have looked like:

linux-763v:~> mount
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)

I see, obviously, those 25 relatimes vs 23 noatimes, despite my fstab using noatime. Once again i’m now out of my depth; i used to think that fstab ruled the roost…

Well, i’m sorry you feel that way. I always try to provide all [or at least lots of] the relevant applicable info when i ask for help. In this case, in my initial post in this thread, i pasted my blkid & fstab, both of which i had believed indicated that my home partition is encrypted [as is [u]swap too, but that might be less obvious, i’m unsure].

Edit: Oh, no, i partially retract that previous paragraph. Whilst blkid definitely shows that two partitions are encrypted, because fstab makes no reference to /dev/sdaX, and because i outsmarted myself by snipping out all the UUIDs, there was no reasonable way you could tell. I apologise, mea culpa.

As a general remark.

When you post between CODE tags, we all assume this is, from the begin to the end of the CODE part, the unabridged, unaltered copy/past from a terminal window. Of course you may want to alter there something small like a readable password, but then you should always say so, and keep it to a minimum. Changing UUIDs is rather paranoid IMHO. When you do not do this, your trustworthiness will soon be damaged beyond repair and your CODE parts will be treated as tainted as your story telling.

One of the main reasons to post terminal output is to see what an OP did and saw without any assumption/conclusion of the OP. After all the OP has a problem he is unable to solve, that is why he asks here. One reason somebody is unable to solve a problem is because he looks at the problem the wrong way (very natural, because (s)he is human). To allow potential helpers to look at a problem fresh and unbiased is to post the facts and nothing but the facts.

We see things here in the forums like “I did not post it because there are only error messages”. That wasn’t you, but it shows how people completely misunderstand the way problem debugging often works.

I have now tried it… but didn’t get anywhere. The LiveUSB’s *KPartitionManager *said, for Lappy’s encrypted home & swap partitions:

File system:    luks
Label:          This file system does not support setting a label.


Does xfs [encrypted during installation with [i]luks*, as i did on my current ext4 /home] support volume labels? If so, & if xfs is not otherwise inferior to ext4, then when i bring Tower along to join Lappy as a Tumbleweed box then i might choose xfs not ext4 this time for my encrypted /home partition.

As a general response:

  1. I respect your wisdom, appreciate your & others’ help, & will try even harder than i already have to provide all the info [IMO i have already done not so badly in that regard; it’s sad you disagree].
  2. I bridle at your aggressive general tone. I respectfully beg you to remember that not everyone has your apparent expertise nor years of experience with Linux generally nor oS specifically. I am trying my hardest, & would appreciate you cutting me some polite slack please. Impugning my trustworthiness & credibility is plain rude, & uncalled for.
  3. He, he, he, he. Lovely, but i am a she, as my UserID rather denotes. I request you apply a little gender neutrality out of respect for all
    your users pls.
  1. I do not disagree, I simply try to initiate you into the tricky action of asking for help in an efficient way. A way not to shy off potential helpers. BTW a good document is on . It is not 100% applicable on the forums here, but it has some good hints. And you do not do badly and that means that I gladly take the opportunity to take you a few steps further. And do not forget that all here is for the benefit of others too. Thus, wen you change UUIDs in a CODE part without much further explanation, I only take it as an example for others that that is probably not a good idea.
  2. I only tell you how it is. This is not General Chitchat or the like, but a technical help forum, were we try to be as efficient as possible. We had threads here were only after days the helpers found out that the information provided by an OP were altered so all understood it wrongly. The result was very confusing, no solution found and the OP after that ignored by many in any new threads he started. All here use their spare time. The reward is nice solutions found and happy OPs. Frustration due to information given sloppy is not an encouragement to help in the future.
  3. I see udserids here on the forums just as a unique combination of characters. Most of the time they are sort of jokes only to be understood by the owner or his/her direct cultural environment. Thus where I understand what the English word Girl means, I have no idea what the part Gooey means, nor if it is English and thus also not if Girl should be read as an English word. I also do not know what your first language is. You only state that you are based at Oz, which is as remote from me as the other person that states he comes from Galaxy. Again, when you use lingo from a certain cultural environment, do not assume the joke is understood by everyone. And I had at least one (s)he on my post, because it was a “General remark”, not only for you.

The only thing I do is configure swappiness in /etc/sysctl.conf…;

vm.swappiness = 1
vm.vfs_cache_pressure = 50

SSD’s these days are pretty robust with respect to writes, check your disk specs, then look at the output from smartctl for write information, most of mine average around 6G writes a day… for example the SanDisk specs for the SSD in this system say 40G a day… My oldest SSD (OCZ Agility3) is at 38K hours and SSD_Life_Left left is 99% now…

Thanks Malcolm.

Yep, already done thanks… Post #1

Aha, good to know, thanks.

I’ll answer my own question… NO, it does not.

I found this by creating another TW VM in my Tower, with root as btrfs [not encrypted], & home as xfs luks-encrypted. In this configuration there is no data entry field available for adding a volume label to home. Oh well.

I’m happy to now regard this thread as Closed.