Steps to take before installing opensuse to dual boot with windows 8.1???

I just installed opensuse on a old pre-uefi laptop. it dual boots with windows7.

and I want to do it again on newer uefi toshiba L840d laptop. i tried twice last year to install kubuntu on the toshiba but i got only problems. the grub boot choice window doesn’t come at boot and it just boots straight into windows 8.1 or if try, into kubuntu, but no choice is given. plus i had other problems. Like this guy

can someone please give me directions to prepare my uefi laptop for installing opensuse??

i can give more details if you want.

The honest answer is that we do not know what problems you will have, until you run into them.

There was a long thread last year:
openSUSE/Windows8 dual boot installation Questions for Secure Boot, UEFI and GPT
on installing on a Toshiba. But it’s a different Toshiba model, so the problems might not be the same. Still, I suggest you browse through that thread to get an idea.

As I recall, the trick was to copy the opensuse boot stuff to the directory “\EFI\Boot” in the EFI partition, and rename “shim.efi” there as “bootx64.efi”. That’s because the BIOS was using that way of booting. But again, you might have different problems.

That’s scary… … i talked to toshiba on the phone and they said they don’t support linux. so this is why people are having trouble with their toshiba laptops.

so should i read that thread and just start installing and come back here for help??


I’m pretty sure we will be able to help you get it working. But it may take a bit of effort.

If reinstalling Win8 is an option, you could change back to ‘legacy’ BIOS, install Win8 first and then oS.

i can put it effort… I did it with the help of kubuntu techs, but after weeks of trying I gave up. i hope it will be differnet with opensuse.

I just reinstalled Windows last month. i don’t want to redo it again. but uefi is very difficult. it wouldn’t even let me boot from usb… let me try again with opensuse.

Be sure you boot the install media in EFI mode. When done the install should be set up to install as EFI. Be sure that Windows is properly shut down 8.X has a fast boot mode an does a kind of hibernate. If you plan to use secure boot be sure to tick the box in the installer.

okay I just tried to install 64 bit opensuse on my laptop but i got a different install screen than i did when installed opensuse on my 32-bit laptop. there were 4 options. boot the live cd, the second was a variation of boot the live cd, the third was media check and the last boot from hard disk.

The first one worked, i didn’t try to second or third and the last gives an error. i didn’t get the install to hard drive option.

when i used image writer to make a live usb for the 32-bit usb, i couldn’t open it in windows, i got an error … but i was able to open the 64 bit usb and there was an EFI folder in it. I used image writer again, same thing happens again… there is only 4 MB visible on my 16gb usb. i’m going to try again and see what happens.

is used the 942mb kde live cd file… should i get the 4.7gb dvd file?

NO size will not change if done correctly

You must use a program to do a binary copy of the iso to the install device

Some report that imagewriter may not work on Window 8.x

try imageUSB

i tried again and the second (failsafe- boot to live cd), third and fourth options fail saying unknow file system.

I disabled secureboot, enabled boot from usb and booted efi usb from change pc settings> update and recovery > recovery > advanced startup.

what to do next? i’m out of ideas.

edit: I’m now going to try imageusb.

Okay, i tried with imageusb (write to ufd) and it didn’t work. i used partition software to clear the usb, format, and reinstall kde live cd 64 bit in there but i’m getting the same four options: boot from live cd, failsafe - boot from live cd, media check and boot from hard disk. the last two don’t work because of unknown file system. the first two are not what i want.

what happened to the install to hard disk option from the 32 bit file? now i can only use this a live usb. i need the install option.

Don’t you have an “Install” icon on the Live system’s desktop?

Maybe the LiveCD just doesn’t support installing on an UEFI system? (I’m not sure there though)
If you have an Internet connection (and it is working in the live system, i.e. you don’t need an additional driver), you could try the Netinstall ISO. That’s what I prefer to use.
It is only 150-200 MiB to download, but it fetches the packages it installs from the Internet of course during the installation.

This is good. You booted the live media in UEFI mode. Yes, the screen is different, and with fewer options.

That might be a limitation of Windows. Perhaps it only opens the first partition on a USB.

I should have added that, once you have booted the live media, there should be an install icon on the desktop. So the missing installation option on the boot screen is not a problem.

no i didn’t look at the desktop properly. i’ll do it agian.

yes, i looked at the usb in a partition tool. it had the full copy of kde live cd there but on a different partition. because windows could only see the small 4mb efi partition.

yes! it installed successfully again!!!

i chose grub2-efi for bootloader and enabled secureboot option in setup.

Most things seem to be working including network. opensuse changes the sound level on screen when i push the keyboard buttons but the volume is the same. I have to use the alsa menu in the right side to actually raise lower volume. how to fix this?

I got in and 1-click installed flash and media codecs. i’m booted back into windows.

everything seems to be normal!!

thanks to all of you again because i got linux and windows working on my laptop after many previous tries!

We are glad to hear that. If you run into problems down the road, then open a new thread on the particular problem.