No thread has been made on it since 2009, yet it seems like StepMania for OpenSUSE Factory is broken (and my testing PC now has a lot of junk on it as I tried to get it to run).

When installed from the official repos, we get a version without NoteSkins. Solution: get the NoteSkins from the source and place them in /usr/share/games/stepmania.

It still fails, and recommends reporting a bug at a SourceForge tracker. But the tracker for that group has been disabled, so that’s no use.

Afterwards I tried the version on the OBS, but it’s severely outdated and doesn’t compile.

After that I compiled the game from source and it still failed to run properly, so I will be making a bug report upstream.

Unless someone else has gotten the game to run properly, I recommend removing it from the official repos.

Please let me know what you think.


Hmmm if it is no longer supported there is little you can complain about you would need to fix the code yourself or interest someone that can in to spending some time on it.