Steam won't start after automatic update today

openSUSE 13.2 x64 KDE4

Steam was working fine a few days ago. Today after staring it as usual from the games menu, it displayed the message below and quit:

Error: You are missing the following 32-bit libraries, and Steam may not run:
libXtst.so.6

After installing this -32 lib from the 13.2 update repo (still online) steam freezes at the Connecting Steam account with a crash dump in /tmp/dumps. Running just steam from console behaves the same AFAICS.

Note: the app menu command is

SDL_AUDIODRIVER=alsa /usr/bin/steam %U

From this thread https://forums.opensuse.org/showthread.php/526094-Steam-not-starting?p=2831901#post2831901 running from konsole, steam freeze after the login dialog, not before:

:~> STEAM_RUNTIME_PREFER_HOST_LIBRARIES=0 steam
cut: /home/blimmer/.local/share/Steam/steamapps/libraryfolders.vdf: Arquivo ou diretório não encontrado
cut: /home/blimmer/.local/share/Steam/steamapps/libraryfolders.vdf: Arquivo ou diretório não encontrado
removing troublesome steam-runtime libs...
-> checking /home/blimmer/.local/share/Steam/ubuntu12_32/steam-runtime
-> checking /home/blimmer/.local/share/Steam/steamapps
find: ‘/home/blimmer/.local/share/Steam/steamapps’: Arquivo ou diretório não encontrado
bringing in our fixed openssl libraries
/home/blimmer/.local/share/Steam/steam.sh: line 138: DISTRIB_ID: variável não vinculada
/home/blimmer/.local/share/Steam/steam.sh: line 152: DISTRIB_RELEASE: variável não vinculada
/home/blimmer/.local/share/Steam/steam.sh: line 138: DISTRIB_ID: variável não vinculada
/home/blimmer/.local/share/Steam/steam.sh: line 152: DISTRIB_RELEASE: variável não vinculada
Running Steam on   64-bit
/home/blimmer/.local/share/Steam/steam.sh: line 138: DISTRIB_ID: variável não vinculada
/home/blimmer/.local/share/Steam/steam.sh: line 152: DISTRIB_RELEASE: variável não vinculada
STEAM_RUNTIME is enabled automatically
Pins potentially out-of-date, rebuilding...
/home/blimmer/.local/share/Steam/steam.sh: line 269: no match:  libpostfix-master.so.1 -> libpostfix-master.so.1.0.1.*}so
Installing breakpad exception handler for appid(steam)/version(1504757234)
Installing breakpad exception handler for appid(steam)/version(1504757234)
Installing breakpad exception handler for appid(steam)/version(1504757234)

(steam:3650): Gtk-WARNING **: Não foi possível localizar a ferramenta de temas no module_path: "clearlooks",
......
(many equal entries)
......
(steam:3650): Gtk-WARNING **: Não foi possível localizar a ferramenta de temas no module_path: "clearlooks",
Installing breakpad exception handler for appid(steam)/version(1504757234)
Installing breakpad exception handler for appid(steam)/version(1504757234)
[0915/192127.678530:ERROR:web_plugin_impl.cc(38)] Widevine registration is not supported after context initialization
[0915/192128.680085:ERROR:web_plugin_impl.cc(38)] Widevine registration is not supported after context initialization
[0915/192129.681953:ERROR:web_plugin_impl.cc(38)] Widevine registration is not supported after context initialization
[0915/192130.683214:ERROR:web_plugin_impl.cc(38)] Widevine registration is not supported after context initialization
Setting breakpad minidump AppID = 769
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561197960265728 [API loaded no]
[0915/192131.684596:ERROR:web_plugin_impl.cc(38)] Widevine registration is not supported after context initialization
Generating new string page texture 2: 48x256, total string texture memory is 49,15 KB
Generating new string page texture 3: 256x256, total string texture memory is 311,30 KB
Assert( Assertion Failed: !bSharedKVSymbols ):appdatacache.cpp:2095

crash_20170915192138_16.dmp[3708]: Uploading dump (out-of-process)
/tmp/dumps/crash_20170915192138_16.dmp
[2017-09-15 19:21:24] Startup - updater built Sep  6 2017 20:37:15
Looks like steam didn't shutdown cleanly, scheduling immediate update check
[2017-09-15 19:21:24] Checking for update on startup
[2017-09-15 19:21:24] Checking for available updates...
[2017-09-15 19:21:25] Download skipped: /client/steam_client_ubuntu12 version 1504757234, installed version 1504757234
[2017-09-15 19:21:25] Nothing to do
[2017-09-15 19:21:25] Verifying installation...
[2017-09-15 19:21:25] Performing checksum verification of executable files
[2017-09-15 19:21:25] Verification complete
appdatacache.cpp (2095) : Assertion Failed: !bSharedKVSymbols
roaming config store loaded successfully - 1187 bytes.
migrating temporary roaming config store
appdatacache.cpp (2095) : Assertion Failed: !bSharedKVSymbols
......
(many equal entries)
......
appdatacache.cpp (2095) : Assertion Failed: !bSharedKVSymbols
appdatacache.cpp (2095) : Assertcrash_20170915192138_16.dmp[3708]: Finished uploading minidump (out-of-process): success = yes
crash_20170915192138_16.dmp[3708]: response: CrashID=bp-d73d14dd-53a2-4685-907b-6e8182170915
crash_20170915192138_16.dmp[3708]: file ''/tmp/dumps/crash_20170915192138_16.dmp'', upload yes: ''CrashID=bp-d73d14dd-53a2-4685-907b-6e8182170915''

From the another post in the same thread https://forums.opensuse.org/showthread.php/526094-Steam-not-starting?p=2831037#post2831037 i tried renaming ~/.steam, but it was just recreated the same - of relevance, there are only links to ~/.local/share/Steam folders with libraries, SDK and such.

After the freeze the following steam processes remain:

:~> ps -aux | grep steam
blimmer   4414  0.0  0.0  13076  2868 pts/2    S+   19:52   0:00 bash /usr/bin/steam
blimmer   4445  0.0  0.0  15948  3584 pts/2    S+   19:52   0:00 bash /home/blimmer/.local/share/Steam/steam.sh
blimmer   4534  1.0  0.4 216948 107316 pts/2   Sl+  19:52   0:01 /home/blimmer/.local/share/Steam/ubuntu12_32/steam
blimmer   4538  0.0  0.2 137336 50696 pts/2    S+   19:52   0:00 /home/blimmer/.local/share/Steam/ubuntu12_32/steam
blimmer   4539  0.0  0.0  13080  2692 pts/2    S+   19:52   0:00 /bin/bash /home/blimmer/.local/share/Steam/ubuntu12_64/steamwebhelper.sh -lang=en_US -cachedir=/home/blimmer/.local/share/Steam/config/htmlcache -steampid=4534 -buildid=1504757234 -steamid=0 -clientui=/home/blimmer/.local/share/Steam/clientui --disable-spell-checking --disable-out-of-process-pac --enable-blink-features=ResizeObserver --disable-smooth-scrolling --disable-gpu-compositing --disable-gpu --log-file=/home/blimmer/.local/share/Steam/logs/cef_log.txt
blimmer   4542  0.0  0.3 706396 89380 pts/2    Sl+  19:52   0:00 ./steamwebhelper -lang=en_US -cachedir=/home/blimmer/.local/share/Steam/config/htmlcache -steampid=4534 -buildid=1504757234 -steamid=0 -clientui=/home/blimmer/.local/share/Steam/clientui --disable-spell-checking --disable-out-of-process-pac --enable-blink-features=ResizeObserver --disable-smooth-scrolling --disable-gpu-compositing --disable-gpu --log-file=/home/blimmer/.local/share/Steam/logs/cef_log.txt
blimmer   4544  0.0  0.2 381516 50748 pts/2    S+   19:52   0:00 /home/blimmer/.local/share/Steam/ubuntu12_64/steamwebhelper --type=zygote --no-sandbox --lang=en_US.UTF-8 --log-file=/home/blimmer/.local/share/Stea lve Steam Client
blimmer   4565  0.0  0.2 411116 67004 pts/2    Sl+  19:52   0:00 /home/blimmer/.local/share/Steam/ubuntu12_64/steamwebhelper --type=gpu-process --no-sandbox --lang=en_US.UTF-8 --log-file=/home/blimmer/.local/share/Steam/ubuntu12_64/debug.log --product-version=Valve Steam Client --supports-dual-gpus=false --gpu-driver-bug-workarounds=7,24,77 --disable-gl-extensions=GL_KHR_blend_equation_advanced GL_KHR_blend_equation_advanced_coherent --gpu-vendor-id=0x10de --gpu-device-id=0x1c81 --gpu-driver-vendor=Nvidia --gpu-driver-version=375.39 --gpu-driver-date --lang=en_US.UTF-8 --log-file=/home/blimmer/.local/share/Steam/ubuntu12_64/debug.log --product-version=Valve Steam Client --se 83D13A24FDAF2865
blimmer   4628  0.0  0.0  10572  1596 pts/1    R+   19:55   0:00 grep --color=auto steam

(that’s the longer command switch line I’ve ever seen)

I can only remove the main steam process with kill -9, from KDE4 System Activity (CTRL+ESC) it won’t die…

Any ideas?

Thanks,

Bump!
Bump!

Hi
openSUSE 13.2

Dead!
Dead! :wink:

Did you try with just running the command ‘steam’ rather than using the runtime prefix?

I tried just one BUMP, but the forum won’t allow me to post something so short, thus the exclamation and repetition. Sorry if it seemed forceful. :shame:

I did run with and without prefixes form a terminal, but without any relevant info. I could go the route of debugging - it’s probably a library issue, but it could very well break again at the next steam update - it updates frequently.

About oS 13.2 - I’m gathering courage to upgrade, but perhaps to 15 (15.1?). This would give me some more time with this exquisitely configured, sublimely crafted install, that I’ll sorely miss… Or not.

I do have steam in a dualboot to play those w-only games, but most are my installed on openSUSE. Perhaps I can transfer them to windows without having to download and reinstall everything.

15.1 is about 16 months away

Hi
More than likely an ssl issue with 13.2… you could try copying data to say a usb device and linking to that on windows?

Perhaps look at creating an autoyast file?

Oops, of course I can’t copy anything - The majority of games are the linux version, they wouldn’t work on windows. Perhaps some data packs could be reused, but there’s no such granularity on steam downloads.