Steam won't install

So… So far so good regarding Leap 15, but I’ve just hit my first (and only) bump since installing it. I’ve installed Steam, but wouldn’t start at all. So when I tried to start it via Steam I get this:

Repairing installation, linking /home/ingvar/.steam/steam to /home/ingvar/.local/share/Steam
Running Steam on opensuse-leap 15.0 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
/home/ingvar/.local/share/Steam/ubuntu12_32/steam: symbol lookup error: /usr/lib/libxcb-dri3.so.0: undefined symbol: xcb_send_request_with_fds
/home/ingvar/.local/share/Steam/steam.sh: line 444: no match: ssfn*

And as usual. I don’t know what this means. But I am generally good at following suggestions.

What I did to get steam to work is I ran steam from a console with the following parameters: STEAM_RUNTIME=0 steam
This started steam, which began the update process, it failed, but I ran steam again and it launched.
If you have any further problems, you can try steamtricks or visit the steam wiki page. Steam - openSUSE Wiki

Thank you very much. That worked beautifully.