Steam: 'OpenGL GLX context is not using direct rendering'

Good day,

My steam starts up, but it opens a window with the following message:


'OpenGL GLX context is not using direct rendering, which may cause performance problems.

For more information visit https://support.steampowered.com/kb_article.php?ref=9938-EYZB-7457.'

I cannot say if this problem started when I updated steam to version 1.0.0.4.8 (games:tools repo) or Mesa to 10.2.1 (X11:Xorg repo), but now none of my steam games will start up.

I have followed steam’s troubleshooting guide, but it didn’t help:

1- not using a remote connection
2- changing the Mesa-demo-x package to 32-bit gives the same result as the x86_64 one:

> glxinfo
name of display: :0
libGL error: dlopen /usr/lib/dri/updates/r600_dri.so failed (/usr/lib/dri/updates/r600_dri.so: cannot open shared object file: No such file or directory)
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
    (...)
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
client glx extensions:
   (...)
GLX version: 1.4
GLX extensions:
    (...)
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD RV710
OpenGL core profile version string: 3.1 (Core Profile) Mesa 10.2.1
OpenGL core profile shading language version string: 1.40
OpenGL core profile context flags: (none)
OpenGL core profile extensions:
    (...)
OpenGL version string: 3.0 Mesa 10.2.1
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
(...)

Running ‘ldd /usr/bin/glxinfo’, both 32 and 64 bits: http://susepaste.org/28300832

Running ‘LIBGL_DEBUG=verbose steam’ and trying to start two games, ‘The Bridge’ and ‘Democracy 3’: http://susepaste.org/25348850

3- the user is a member of ‘video’

I’m using:

OpenSUSE 13.1, kernel 3.13.7-1.ga68bc7c-desktop (or 3.15.1-1.1.gee8dd2b-desktop, same result).

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV710/M92 [Mobility Radeon HD 4330/4350/4550] and the open-source radeon driver

Any clues? Maybe I just have to wait for X11:Xorg to get updated again?

Thank you.

Your problem seems to be this:

libGL error: dlopen /usr/lib/dri/r600_dri.so failed (/home/gaming/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1: version `GCC_4.7.0' not found (required by /usr/lib/dri/r600_dri.so))

Steam loads the libgcc_s.so.1 from its own directory, and that doesn’t provide the symbol GCC_4.7.0 required by the radeon driver (r600_dri.so).

Try to run steam like this, it should then use the system’s libgcc_s.so.1:

STEAM_RUNTIME=0 steam

Or try to remove/rename /home/gaming/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1 so it isn’t found.

3- the user is a member of ‘video’

This shouldn’t be necessary.

By the way, there is no libgcc_s.so.1 in ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/

I get the message:

You are missing the following 32-bit libraries, and Steam may not run:
libbz2.so.1.0

and the client refuses to open, although libbz2-1-32bit is installed.

That did it. A very simple solution. Many thanks!

openSUSE’s libbz2-1-32bit only contains those files:

# rpm -ql libbz2-1-32bit 
/usr/lib/libbz2.so.1
/usr/lib/libbz2.so.1.0.6

You could create a symlink /usr/lib/libbz2.so.1.0 that points to one of those.

That did it. A very simple solution. Many thanks!

Ok. Great! :slight_smile: