steam no sound AT ALL


ive been looking for days about this issue. All i could find is people reporting about not having sound on valve games.

but my issue is bigger. steam does not have any sound at all. no sound notifications when a new chat msg comes in etc.

i have tried this so far:

i have tried installing as suggested in other topics nspluginwrapper, alsa-plugins, gnome-media and pulseaudio.

and to add the lines (one per try…) to the usr/bin/steam file:

and if i add the line “SDL_AUDIODRIVER=[any sound service] steam” it makes my cpu go crazy and my pc unresponsive.

running 13.1 x64

thanks in advance

pulseaudio should be installed by default, and I don’t see why gnome-media or nspluginwrapper should be needed for sound in steam…

But check that you have alsa-plugins-pulse and alsa-plugins-pulse-32bit installed.

and to add the lines (one per try…) to the usr/bin/steam file:

and if i add the line “SDL_AUDIODRIVER=[any sound service] steam” it makes my cpu go crazy and my pc unresponsive.

By default pulseaudio is used, which blocks every other application from using the sound card directly, that’s why those things won’t work.
As written above, alsa-plugins-pulse and alsa-plugins-pulse-32bit should help with that as it redirects all applications to use pulseaudio instead of alsa directly.

You could also try to disable pulseaudio in YaST->Hardware->Sound. Click on “Other…” and select “PulseAudio Configuration” for that.
Does it work then after a reboot?

Starting steam with


works for me.

oS 12.3 64bit, -32 libs installed as per wolfi post.

Also, there’s a lengthy thread on sound in steam linux forum, take a look.

Some people report using RUNTIME=0 (or something similar) on startup works. I didn’t try, as the above post solved my problem.

well installing all that makes so it works but everytime i start up a game, i have to make sure i run before killall pulseaudio. otherwise no sound.

its somewhat inconvenient but i guess it comes with the territory (linux). hopefully this will be fixed in further updates.

Installing all what?
Please verify that you have alsa-plugins-pulse and alsa-plugins-pulse-32bit installed. It should work then with pulseaudio running.

And, again, if you disable PulseAudio in YaST->Hardware->Sound you also would not have to kill it since it would not be running anyway… :wink:


wont cause that other issues? i mean, doesnt everything uses pulseaudio? anyways, not a big deal. this was just for testing purposes. I find that, at least the games i tried (serious sam 3, painkiller hd, and l4d2) runs way better on my other windows computer. so no big deal if once in awhile i want to try out something i run that killall pulseaudio command.

thanks for the info and tips.

Not at all.
That’s why you need alsa-plugins-pulse (and alsa-plugins-pulse-32bit for 32bit programs on a 64bit system) to redirect all applications that use ALSA to pulseaudio instead.

Pulseaudio, when it is running, blocks all other programs from accessing the soundcard. That’s why program’s not using pulseaudio cannot output sound then.

Btw, I don’t even have pulseaudio installed here, and sound works fine. In every program I use.

interesting. ill give it a try.

thank you again.

On 01/19/2014 03:16 PM, docpariolo wrote:
> interesting. ill give it a try.
> thank you again.

If you still dont get it to work maybe you have to try

Was I helpful? Click that little star so that I can brag about it to my
invisible friends >:)
Bring the Penguins Back!

I’m facing this same issue. The sound works in same games including Valve titles, but usually I get no sound (The Swapper, Cat Lady, Amnesia, Papers, Please). I have ‘alsa-plugins-pulse’ and ‘alsa-plugins-pulse-32bit’ installed.

I still haven’t figured out how to solve all my sound issues, audio volume is much lower than on Windows and I only can listen modern “loudness war era” records on comfortable levels. Alsamixer is at 100, OS volume is at 100% in Audio Mixer and my sound card is HDA Intel PCH (Alsa Mixer). I want to output to my external DAC but I have no idea how that’s possible.
I’ve installed Pavucontrol, but that didn’t help much. I don’t know how important is to disable unused audio devices.

There is also a weird tendency to default the audio levels to 92% or 108% with applications and on the system level. I just noticed that my music player was playing at 92%, I don’t know why that happens >:(

Sorry, the default audio device was wrong, it’s USB Audio Codec. I confirmed in Yast.

You attached your problem at the end of another on, more then one and a half year old.

You may think it is similar, but it is not sure that it is exactly the same. The more so because openSUSE versions did not stay quite the same. Same for the other software versions.

Also, how many people do you think are still watching this old thread?

To get the maximum of exposure to your problem, please start a new thread in the Multiedia forum, with a good title, that has the keywords to draw the attention of people with knowledge about your problem area.

I will start new threads in the future.

Ill put here a fix, as some guys will end in this topic searching for a fix for the no sound issue in some games, I had it, and I had to google a lot, but I found the solution going to the forums of that specific game in steam, I suppose it will work with others as well, if someone can verify it it would be perfect, the fix is opening steam, go to the game in your library, right click on it, properties, and in launch options put this…

SDL_AUDIODRIVER=alsa %command%

In my case the game opens with no sound, but in 10 or 15 seconds sound comes, and you have perfect sound in game, hope it helps, Im using Leap 42.1.

export SGL_AUDIODRIVER=alsa worked for me.
Though apparently just when running the game directly. Doing so from within Steam did not have the desired effects.