Steam login not displaying text or accepting input

After a recent update to either wine or steam itself the login for steam broke. No text is displayed in the login screen and it won’t accept input in either the ID or password fields. Most of the login window is there, but the there is no text. I tried fixing then uninstalling steam. That didn’t work. I now have the same problem but with the account setup screen after I reinstalled. No text. Does anyone have an idea of what has gone wrong? I have done a rough search of winehq but with no success.

I know this is off topic but it does offer hope for the future: Linux | Valve

I’m sorry I can’t help you with your problem.

Although I don’t have a clue what might be the reason for your problem I would try to downgrade wine to the version in which steam was working. That would be the easiest test to isolate the problem.

Try adding -no-dwrite switch to your steam shortcut.

That solved the problem. Thank you very much.

Just a workaround, you can reproduce this bug by switching offline mode.
It’ll auto-restart and there will be no text again, until you manually start it with -no-dwrite.
wine 1.5.11 default