Steam Games not Launching

Ever since I updated my graphics card, some of my Steam games have not been able to launch. At first it was because when they were downloading, they didn’t create a folder in the /.steam/steam/steamapps/common directory where all games are located. When I imported files from my laptop however, the games still wouldn’t run. When I clicked play it said Running, Syncing, and then nothing would happen.

The games are:
Besiege
Goat Simulator
All Half - Life Games
Kerbal Space Program

I’m running OpenSUSE 13.2 with a Nvidia Geforce Gt 740. Weird thing is, back when I had a Geforce Gt 440, all the aforementioned games worked fine.

Not an expert.
But if you run Steam in a terminal, does it shows any errors?

Never thought of that. Quite a few things show up:

http://pastebin.com/PRpx7xr1

What could I do to resolve the errors?

Also, do you think it matters that I’m using a 42.1 version of Steam on 13.2? When I tried re-installing the 13.2 download of Steam on the repository was no longer active.

13.2 is no longer in support thus some repos may be unavaliable. And yes it may make a difference if you try 42.1

Uh… thanks, but still not helping. Could anyone interpret this error log when I run steam from the command line:

http://pastebin.com/PRpx7xr1

Hi
Not sure, but I would definitely see issues with trying to run an application compiled for later libraries not running…

FYI, I’m on 42.1 with Steam and a 8800GT card, works fine, also run on an AMD Mullins R5 card with openSUSE 42.2 and Tumbleweed, again Steam runs fine for the few test games I have.

Since all the repos are disappearing and support limited to non-existent, suggest you look at upgrading…