Steam games don't run


I’ve installed Steam on openSUSE 13.1 a few months back, but the games didn’t run, so I decided to wait and try it again in the next version.

(A bit offtopic, but when I tried to install the nvidia driver, it didn’t work. I was told on IRC to use Yast for installing drivers, but it thought I was using a 8000-9000 line, while I’m on the 300 line. Still, I was told to use what Yast suggested. It installed a driver different version number that I got from the nvidia homepage, but both works the same.)

So I’ve successfully installed it, and a few games (CS 1.6, Dota2), but when I want to start them, the immediatly stop at the first screen without error message. I found an idea to start it with STEAM_RUNTIME=0 command, but when I did it, it gave lots of error messages, including about 10 missing libs. I managed to install all of them, except one: This one cannot be found. So at this point, I’m stuck. I’ve already upgraded to 13.2 (except the Grub, that couldn’t be updated for some reason, but that’s hardly causing the problem).

Also, while poking around the internet, I saw that people giving advices on which desktop do they use, and most were for GNOME or KDE. While I doubt it causes any problem (I think the DE has nothing to do with the games…), I’m using LXDE, and there are no guides for that.

I would appretiate any help.

EDIT: I tried a non Steam game, Battle for Wesnoth, and it seems it works just fine. Only the resolution is incorrect.

Very confusing post. Did you or did you not successfully install the correct NVIDIA driver?? Give the exact model of the graphics and which driver you installed.

I don’t run steam so can’t help there, sorry But I do know you first have to have the correct NVIDIA driver installed and working if you use NVIDIA graphics.

Not quite. I have a GT 320M, and I downloaded the driver for it from the nvidia homepage. However, I was unable to install it, even with terminal, so when I asked on the IRC, they told me to use Yast, and don’t do it manually. The Yast said I need the “8 and later” driver. After some inquiry, I was told to beleive Yast.

But as I mentioned earlier, other games do work. Not just Valve games, even EU4 refuses to start from Steam.


Not related to your question but i think you should be aware of this bug.

Just saying :wink:

ok You should not install one NVIDA over another NVIDIA driver. There is a command line option I believe is ti call the installer program with --uninstall perameter.

It has been a while since I did a hard way install so I might not hve that right . There should be a rename file though or instruction on the NVIDIA site.

But that is too late now.

SO what files did you actually install??

rpm -qa | egrep "nvidia|kernel"

I did not install manually, because it did not run because X was running. So I installed nothing, Yast did.

However, I just checked the nvidia page again, to check what cards does this driver support, and it also supports my 320M. I guess it’s right afterall?

Linux x64 (AMD64/EM64T) Display Driver
Version: 340.65
Supported products
GeForce GTS 360M, GeForce GTS 350M, GeForce GT 335M, GeForce GT 330M, GeForce GT 325M, GeForce GT 320M, GeForce 320M, GeForce 315M, GeForce 310M, GeForce 305M

Any news about this one?


I started to run some other experimets. I wanted to know, if Steam works under WINE. It doesn’t, and it’s worse, it doesn’t show any letters. And the games still don’t run.

But I also tried a Windows version of Warzone 2100. And this game works under WINE. But some others don’t, because give error message “not properly installed”, or “could not find graphic files” errors. As a matter of fact, there are some that are natively running on openSUSE, and some that not, there are some which running on WINE, and some are not. Cool, ain’t it?

And this is a surprise because???

I don’t run Steam but others have gotten it to run under openSUSE. To be honest Steam is developed more for a Debian (Ubuntu) environment. But it is just Linux so should run ok on openSUSE with perhaps some tweaking. There are several thread here that end in happy game players you should investigate those may give a clue on what you are doing wrong.

Steam works on OpenSUSE and it doesn’t even need any tweaking in my experience. You can install it from or through YaST/zypper from games:tools repo.

Steam also works in Wine, there might be some differences in versions like always with Wine, but in general it works. There is a fix for “no text”:

If you wish to play games in Wine with or without Steam, I recommend using (also available from games:tools). PlayOnLinux allows you to easily manage different Wine prefixes (or “virtual drives”) and different Wine versions.

Finally, about the graphics issue, unfortunately it might be because your graphics chip is a mobile/laptop chip. Those are always more problematic, gaming-wise.

I wanted to play natively on SUSE, I just tried WINE for trying if games work normally at all (they are worse). For installation I followed the steps that was on this website. The Steam itself was installed perfectly, and everything works (webshop, inventory, workshop, etc.), except the games themselves. I’ve scoured for more information, and there were some infos about it being solved under GNOME and KDE differently, however, I use LXDE. Also I was told to switch runtime, but I need the lib I mentioned in the first post for 32-bit, and I couldn’t find it in any repo.

Finally, about the graphics issue, unfortunately it might be because your graphics chip is a mobile/laptop chip. Those are always more problematic, gaming-wise.

Ah, that might be the crux of the problem. Everything works fine under Windows at the moment, but there were indeed problems with this for earlier laptops. (Although, it would be stupid to put a strong video card into a laptop if it couldn’t be used for gaming. xD )

Okay now I get it.
I doubt the “runtime switching” will help. The Steam runtime is a bunch of libraries that are installed with Steam. The games distributed through Steam are built against the Steam runtime and they will use those libraries and not the system’s default libraries. STEAM_RUNTIME=0 probably disables the usage of the Steam runtime, and the game executable then tries to find the system’s default libraries instead.

I think none of that stuff is really necessary…

You mentioned EU4 doesn’t work. I know that game can be launched without Steam. Use terminal to navigate to the installation directory of EU4 and launch it from there. Something like this:

cd ~/.local/share/Steam/steamapps/common/Europa\ Universalis\ 4/

And let us know the error you get (copy/paste).

[S_API FAIL] SteamAPI_Init() failed; no appID found.
Either launch the game from Steam, or put the file steam_appid.txt containing the correct appID in your game folder.

It was the error message it gave 6 times. However, the game worked perfectly (with a bit low framerate, but not unplayable). I guess that means I should go to the Steam forums instead.

Thanks for the help!

You’re welcome. Some games like EU4 can be launched without the Steam client running, but majority unfortunately are protected by Steam DRM and thus cannot be launched without the client running. You could try to troubleshoot the other games with the same method - starting them from the terminal and see the output (they should all be in the same ~/.local/share/Steam/steamapps/common/ directory). If the game doesn’t start and complains about the Steam client, start it and try again. Then there are also games that cannot be launched like that at all, but only through the Steam client.

Just found on the Steam support page, that Steam supports only Ubuntu. I might’ve been confused, since Steam can be installed on SUSE. The whole thing started when someone in Dota2 mentioned that he is testing the game under Linux, and one other said he has been playing on openSUSE for a while now, and I thought it could work on mine too. Well, I guess I will be gaming on Windows for now.

Thanks anyway!

It is only officially supported on Ubuntu - but it works on OpenSUSE too. OpenSUSE itself isn’t the problem here.
I don’t play DOTA myself but other games with and without Steam.

I suspect there’s problems with the graphics chip you’re using or some driver issue, but it’s impossible to say without further info.

Yes wast graphics do you have and what drivers are you using this would possible account for low frame rates

Umm, I already wrote those, didn’t I? Geforce GT320M with nVidia 340.65-32.1.x86_64 for Geforece 8 or later.

Sorry forgot I read a bunch of threads sometime they get mixed up :shame:

On Mon, 26 Jan 2015 12:46:02 +0000, Kry wrote:

> I wanted to play natively on SUSE, I just tried WINE for trying if games
> work normally at all (they are worse).

That is highly dependent on the game in question. I remember playing
Neverwinter Nights under WINE and actually getting better performance
overall than on Windows (identical hardware in both cases - I had laptops
for a lab that weren’t occupied with anything at the moment, so I put
Windows XP on one and openSUSE on the other and tried both - the Linux
performance blew away the Windows performance easily).

When it comes to WINE - remember it’s not a Windows Emulator - it’s an
implementation of some (a large portion, but not all of it) of the
Windows APIs.

That means that whether software works with it or not depends entirely on
the software you’re trying to run. For example, anything that depends
on MAPI absolutely will not run.


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at