Steam for Linux

Anyone tried Steam for Linux on 12.3? I was about to install it, but then took a look at the list of 32bit libraries it needed and aborted. How is the performance and stability of this linux port?

> How is the performance and stability of this linux port?

why not ask a mod to move your question to the games forum…


While Steam is a gaming application, it is also an application. Posting here is just as applicable as in the Gaming forum. Posting to the OP that he should post in another forum is not helping to answer his question.

I am running steam since it went public beta.

If you have an nvidia car, you prob will have more fps then on windows.

If you have an amd card, like me, amd has stll allot of work to do on their openGL Linux/ windows driver.

Because I could not edit my post any more. 12.3 64 bit

First I wanted to put this thread in the gaming section, but I thought this was more of a application post than a gaming post. If the general consensus is that Steam belongs in the Gaming section perhaps it should be mentioned within the (native, Wine hosted, online). As it stands now it looks like its more for games specifically.

Does your installation of Steam has 32bit library dependencies? I try to minimize my usage of such libraries. To me it seems a bit redundant to have libraries in both 32bit and 64bit.
Think I will try install Steam anyway. Though my favorite game Civilization has not been ported to Linux, I keep a hope up for it. Seems there is a bit of interest for this Civ 5 linux edition - sign petition :: Sid Meier’s Civilization V General Discussions
I have been running Civ5 with Steam on Windows fairly well.

I have NVidia graphic card: ASUS GeForce GTX 650Ti 1GB PhysX CUDA PCI-Express 3.0, “DirectCU II OC”
Anyway running on a fairly old and “slow” CPU (Intel Core 2 Duo 2.8GHz). Didn’t build my system to gaming specifications.

I have steam up and running. It works fine on my system. (ASUS P8Z77-V deluxe, GT680 w/latest nvidia driver, i7-3770, etc.) I did have an issue where games were coming up with a black screen when trying to play them.

If you get this issue, go to the** Steam** > Settings >In -game tab and un-check the “Enable steam community in-game” setting. Click OK and everything should work properly. I’m not sure what the issue is, but this seems to be the common fix for the black screen issue in game. (My understanding this is a steam issue, and affects multiple, if not all, Linux distros),

The deciding factor here IMHO is where you think you have the best chance to introduce your problem/question to those people who know something about your subject. The staff (and some others) when seeing a thread started in a forum where they think not many people can help, will point the OP there to the fact that publishing somewhere else might be more efficient in getting the problem solved and offer to move it.

In some obvious cases (like posting a question in a sub-forum where it says in a big font at the top that that sub-forum is not to be used for asking questions), the staff will decide to move out of it’s own decission.

So it is up to you where to post and to ask it to be moved when you decide later that it would been better in another sub-forum. But we would appreciate when asking for moving threads would be kept at a minimum by starting a thread in the best forum in the first place.

But please do not double post, we realy hate that :wink:

Yes, I have allot of 32 bit libs installed,

The only solution I can think of, install a 32 bit openSUSE, but that might bring other issues.

The best place to ask for help on steam is in the gaming forum.
Nobody except gamers use steam.

And because of the amount of topics, on the openSUSE forum, I doubt most users will read all posts.