static IP address settings become reset after restart

I have SuSE 11.1 linux desktop PC. If I try to see IP address using “ifconfig” at root console, it is not giving any IP address So I manually given Static IP settings.
If I restart my system then IP settings got disappeared, I need to set again using “ifconfig”.

Can anyone tell what options should be enabled and where it will be to get the same IP configurations ?

Also my network services(xinetd) behaving the same way.
Pls help on this also.



Why do you not configure your IP address using YaST > Network > Network devices?

It should be set to “traditionaly with ifup” and “do not use DHCP” (or similar wording). And of course fill in your IP address, netmask and default router at the appropriate places.

I have done this way at first by setting static IP , netmask, DNS servers and default gateway then when restarted I noticed there is no IP address set if I check with “ifconfig”. So then onwards whenever I start the system first I will set IP and deafualt gateway using console then I will work.

Pls let me know if I missed anything in doing configuration.

Not the solution you have asked for but perhaps still a solution is to check if your router (if you’re using one) supports assigning IP Addresses based on the MacAddress.

I use this to avoid having to reboot to set the ip address upon reinstall. (The Macaddress can be seen with the ifconfig command, but since you already used said command I assume you are aware of that ;))

I have successfully mannually assigned it a static value in the passed with YaST Network Settings.

PS: You are running ifconfig with rootrights? Wont show you anything if not.
Used the following command if you’re not sure. sudo /sbin/ifconfig

YaST not only sets the parameters on the fllight, but it also saves them for future (boot) use. This done in /etc/sysconfig/network/ifcgf-eth0 (for eth0, similar for other NICs).

Check there. Mine is e.g.:

boven:/etc/sysconfig/network # cat ifcfg-eth0
NAME='Hewlett-Packard Company 82801G (ICH7 Family) LAN Controller'
boven:/etc/sysconfig/network # 

Your STARTMODE could be wrong. You can edit these manualy to test, but first make a backup of the file!

In my system
linux-487l:/etc/sysconfig/network # cat ifcfg-eth0
NAME=‘PRO/100 VE Network Connection’
linux-487l:/etc/sysconfig/network #

Well, your STARTMODE=off! so nothing happens on boot.

Either change this with an editor, or look into YaST > etc., it is somewhere in the configuration window of YaST (like: on cable connection, on boot, …).

I also am amazed aboout the parameter BROADCAST not being filled in.

Edit: is realy the IP address you want to use and 172.16.. your network?

Hi hcw,
Able to retain the static IP even after restart if I change STARTMODE=“onboot”

Thanks for support and help.:slight_smile:

You are welcome.