StartX error after installing AMD

After I have installed AMD DRivers flgrx, startx gives me the following error: xf86OpenConsole: VT_ACTIVATE failed: Operation not permitted
​any idea?

How did you install fglrx?
What openSUSE version are you using?

Try to run startx as root, does it work then? It’s not supported to run it as user (or actually at all) since years.
Can you switch to graphics mode with “init 5”?

If that doesn’t help, please post your /var/log/Xorg.0.log.

I have Thunderbleem KDE, with sudo startx , startx start in a minimalist enviroment. With int 5 it stucks with only the background photo . I installed through yast2

On 2015-06-13 21:46, zinc7 wrote:
> I have Thunderbleem KDE,


Then you have to ask a moderator to move your post to the tumbleweed
forum. use the triangle button below.

Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

W ill be moved to Tumbleweed and is CLOSED for the moment.

Moved from Hardware and open again.

the log file has this error (after changed the perimitions.local): glx error cannot get required symbols

else is there any way to dissable discrete graphics? I have overheating problems and amd drivers are only way to fix it

Of course it does. But is it working now? You wrote it gives you an error message.

You can set the WINDOWMANAGER environment variable to start another desktop environment. E.g. this would give you a KDE session:

WINDOWMANAGER=startkde startx


WINDOWMANAGER=gnome startx

Can you please post the exact error message? Or better the whole file?

This sounds like incompatible packages.

So please post your repo list too, and what fglrx packages you installed:

zypper lr -d
rpm -qa | grep fglrx

So you are using hybrid graphics?

AFAIK the discrete graphics shouldn’t even get activated if you don’t use it.
But have a look at the BIOS settings, you might be able to disable it there.

I have now reformated the pc,now I want only to disable discrete graphics because of heat and battery issue. No bios options. Any suggest? I have ati 7600M

On 2015-06-18 13:16, zinc7 wrote:
> I have now reformated the pc,

And what release do you have now?

Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)