Startx does not run automatically on login - In order to login I need to run it via tty manually

After an upgrade this week I can’t start plasma unless I login via TTY and manually startx. If I try to login normally it loops back to the login screen.

I have nvidia, but I tried to install bumblebee, bbswitch, drivers etc and the problem was not solved. This problem started after a bbswich + bumblebee upgrade. Trying to rollback using snapshot doesn’t work. This indicates that some config file in my /home (which is not btrfs) changed.

Also, after startx, I need to export display=:1.

If you have a login screen, then X has probably started (else you wouldn’t have a graphical page of any sort, at least I would think). Trying to start another instance of X probably wouldn’t work (obviously, I could be wrong about that) and is probably why you have to export that display to :1.
As for your installing bumblebee, do you actually have hardware that needs bumblebee? Does your hardware actually have two graphics systems? Others who are much more knowledgeable will have to chime in at this point.

I am having the same issue on a TW downloaded DVD ISO and install from 20.08.2019. Installed KDE desktop option,

I have an AMD RX 5700TX graphics card. The install went smooth in GUI only, then on boot i only get CLI login. After logging in to CLI as root I am able to do “startx” and i get a GUI running, if I try with my non-root user “startx” fails complaining about rights.

What I would try, since this sounds like something that happened to me, is open YaST2 -> Security & Users -> User & Group Management, make any kind of change to any regular user, then save/exit. I think this might straighten out a pam problem causing the login failure.

startx -- :1

will avoid the need to separately export :1.

Non-root user rights usually can be worked around by

sudo chmod 4711 /usr/bin/Xorg

which is not recommended due to security risk it creates.