Starting VNC server

I have been using tigerVNC for years in order to log into
other linux computers on our LAN. Never any problem.

Now, I installed openSUSE 42.2 on a new computer.
When starting the VNC server as follows:

/usr/bin/vncserver :1 &

I get this response:

You will require a password to access your desktops.
getpassword error: Inappropriate ioctl for device

What Password am I supposed ot provide? The system has
never asked me to specify a password for this purpose, and
neither the normal log-in password, nor the root password
is accepted.

There exists a directory /etc/vnc, which may be a
configuration directory for VNC, but the same is empty.
There is also a .vnc directory in my home directory, which
contains the file ‘default.tigervnc’. Appears to be a
configuration file, but there is no hint about a password
in this configuration file.

Can anybody give me a hint about what I can do in order to
get this to work? Any help will be highly appreciated.
Thanks in anticipation.

See vncpasswd. This is password that you need to enter in VNC viewer when connecting to VNC server. You set this password to whatever you like. I wonder how you managed to not setting it in the past - it was always necessary for as long as I remember.

Hello there!

I have for many years started vncserver (root as user) with:

 vncserver -geometry 1150x870

(the geometry part above is only what resolution I want).

And if this is the first time on the computer it always ask for a password and also ask if I want to configure a view only password as well. I did it twice on 2 newly fresh installed 42.2 servers less then one month ago.

The configuration ends up in this case in /root/.vnc contains the files (config,,, passwd, *xlstartup).

I dont know if you went any wiser but maybe you are on the right track that a .vnc should show up in the user:catalog with those files.


You should take a look at how VNC server is set up on openSUSE which is different than how you know it (and openSUSE is not alone).

Read the openSUSE community documentation on VNC at the following link, it’s pretty good and covers just about everything you should know

Some things you should note that is described in the documentation…

  • Use the YAST Remote Admin (VNC) applet to install. You can also use the applet to do some rudimentary management like enabling start on boot. An important thing the YAST applet does today that won’t happen if you install only a VNC package is to also install an X server for your remote connections.
  • Nowadays, you don’t specify the display or screen resolution in the client when you connect. Instead, VNC server pre-configures these parameters and assigns each client configuration to a different port. So now, when you connect using a VNC client you only need to specify a different port for a different client configuration.


No I dont but I didn’t write it out, attach a full filelist on my /.vnc contents. I (as not above) never ask for a port specifik. It change.

total 116
-rw-r–r-- 1 root root 332 18 dec 11.06 config
-rw-r–r-- 1 root root 61949 21 dec 15.39 ghost:2.log
-rw-r–r-- 1 root root 5 21 dec 14.23
-rw-r–r-- 1 root root 16685 22 dec 15.42 ghost:3.log
-rw-r–r-- 1 root root 5 21 dec 15.41
-rw-r–r-- 1 root root 10820 21 dec 15.43 ghost:4.log
-rw------- 1 root root 8 18 dec 11.06 passwd
-rwxr-xr-x 1 root root 639 18 dec 11.06 xstartup

On the other hand port (5801) that should repond by webbrowser gives me:

42.2 (on server end) and KDE suffer of problems in the client end… VNC by the cli works fine but on krdc or remina…


Did a test install, and everything worked out fine.
Am not able to replicate your issue, so it’s likely you’re not installing your VNC server correctly.

Here are some screenshots…

When you install VNC using the YAST > Remote Administration module,

You should see the following screen. Select the radio buttons as shown

When you click “OK” in the above screen, your install should proceed and you will be prompted to install xorg-x11 and vnc manager as shown below. Click the “Install” button to install these new components

When your new components for vnc server have been installed, you should see the following screenshot which instructs you to either log out and back in or reboot so that changes to your Display Manager can take effect

Once you’ve logged out and back in or rebooted, you can check to make sure your VNC Server service has started and is running without a problem as shown below

If you wish, you can also optionally inspect which VNC client configurations are active and available on which ports in the screenshot below. You can edit the file to enable any that are disabled or create your own by copying any of the configurations and modifying. This forum software won’t allow me to embed the image, but you can view a screenshot of the config file at

I tested connecting to this VNC Server running on a 42.2 from a TW machine.

Interestingly, the vncviewer didn’t automatically connect to a default connection without defining a display. Also, because the VNC server created a self-signed certificate using the machine name and I connected using the Server’s IP address, I had to authorize over-riding certificate mis-matches


I also did a successful test using a Firefox web browser and the VNC java applet, because the Iced Tea plugin had to be activated and authorized plus I was connecting using an IP address instead of the machine name, I had to restart the browser at least twice, create a certificate exception and manually authorized over-riding security checks numerous times (maybe 8?) before I was able to successfully connect

Again, it all starts with installing VNC server correctly.
You can either install using the YAST Remote Administration module or manually install what is needed, but YAST is the only way I know of that will ensure a success with minimal chances of mistakes.
Note that you can always re-run the YAST Remote Administration module to turn off your VNC server (Select the “Do not allow…” radio button) and change whether session management should be supported or not.


… and decent instructions. Well done, tsu.:good:

Thank you for letting me know what I am using for the last 10+ years on SUSE does not exist.

What your are referring to appears to be the login password when connection to a VNC server. With this I have no problem, have always specified and used it.
The problem is: When I start the VNC server on the computer where I want to log into, then it asks for a password. This was never before, and it is not now on some of our machines. The personal login-password is not recognized, nor is the root password.

From your description, it appears as if you are referring to the login-password that must be specified when login in onto the VNC server.
With this I have no problem, in fact I have been using it for years.
This problem is different: When I start up the VNC server on the computer that I want to log into with the command “/usr/bin/vncserver :1 &”, then it asks for a password. Prior to SUSE 42.2, I have never encountered this. The personal login password does not work, nor does the root password. I am at a loss as to what to do about this.
Regards Egbert

Invoke vncserver without the flags.
You will then be prompted to enter a VNC password

# vncserver

You will require a password to access your desktops.