Starting Virtualization as newbie basic checks with network conection VM from here!

It has been a year since I tried and failed to work with VM so am starting over. My test machine is a Leap 15.4 OS with KDE desktop.
For the network connections I am using wicked and have a static IP on the on-board nic. For a second network connection I am using an USB dongle which is plugged into the same sub-net but with DHCP not static IP.
I have created a bridge connection and before I get any further would appreciate confirmation please that my network connections are OK. Here is what I have so far:-

alastair@HP-Z640-1:~> sudo wicked show br0
[sudo] password for root: 
br0             up
      link:     #4, state up, mtu 1500
      type:     bridge, hwaddr 7c:c2:c6:33:10:d0
      config:   compat:suse:/etc/sysconfig/network/ifcfg-br0
      leases:   ipv4 dhcp granted
      leases:   ipv6 dhcp requesting
      addr:     ipv4 [dhcp]
alastair@HP-Z640-1:~> sudo wicked show-config br0
<interface origin="compat:suse:/etc/sysconfig/network/ifcfg-br0">

I should add that eth0 has static IP of

I wish to have a VM using Win 10 and I have DVD with license key. I shall need help here as I have made several attempts and failed. I suspect a several incomplete attempts are lurking which will need to be cleaned out in due course.

@Budgie2 In YaST Networking, just go there and delete the USB dongle DHCP connection. Then press add, type bridge and then on the adapter page, add the usb dongle and save.

Then in your guest operating system you can set it to either dhcp or static ip as required. There is nothing from and ip address etc to do on the host system.

Next question: storage space for VMs.
I have half of a hard drive not in use. At present it is formatted with XFS and mounted at /srv. If I am to use this drive space for VM storage, where should I mount it?

@Budgie2 in virt-manager you click on the add hardware and then Storage and add the partition to the created virtual machine.

Hi Malcolm,
I am not having any success with this. The installation appears to run but then nothing. Virt Manager shows the system running but I am not seeing what I expected? When I stop the machine I get an error:-

Error shutting down domain: Requested operation is not valid: domain is not running

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/", line 72, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/", line 108, in tmpcb
    callback(*args, **kwargs)
  File "/usr/share/virt-manager/virtManager/object/", line 57, in newfn
    ret = fn(self, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/object/", line 1380, in shutdown
  File "/usr/lib64/python3.6/site-packages/", line 2923, in shutdown
    raise libvirtError('virDomainShutdown() failed')
libvirt.libvirtError: Requested operation is not valid: domain is not running

What and why?

@Budgie2 As in here?

Yes I have reached this point but I want to know where to mount the partition I have. At present it is formatted as XFS but where should I mount it.

Going back a few steps I thought I could just allow the space to be created within my system as a virtual device as I have plenty of spare room but this didn’t work either so perhaps I should forget the hard drive for now and just get it working!

@Budgie2 you add it to the virtual machine, then power on the guest and it will show up there and mount it as required.

I have the guest running but not responding at all. Will start over but I am missing something in the initial configuration I think.

Could it be I am selecting the wrong Firmware. I have selected UEFI x86_64:/usr/share/qemu/ovmf-x86_64-opensuse-code.bin. Is this right?

In order to get a window with a Windows start screen I had to download a VirtIO Drivers iso from another site and then I was able to advance but:-

How do I get to a full sized max resolution screen? All I have is a very low resolution screen in a fraction of the screen being used; rather like watching and old video on a wide screen. My normal screen is 2560 x 1440 using the whole screen.

Why are the VirtIO drivers apparently not being used. I had assumed these would have been selected in step 2 of the machine creation process but couldn’t get a gui screen until I downloaded the drivers.

Seems my coronation will be a dunces hat!!!

@Budgie2 the firmware I’m using for Windows 10 and 11 is ‘ovmf-x86_64-smm-ms-code’ and tpm 2.0.

Shutdown the virtual machine and under the video settings select the Model to be ‘Virtio’, you need to have the virtio cd still present on the system eg virtio-win-0.1.229.iso.

Boot the system, then open windows device manager and select the ‘Display Adaptors’, Highlight the microsoft one, right-click and update driver.

Then you want to browse my computer, select the cdrom (eg D:) and ensure the check ‘Include subfolders’ box is check and hit next. It should add the ‘Red Hat VirtIO GPU DOD controller’ and should then be able to select display resolution as required.

Screenshot from 2023-05-06 08-57-14

Hi Malcolm,
I deleted windows and started over with a VM of Tumbleweed. Went like a dream with no problems at all.

I have no idea why I was having so much trouble with windows. I had lost faith but now morale restored by Tumbleweed.

Shame I have to get windows working for work tasks but on an IBM server. I don’t need it on this HP_Z640 as I have dual boot if needed but your details on how to get windows working will be required when I have the will to try again!!!
Many thanks again for putting up with my struggles.

Hi Malcolm,
All good except for the Red Hat VirtIO GPU DOD controller. Not here yet. I cannot get a download of the Virtio drivers from Red Hat. My Red Hat log-in doesn’t work so I found another version, I suspect from Fedora. The VM is working fine but the Windows Display Driver is a basic Windows driver. I assume the Red Hat GPU controller is included in the VirtIO driver.
Please can you give me a link so I can complete the installation.

@Budgie2 The iso image you need is here;
Grab the image called virtio-win-0.1.229.iso and add that to your vm

Hi Malcolm,
Found it yesterday and I have been able to set up Win 10 and Win 11 VM on both IBM server and HP Z640. I shall avoid Win 11 as it requires registration with M$ whereas using a product key with Win 10 can be less intrusive.
Many thanks for the help especially with the display. Took me a while to figure it out even with your screenshot.

I do have one new problem. I was enjoying my full higher resolution screen and at had the screen freeze. No mouse so no way to switch back to windowed view and restart the VM.
Because I couldn’t move mouse I was stuck.
Is there a magic key sequence that will work? I tried alt-tab and many others but nothing worked. Had to use the power switch!!!

@Budgie2 To create an offline account (I’m assuming these a Home versions?), when it gets to the Create an Account, just disconnect the network, press the back button and then go forward again, may take a few times before it gives up and lets you create a local/offline account.

In the top center of the screen slowly move the mouse cursor up and the dropdown appears to get out of full screen mode.

Screenshot from 2023-05-08 06-45-35

Hi Malcolm,
On the one occasion I had no control at all and had to use the hard switch. Since then it has all been great and working as hoped. If I have no other problems I shall put the system into work environment next week.

1 Like