starting udev hangs

So I am trying to install opensuse 11.2 on my laptop. I know it is not the DVD because I used it to install on my desktop, which worked just fine. When I am initialing booting to the installer of 11.2 start udev hangs. Eventually it gets past it and recommends using broken_modules. The installation will continue up to the partitioning of ext4 then it just dies. An installation error has occured or something of that nature. Might have something to do with this? -> Doesnt support DPO or LUA - openSUSE Forums

Have you tried a text mode install or the live cd?

No I have not tried a text install, nor do I know how. And I was using Live KDE cds before 11.2 came out. And the last two KDE 4.3.2 & 4.3.3 didnt work due to the error that I linked to. So I doubt the live cd would help.

Like this at boot menu press F3](

You could also try typing these in the boot argument (any combination, one or all of them)

edd=off acpi=off noapic

Just started both options. Tried using the text mode, udev hangs and tried using those boot options. udev still hangs. Any ideas?

Yes. I´d like you to check the installation medium with the integrated check routine. It´s not very uncommon that the DVD just plays along nicely with one computer and on another installs corrupted files. Although one has the option to skip the checking process I´d recommend everyone to take the time and be patient to run it prior to posting any bootup problems. GOOD LUCK!

Just ran a medium check and no errors were found… great
So I have no idea whats wrong.

If you really don´t know what to do, you could try the install via Live-CD.
OpenSUSE will then load required files itself based on dependencies as you add programs and repositories. All ways lead to Rome. :wink:

All right I will try it. But the last live cd I used (from here: “KDE Four Live” CD]( wouldnt boot and lead to this error: Doesnt support DPO or LUA - openSUSE Forums And that was never fixed. I feel like weird stuff always happens to me.

Just tried a live cd. Starting udev hangs. Ultimately the live cd wont boot. In fact it broke my Windows 7 install. Is there any distribution that doesnt use udev?

If it’s still actual:
I had the same problem on my HP ProBook laptop - SUSE 11.2 was getting stuck on “Starting udev…” when I was trying to install or check media or do anything else.
I have an option in laptop’s BIOS - FAN always ON while on power from AC - I turned it off and it worked

Hash: SHA1

Change the kernel to the default version instead of the desktop, to boot
the system, force the root shell from grub and then retire the x
permission to udev script

No in elenath hîlar nan hâd gîn
Version: GnuPG v2.0.12 (GNU/Linux)
Comment: Using GnuPG with SUSE -


I had the same problem with my laptop and solved it as described below:

  • First install openSUSE v11.1 via DVD.
  • After the installation, configure network installation for v11.2.
  • After booting (I didn’t have “udev problem” anymore!) switch installation medium to DVD and continue the installation.

Hope it helps…

As long time Linux user (Slackare 2.0) and SUSE user since v8 it is disappointing to have the same problem (hangs at starting udev) trying to install OpenSUSE 11.2 on to a Toshiba Satellite laptop with both the DVD and Live-CD. It is especially disappointing since I’ve flawlessly installed and run OpenSUSE on Toshiba Satellites since v10.

Does anyone know what the actual problem is with the install? I’d like to continue to use and recommend OpenSUSE but the broken install makes that difficult.


Had the same problem. did hard reboot nothing changed. unpluged my usb mouse and tried hard reboot and it worked. must have smiled that time;)

When installing 11.3 via DVD on a small PC104 it always stopped at udev. On the grub menu I changed the kernel version to safe settings and everything worked great.