Starting services

I’m new to OpenSUSE, but I’m not so new to Linux. One of the things I’ve learned is that each distro has their own ways of doing things, but many also stay the same.

I just installed the LAMP server on my system then rebooted, expecting the daemons HTTPD, MYSQLD, FTPD, etc. to start. When they didn’t, I didn’t panic I just attempted to run “sudo service start httpd”. Surprise, suprise - “command not found” :o:O.

OK, Folks how do I start these daemons??

Open YaST and search “runlevel editor” or read “man chkconfig”.

I don’t have a “runlevel editor” on my YaST screen. I do, however, have “systemservices editor”. Not sure if that’s the same thing but it seems to be. I found the MYSQLD entry and ecnabled it but neither httpd nor ftpd showed up.

Just to add insult to injury, when I logon items on my task panel have disappeared. Including the network icon, the date/time and the windows selector and items I put there like firefox and thunderbird.

Another thing that happens, when I minimize something I’m working on it just disappears too. Rather aggravating when you want to go back to what your doing.

Thanks for your help. I didn’t realize how different SUSE is from the other distros I’ve used.

Jim

There certainly is an editor for services and runlevels, maybe name has changed slightly in 11.2, but it will be easy to find.

On CLI you can use chkconfig (or insserv) which is also used by other distros (RH/Fedora IIRC) read the manual page for chkconfig or insserv, then you don’t even need YaST.

As every other distro, openSUSE uses start/stop-scripts, there is no real difference.

  • Quick & temporary: sudo /etc/init.d/apache2 start (or status or restart or stop)
  • Permanent by CLI: see Akoellh post
  • Permanent by GUI: Yast → System → System Services Runlevels → list where you can click enable/disable for default runlevel settings --or-- use “Expert” for non-default runlevel settings.

Swerdna - Thank You!!! :slight_smile:

Now, can you help with the rest of the problems I’m having.

Such programs as Banshee and Skype continue to run even after you close their main windows and put an icon on the right panel (task panel?). Additionally, there are other icons such as the network indicator there too.

For some reason after I did the system updates those icons have disappeared so I can not, for instance, access Banshee to change the play list or if I decide I want to make a Skype call I have to keep their respective window open or, at best, minimized.

Any idea where these icon or panel may have gotten off to?

You need to add a system tray widget.

press right mouse button unlock widgets

click the cashew on the panel. Select add widget and add a System tray widget. You may need to log out back in to get all back.

Sounds like Gnome. I don’t have Gnome installed ATM. But I recall I used to do this a lot: find the icon in the Gnome menu of “more applications” and just drag it to the panel and it would stay there permanently.

Not sure if that’s what you need. If not, start another thread so it can be seen by the Gnome experts.

Thanks again. I’ll do that…

Hi
Right click on the panel, add to panel. scroll down the list and add
‘Notification Area’.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.45-0.1-default
up 7 days 2:30, 3 users, load average: 0.10, 0.33, 0.26
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.53

Malcomlewis – Again, thanks for the quick and useful answer.

Gogalthorp - I tried right clicking on the panels and on the desktop. I couldn’t find anything like you described.

Jim

My answer was for KDE Gnome is different