starting from a "server (text mode)" install

Here’s my build starting from a Leap 42.3 net installer.

During installation:
Choose “Server (text mode)”.
Disable “use this password for system administrator” and “automatic login”.
Enable the firewall.

Get X:
zypper in -t pattern x11

Get a display manager:
zypper in lightdm

Get a window manager:
zypper in openbox

Get sound:
zypper in pulseaudio

Patch packages:
zypper patch

To load a graphical interface run ‘lightdm’ as root.

Set the system to load lightdm automatically:
YaST › System › Services Manager and set the Default System Target to Graphical Interface.

I’ve since added:
zypper in --no-recommends -t pattern xfce
zypper in xfce4-terminal mousepad xfce4-panel-plugin-pulseaudio
zypper in chromium

Pulseaudio can be started by:
pulseaudio --start
pulseaudio-module-x11 (I assume)

Please let me know if I’ve missed something fundamental. ;-]

Problems with restart and shutdown via the xfce menu were solved by adding
exec dbus-launch --exit-with-session startxfce4
to my ~/.xinitrc

Adding a graphical Desktop to a text-only “Server” system can be an adventure.

I don’t have the name of the pattern off the top of my head, but it’s a unique collection of packages which have to be uninstalled manually because some of those packages block the proper operation of a graphical Desktop.

My advice generally is…
If you don’t have security concerns, install the “MinimalX” configuration, ie with x-window system in the initial install. That should prevent that special text-mode server install from being installed, and ease any future upgrade adding a full Desktop. The space and resource usage of a “MinimalX” system is nearly identical to a text-mode system, so is not an issue on tiny, limited resource deployments.

As for what you should do if you’re already starting from a text-mode system…
My general recommendation is to just pave and start over.
Else, find the name of that pattern I’m describing, list its contents and remove each and all of them as part of your adding a new Desktop.


Where did you read it’s not working ? :smiley:

He got it to work… for now.
Am saying… To do it right and have a high degree of success takes more than a dbus configuration.

Knock on wood, he won’t run into any future problems, but I hope I’ve provided a starting point for anyone in his situation to get a full result.


Thanks. :-]
I totally ignored the “custom” option on install for some reason.

This was/is a beneficial learning experience,
specifically in regard to display managers.

I switched to XDM, which apparently came with the x11 pattern,
and found that the xfce shutdown works fine without the ~/.xinitrc file.

The xfce panel’s volume control has a mute feature that works;
however, it will not unmute.

To solve this I
zypper in pavucontrol
> pavucontrol
Output devices -> Built-in audio analog stereo -> Headphones -> unmute

Actually, Xfce’s panel volume control: Right click, Run Audio Mixer, and you can unmute it there.

Yes, I also found that simply unchecking the Right click => Mute did not work, but opening the Mixer solves that.

For me unmuting headphones in the mixer also doesn’t work – it only works in pavucontrol.

Actually… I now see it mutes three things: Master, Headphones and Front.
I needed to unmute all of them.

Yes. I also discovered that … after a few moments of frustration. lol!

Switching back to lightdm, the xfce shutdown and reboot options now work without the ~/.xinitrc
Maybe I hallucinated the problem. :rolleyes:

I got Python 3.6.4 and PyQt 5.10 installed:

I also got qutebrowser:

cd src
git clone --depth 1
pip3 install --user sip pyqt5 PyYaml attrs pygments Jinja2 pypeg2
python3 ~/src/qutebrowser/

OK I wasn’t hallucinating. ;-]
The problem with shutting down or rebooting from the xfce menu
only happens when I start lightdm from a virtual terminal.
If the system is set to start lightdm automatically, then it’s not a problem.

I finally decided to investigate how to speed up wicked during boot,
but found using NetworkManager is more appropriate (and faster).

zypper in NetworkManager

YaST2 > Network Settings > Global Options > Network Setup Method > NetworkManager Service

I tried something similar to that. My big problem was when it came to updating for example I used:

zypper up

There was alot of unecessary packegas installed, if memory serves me correctly I saw libreoffice packeges in the list.