Starting Firefox breaks internet connection

Hi, I’m not exactly a Linux or Network expert but I’ve got a strange problem that doesn’t seem to make much sense.

I’ve have OpenSuse 13.2 64 bit installed without any issues but this one, so far. I can connect to internet via my WiFi router using the NetworkManager: on loging in the connection is made and I can ping the router and google just fine; however when I start Firefox for the first time the connection to the internet breaks. Although I still appear to be connected to the router pinging fails as well. If I then “Forget” the connection in NetworkMagner and then reconnect imeadiately I can ping just as before and now when I use Firefox all is well and works normally. This happens every time I start OpenSuse.

I’ve checked dmesg for errors or other information and there is nothing obvious, I’ve check the routing table via <route -n> and there is no difference between when the connection works and doesn’t.

I don’t believe this is limited to OpenSuse as I’ve tried other flavours and they seem to have the same issue.

Any ideas where eles I should be looking for the problem, log files or setting files I don’t know about.


As first step may be try to disable firewall?

Have you tried using another browser? Try launching firefox in safe mode (without extensions/themes loaded)

firefox -safe-mode

Any different?

Edit > Preferences > Advanced > Network > Settings, is it configured as 'Direct internet connection (no proxy)?