Start up Problem

I want to change my screen resolution to 1440900. I have 17 inches hp laptop monitor. I installed nvidia graphics card driver. It installed successfully. I can change the resolution in the YAST to 1440900. It says changes will take effect when i restart the computer. Then i restarted the computer. But it do not apply the changes and it is still 1024*768 resolution. How can i solve this problem?

Dear all,
I have almost tried everything to make my dv9000 to work in 1440x900 resolution. I edited my file manually. Added several different modelines. But my computer persists in working in 1024x768 resolution. I am desperate now. I even think about stop using suse linux. I may move to fedora if i cannot solve this resolution problem.

How did You install the drivers?

Nevermind, when booting add to the boot option init 3 (it’s probable that init does nothing and this 3 activates runlevel 3). When You get to the 3rd runlevel you run sax2 -r -m 0=nvidia and You then set appropriate resolution. You click change to make sure it got the correct settings, then save then ok. YOU DO NOT NEED TO RESTART THE PC!!

when you are at the command prompt after running that command you type:

sudo /etc/init.d/xdm start (it should ask for password), if it does not work then login with su and run above command without sudo.

This should start the x server. If the resolution will be fine then you are set if not then as a last resort try NVidia’s tool by typing nvidia-settings in the konsole.

You can set resolution there and some other settings.

Thank you for your suggestion but they do not work for me. it seems like everything is okay but when i run kde it starts in 1024x768 resolution.

Then i have another idea for You mate.

Go to /var/log/ you will find a Xorg.99.log file in there. Open it and search for a string Modeline, you should find modelines taken from Your laptop’s monitor edid. Choose the one appropriate for Your resolution. Next go to YaST, then sysconfig, choose Desktop–>>Display Manager–>>then choose DISPLAYMANAGER_RANDR_MODE_AUTO ( you can see there is some 1024x768 resolution) now change that with the modeline found in Xorg.99.log for your desired resolution. Watch for capital letter as modelines in Xorg.99.log don’t have them so adjust it and paste in there, hope it will help You. Please report back if it will help You. Don’t copy the part with kHz :wink:

Thanks for your help but it is not working again. In the log file there is no modeline defined.

However I tried something else. I run this command: xmode -x 1440 -y 900 -r 60
then i get modeline for 1440x900 resolution as follows:
Modeline “1440x900” 106.47 1440 1520 1672 1904 900 901 904 932
Then I edited this line to write it in etc/sysconfig Editor. But then again it did not work.
In the meantime, I figured out something new. While booting the suse linux it always use failsafe configuration.
It gives the following message: using failsafe X.Org Configuration /etc/X11/xorg.conf.install
This is the problem i believe it never loads my real configuration.
I thought it might be related with either my keyboard or my mouse. Then i disabled my mouse. Nothing changed. Afterwards, I set my primary keyboard layout as English basic. Then again nothing changed it still loads failsafe config.
I also tried to use krandrtray. But in the krandrtray the only resolution available is 1024x768.
I am desperate…

I found solution to my all problems. I downgraded my kernel and installed trace kernel. In trace everything is working. Now my screen is in 1440x900 resolution.

Weren’t You using the failsafe boot options by mistake ;)??

yeah seems like that… :wink: