Start network interface at Virtual Terminal

I would like to use zypper to update openSUSE 11.2 through the Virtual Terminals (tty1 thro’ tty6).
Network Interface is wlan0 (Wireless LAN, home network through a Router) that requires a password using WPA2.

My question is how to start wlan0 through the command-line ?


You do not tell, but it seems that you use a Network Manager.

When that is correct, you could change to configure the network device with YaST to use “traditional method with ifup”. You can fill in all the parameters (including password sentences). It will see that your networks starts on boot (runlevel 3 and/or 5) and not on user login, as this is (should be) normaly the case for any server and desktop system.

Network Manager is for GUI (RL 5).

I would like to plugin the USB Wireless Adapter after logging in to console (RL 3) and activate the wlan0 interface through cmd-line.

Install ‘cnetworkmanager’, it’s the Networkmanager for the command-line. Do a ‘man cnetworkmanager’ to see how you connect.

Another solution is, to set the networking from Networkmanager to Tradiditional Method in Yast. That would allow you to configure the card, and start it at boottime.

Is it possible to make NetworkManager use a manually set IP address from the console? I don’t see such an option in cnetworkmanager, and since my knetworkmanager stopped working for some strange reason, I’m trying to set up my network from the console. Maybe it’s possible to do using some configuration files?

Came across this thread from, should work for openSUSE also

How to set up a WPA2 wireless connection in Fedora using the ifcfg method -

When you want to do everything from the CLI read the man pages of ifconfig, ifup, iwconfig, route and do not forget resolv.conf for your DNS.

It is all possible, thirty years ago we did it all in this way (ecxept for iwconfig).

Yeah, I’m familiar with ifconfig etc., however I found NetworkManager a much better alternative. It’s just that the KDE front-end for NM suddenly stopped working after my last reboot and it’s really annoying not to be able to set a static IP ─ all I can do with cnetworkmanager is pick the SSID and my WPA-PSK phrase. Guess I’ll have to wait for some kind of update or something…

We are on a different course here. I do not see any use for NM when one wants a static IP address. The correct method imo is then configuring with YaST and there ‘traditional’. The network starts then on boot like every other component of the system, ready to be used by anything in the system that needs the network.

Straight and simple: use Yast. Set it to use Traditional Method (ifup), configure the card, done.

@hcvv: you’re right, no need for the OP to use the networkmanager.

The problem is, I only want to have a static IP on my home wireless network ─ so I had the IP assigned to my home access point, and used DHCP everywhere else I took my laptop.
Anyway, for now I’m using wicd, and just hope some update will fix knetworkmanager.