start lxde

Hello,

I’m not able to start lxde as default window manager. I have set

DEFAULT_WM="lxde"

in /etc/sysconfig/windowmanager, but IceWM is still load as default. I chose LXDE on grafical boot screen, but stille IceWM is load. I can run LXDE from konsole by command

startlxde

. It’s work when I log in to IceWM as standart user. Not rsuper user is required. Wher can be problem?

Thanks for help.

On 08/08/2013 09:26 PM, socool2 wrote:
>
> I’m not able to start lxde as default window manager. I have set
> Code:
> DEFAULT_WM=“lxde”

i’m not sure (hope someone who is will happen by and say the facts)
but LXDE is not a windows manager, instead it is a desktop
environment (which runs on top of a windows manager, like KDE runs on
top of its WM named kdm)…

still not sure, but i think LXDE runs normally in the WM named gdm or
lxdm or ???

suggest instead of trying to start lxde the way you are, put all the
config files you have edited back to their default values and just
select LXDE in the Sessions link on the log in page…

well…hmmmmm…that should work if you used YaST Software
Management to install LXDE from the normal openSUSE repos…if you
installed it in some other way you will have to hack the configs
yourself–but still i do not think setting LXDE as the WM is gonna
work…i think…


dd
http://tinyurl.com/DD-Caveat
http://tinyurl.com/DD-Complaints

AFAIK lxde uses openbox as its default WM. If you have installed lxde, it should appear in the list of alternative desktops at your login screen.

I have not changed any config file manuly, but in /etc/sysconfig/displaymanager

DISPLAYMANAGER="lxdm"

has been set an in /etc/sysconfig/windowmanager

DEFAULT_WM="lxde"

hes been set.
I thing that is right for use LXDE as default.

I have LXDE in list of alternative desktops on my login screen. I have choose it, but IceWM has been load. That is my major problem.

In /etc/sysconfig/displaymanager if you are using lightdm then change DISPLAYMANAGER=“lightdm”
In /etc/sysconfig/windowmanager change DEFAULT_WM=“lxde” to DEFAULT_WM=“startlxde”
I think that will work for you.

Sorry for the above post.