standard Installe L15 about two weeks ago "auto updates" ALL READY BROKEN I mean'REALLY'? NEW USER!

I installed Leap 15 ‘fresh’ went smooth everything worked, nothing custom. it started doing ‘automatic checking for new/updated software’ ok, read the list clicked ok/authorize software update to be ‘current’.
No ‘fancy’ software installed just basic install, firefox, evolution, libre office. That is it, a week ago after a ‘you have new updates’ I say ok, downloads/installs and requires a -reboot- to complete installation.
Done, reboots and now I “CANNOT LOG IN AS USER”. SERIOUSLY? WHY? I logged in as USER before the upgrade, shows my name as USER and the only user on this system,
but will not accept my password just keeps looping back to ‘SELECT USER’.
I can sign in as ‘root’ which is how i am able to communicate through Firefox because I am signed in a root, and it is the same password!
i have just discovered the ‘software’ has made changes and has also re-written the configuration of my hard-drives, 1-120gb SSD, 1-1tb WD (was /home), 2-3tb Seagate Barracudas.
Boots from SDD as as before,SDA has SWAP, took SDC and spilt into TWO “WINDOWS” partitions? what the! I do not have and did not select ANY WINDOWS PARTITIONS, HOW CAN THIS SOFTWARE MAKE SUCH

right now its just a lit ‘paperweight’.

Sorry if i seem frustrated, because i am.I am new to Linux, but for a Super Operating System as is claimed, it seems to ‘break’ a lot and i do not know all the super cryptic-codes to find out and tweak to perfection.
I JUST WANT IT TO WORK AS INSTALLED. what is unreasonable about that.

any help appreciated thank you.

You have not told us enough about what you did. So it is hard to know what went wrong. I’ll just say that I have never run into this problem.

One possibility is that, when logged in as root, you somehow changed permissions so that your user no longer is the own of his own files. That can mess things up and cause the problems that you are describing.

I can only back @nrickert that you are to vague. But I seem to read from it that you run root in the GUI. And even run Firefox with it. When that is true, please,please, please don’t. Never log in as root in the GUI. You should even not run in in the CLI as root, exceot in very special circumstances.

Linux is rock solid as long as you, the system manager, take a few basic precautions, like: Do not login in as root …

Inability to accept password seems to have become a common problem lately. is one example that includes pointers to other examples.

To see if it helps, please try booting selecting prior kernel in your Grub menu.

Hi all, thank you for your replies.
Sorry if i did not provide enough information.
I had a ‘clean’ basic/default install from DVD, everything worked fine, just about right after the install the ‘automatic’ message you have new/update software to install appeared,
i ‘viewed’ then clicked ‘install’ and the software downloaded and automatically installed the ‘updates’. This was only from OpenSuse repositories, like i said default install.
This happened two or three times with no ‘issues’ or problems.
Then the ‘automatic’ message came up again i ‘viewed’ then clicked ‘install’ again, download/update was ok except this time i was notified a ‘reboot’ would be required for all updates to take effect, which i did.
Upon ‘reboot’ the User Login screen (my name) appeared just like before pressed ‘enter’ for my name as User, the enter password screen appeared, i entered my password, the same one i used before to login
and ‘boom’, the message that did not work try again? i did and it just kept coming back to the user login with the same message:,that did not work try again.
i did not change ‘anything’ other than accepting the ‘update’ notice? As i said i had already ‘viewed’ then clicked ‘install’ two or three times before with no issues.
I cannot ‘login’ as User, i can only get into the system by choosing a different ‘User" and the only other one is ‘root’ this is a single home desktop and i am the only user.
Root is the only way i can login to the system and communicate right now. and i know not to Use ‘root’ for anything but for ‘system’ use, i always login as User-my name!
Which is the problem, I do not use ‘root’ for anything and i cannot get as User-my name (me!).
I have tried reading through notes, books i have and checking through the forums? but to no avail.
I did try as ‘root’ through Yast and CLI to “delete” User-me and ADD new User-me with a different name/password, no go same result/error!
So like i said ’ it is just a paperweight’ right now because i CANNOT LOGIN as ‘User-my name’ and run programs as ‘User-my name’ not #root. I do not know what else to do i am stuck, dead in the water?

Again thank you for timely replies all. Any ideas?

Can you log into a terminal as youself??

Press e at the boot screen find line starting linux or linuxefi and press end key add a space and 3 continue boot with F10

Log in as yourself.

Does this work??

Also remember that Linux is case sensitive so pay attention to cap locks setting

Hi gogalthorp, thank’s for your reply.
I cannot login as User-Noel (thats me) I can only login as User-root. which is how a can run Firefox to communicate.
At ‘reboot’ a line flashes by: failed to load system kernels module
then a GUI sceen appears, i press F2 to get the list as loading, everything loads with ok ] except for ‘two’:

Any thoughts/suggestion.


  1. As @mrmazda suggests, at your GRUB menu, you should try selecting the “Advanced” option, and then first the recovery mode (although I don’t believe I’ve ever heard that helped login problems like yours) and then an older kernel if you have multiple kernels.

  2. The next try I would suggest is login as root as you’ve done, then open up YaST > User module and change the password to your ordinary User account (then reboot or logout). If that doesn’t work, login as root again and this time change/set the password to your User account by command line… open a console and type

passwd *username *

You should be prompted to type in the new (or can be the same unless you also set password policy restrictions) password, type again to verify. Logout or reboot and I’d say that the chances are probably over 75% likely your problem should be resolved.

  1. If you think your problem might have been caused by an update which although possible is somewhat rare, you can try rolling back your machine to the moment it was “born” using Snapper. Not difficult to do, but I wouldn’t guess would be effective.

I’m going to guess that you might have mis-read the 2 Windows formatted partitions you saw… I’m going to guess your 2 Barracuda drives may be formatted NTFS. Although possible with 3rd party utilities, I don’t know that openSUSE itself has any way to format NTFS or any other kind of MSWindows format.


Hi Fluxcapicitor thanks for you response.
I did what you said logged in as #root, passwd noel,
changed password ‘twice’ , got ‘change successful’ and “rebooted”,
Got to User Login: Selected User-me entered data and same result ‘password not accepted etc…’ re-looped back
to User Login: I can still only login as ‘root’?

A couple of things i found out:
[Failed] failed to load system kernels module
[Failed] dhcpd ISMC DHCPV4 SERVER

[Failed] dhcpd On Boot [Failed]

[Failed] firewalld On Boot (Inactive Dead)

Error: DHCP Server cannot determine hostname. LDAP based configuration of DHCP server will not be available.

Error: Yast & User logon Management - Domain status: stopped

I did this through Yast as #root, so i just ‘looked’ around but changed nothing.
I hope this gives you some info.

Again thank’s for any help.

Run the following and post the result

pwck -r /etc/shadow | grep Noel


pwck -r /etc/passwd | grep Noel

The above checks for possible corruption of the password data related to your user account.
You can also run the above commands without grepping if you’re curious what everything else in the password data looks like.

If either reports something, it could be the source of your problem in which case you’d be advised to

  1. Verify your hard drive isn’t bad, reading your disk’s S.M.A.R.T data would be a good start.
  2. Create a new User account and migrate your data from your old User home directory to your new. Since your machine is so new, you can decide how much data if any you want to preserve or simply start over. Your access to your system with your root account means that you shouldn’t lose anything you fell is valuable.

I’m a bit curious about the references to an LDAP DHCP.
Do you know anything about that? Do you have LDAP installed in your network in any way?
If you’re logging into any network security like AD or LDAP, that could mean your account might be stored on the network and not locally on your machine… So, if any of this is possible, don’t make other big changes to your machine until we know more about your situation.

Good Luck,

Gee whillickers, or somethin’ like that!

Log in on command line as root.



Security and Users => User and Group Management

Highlight your normal user (not root)


Make a new password.

finish up in there, then reboot and test again