sshfs - remote host has disconnected

I’m trying to use sshfs, but I get “remote host has disconnected” error. Even when I use -o sshfs_debug I get no other information. It looks like this:

host1:/mnt # sshfs host2_config:~/ /mnt/user/ -o sshfs_debug
SSHFS version 2.2
Enter passphrase for key '/root/.ssh/id_rsa': 
remote host has disconnected

It does not make any difference if I do it as user or root on local machine.
The only thing I haven’t tried is setting up user root in .ssh/config for host2, but I’d like to avoid that.
ssh (with X froward), and scp works perfectly fine.

What could be a reason?

Are you connecting to a 64 bit machine ?
Have you tried to connect directly with sftp ?

I just had the same issue and found out that the sftp subsystem was not configured properly:
In “/etc/ssh/sshd_config”, see the line with “Subsystem sftp /usr/lib64/ssh/sftp-server”.
This line must be enabled (no # at the beginning).
Also, the path to that file doesn’t exist for some reason, and it must be replaced with “/usr/lib/ssh/sftp-server”.

This might be a bug in the openssh package.

Hope it helps.

My target machine is running openSUSE 12.1 x86_64.

Thanks for the information. I had the same problem today.
… which makes me think:
Has anybody filed a bug for the

I’ve found a report here:
It seems the problem only appears when upgrading from 11.4 (which is my case)