sshd is not located under /etc/init.d

I’m unable to connect to my VM suse from my host machine windows 8.

I’ve searched on google about this problem, and some people was talking about restarting /etc/init.d/sshd, but I can’t find this file under init.d directory.

Could anyone help me to add sshd file under init.d?

Thank you

So which VM and how is the Virtual network set up???

VMWare Workstation 11.0 and Network is Bridged(automatic)

Probably should ask this in the VM section

I can’t help with VMware. it has been years since I used any of their stuff

On 2015-01-20 03:56, tosihiro2007 wrote:

> I’ve searched on google about this problem, and some people was talking
> about restarting /etc/init.d/sshd, but I can’t find this file under
> init.d directory.

Means that you probably don’t have sshd installed; so check in YaST if
it is, and if not, install it.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

On 2015-01-20 04:06, gogalthorp wrote:
>
> Probably should ask this in the VM section
>
> I can’t help with VMware. it has been years since I used any of their
> stuff

I don’t think it is related to virtualization at all, because he says he
doesn’t have the “/etc/init.d/sshd” file. On my 13.1 at least it is not
a systemd service, the initd script exists.

So he just needs installing the sshd daemon in openSUSE, which is not
enabled by default (IIRC not even installed).

I’m off to sleep :slight_smile:


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

All installations I did (minimal text mode mostly) installed sshd by default, but also firewall was active by default and was blocking port 22.

Looks like after reinstalling OS again, it worked.

Thank you for the suggestions.

On 13.2 there is no /etc/init.d/sshd any more and it’s completely integrated with systemd.

It is still however disabled by default and requires systemctl enable sshd && systemctl start sshd + opening port 22 in firewall - rcsshd still exists though :slight_smile:

configuration files in /etc/ssh/