SSH connection suddenly stop

I’ve an issue with ssh connection.
I’m in my intranet and from my PC (LEAP15) i can connect with ssh to a PC with opensuse 13.0 (no firewall) without any issue.

Now I’m setting up a new PC (LEAP15) always on my intranet and ssh connection is very problematic. Connection started without any issue and always stopped within 1 or 2 minutes.
I’ve tried also to disable the firewall but the result is the same.
This is what I do:

  • open konsole on my pc and as normal user i run : ssh remoteuser@ipaddress (connection started succesfully)
  • i give the remoteuser password and i switch to su with root password (root of remote pc)
  • suddenly within 1 o 2 minutes the connection freeze …

All network connection are hardwired (no wifi).

What can I check / do ?

Here, “ssh” is working reliably. That suggests that your problem is with the hardware, rather than the software. Maybe check network cables. Also try testing the network on the problem machine – can it maintain other connections?

I believe hardware and cable are not the problem because I can update the system / navigate without any issue.
Is there any rule (maybe in polkit) that can block ssh ?

Just for knowledge the new PC is a HP Proliant microgen 10 …

IIRC many, many years ago this same question was asked and there was a timeout configured.

Inspect your ssh configuration.


The problem IMO is on the server side. Does it connect if you keep active in the connection? But also check your local sshd settings.

After further investigation I’ve to change my diagnose : the culprit isn’t ssh but is the remote ‘graphic’ server.
Applications that freeze (and often, after 15-20 seconds restart) are yast and mc, ssh shell is perfectly working …

Thanks for that update. Now you have a different problem to solve :frowning: