ssh client hangs after typing password

I got this strange problem.
After connecting to any host, the openssh client hangs after I type the password.

The strange part is, it only hangs if when I use the wlan card. If I connect my phone to the computer and uses it to connect to my server, it works 100%.
If I use any other computer at the wireless network, it works 100%
If I use putty on the same machine, it works 100%

It is only a problem when I use the build-in wireless card, under openSuSE 11.3, on my Lenovo L512.
(note that everything besides ssh works completely)

This is driving me crazy, anyone got a clue whats going on?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

The joy of the ‘ssh’ command is the debugging output you can easily get:

ssh -vvv whatever@yourbox

You should get a fairly large chunk of output. Note, as it is connecting,
where it hangs. Also, see if it will continue after a couple minutes.
Another thing to try is sending a command to run to see if that works
while an interactive login does not:

ssh whatever@yourbox ‘ls -l’

Good luck.

On 01/05/2011 02:06 PM, Karstenu wrote:
>
> I got this strange problem.
> After connecting to any host, the openssh client hangs after I type the
> password.
>
> The strange part is, it only hangs if when I use the wlan card. If I
> connect my phone to the computer and uses it to connect to my server, it
> works 100%.
> If I use any other computer at the wireless network, it works 100%
> If I use putty on the same machine, it works 100%
>
> It is only a problem when I use the build-in wireless card, under
> openSuSE 11.3, on my Lenovo L512.
> (note that everything besides ssh works completely)
>
> This is driving me crazy, anyone got a clue whats going on?
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.15 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJNJOQyAAoJEF+XTK08PnB5I3kP/iUEBg9zTs0YQCLzCvH4Z/IM
/EHL86tS+fUYRry/2iGHUhNTcLTd1kab81/GhvxMhCMNWedREWl9R60lbcIqSDBp
U6MAlOvpSlZzw2Ar0a1cugSOKUGVRnC2Wp/1hq/nE0iZRTwrJfYbwjjNwXNzfsWE
CXDLwevR1uXmt5C7FyVGKPuwxNPI1LAoP7F3SddusWnrCvbwrsADGPirPAqLEmCO
FBDhUIZQO9A8zGedyuCVLvPlpJVDlR3OY+epu3pswROmYE6gIkhE1h2IhPo7CjHF
o5iJcPuOn9+n0QIrCZTarez0WT1HIN8K3RqoKjq6q8hB8QFpkviFfUDZ3vTsZF/j
+XrcAvFQmlhB/7naEj7jswutg85i8mT3LdT9jyncEEMdU857qFdMFEEr+Xs0o3IO
G6LVhC27fbX2PQMQ5bAFzIUMKMVoyAoYY1qnMZlGOkEtY9jKUrl7UgKZ35jXDOOL
GnIpsbiFRPPaLqgiIf1fTQO2UOBxSoQu6NHiNN/Z1Dypexlk62UcxvpABC0gxR3X
cM8fjUI+qItMRzX1xvdYyYr+49OIKVWT2RwaGeL4GBkQmbXJWYZvogK3+M9WBKYv
6VxsGoN1rhHuU1WPBbaTHnPBHPoYkScFNP5mYMRfCfHVUsVTLOzBj6Z41nA2pHpX
uJ0itWcSipioCHNIDRIa
=fCc+
-----END PGP SIGNATURE-----

The rather large output:

OpenSSH_5.6p1, OpenSSL 1.0.0 29 Mar 2010
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to ingrid.ogr.dk [91.144.248.108] port 22.
debug1: Connection established.
debug1: identity file /home/karsten/.ssh/id_rsa type -1
debug1: identity file /home/karsten/.ssh/id_rsa-cert type -1
debug1: identity file /home/karsten/.ssh/id_dsa type -1
debug1: identity file /home/karsten/.ssh/id_dsa-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_4.6
debug1: match: OpenSSH_4.6 pat OpenSSH_4*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.6
debug2: fd 3 setting O_NONBLOCK
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa-cert-v01@openssh.com,ssh-dss-cert-v01@openssh.com,ssh-rsa-cert-v00@openssh.com,ssh-dss-cert-v00@openssh.com,ssh-rsa,ssh-dss
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: first_kex_follows 0 
debug2: kex_parse_kexinit: reserved 0 
debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com
debug2: kex_parse_kexinit: none,zlib@openssh.com
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: first_kex_follows 0 
debug2: kex_parse_kexinit: reserved 0 
debug2: mac_setup: found hmac-md5
debug1: kex: server->client aes128-ctr hmac-md5 none
debug2: mac_setup: found hmac-md5
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug2: dh_gen_key: priv key bits set: 131/256
debug2: bits set: 512/1024
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug3: check_host_in_hostfile: host ingrid.ogr.dk filename /home/karsten/.ssh/known_hosts
debug3: check_host_in_hostfile: host ingrid.ogr.dk filename /home/karsten/.ssh/known_hosts
debug3: check_host_in_hostfile: match line 1
debug3: check_host_in_hostfile: host 91.144.248.108 filename /home/karsten/.ssh/known_hosts
debug3: check_host_in_hostfile: host 91.144.248.108 filename /home/karsten/.ssh/known_hosts
debug3: check_host_in_hostfile: match line 2
debug1: Host 'ingrid.ogr.dk' is known and matches the RSA host key.
debug1: Found key in /home/karsten/.ssh/known_hosts:1
debug2: bits set: 488/1024
debug1: ssh_rsa_verify: signature correct
debug2: kex_derive_keys
debug2: set_newkeys: mode 1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug2: set_newkeys: mode 0
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug2: key: /home/karsten/.ssh/id_rsa ((nil))
debug2: key: /home/karsten/.ssh/id_dsa ((nil))
debug1: Authentications that can continue: publickey,keyboard-interactive
debug3: start over, passed a different list publickey,keyboard-interactive
debug3: preferred publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /home/karsten/.ssh/id_rsa
debug3: no such identity: /home/karsten/.ssh/id_rsa
debug1: Trying private key: /home/karsten/.ssh/id_dsa
debug3: no such identity: /home/karsten/.ssh/id_dsa
debug2: we did not send a packet, disable method
debug3: authmethod_lookup keyboard-interactive
debug3: remaining preferred: password
debug3: authmethod_is_enabled keyboard-interactive
debug1: Next authentication method: keyboard-interactive
debug2: userauth_kbdint
debug2: we sent a keyboard-interactive packet, wait for reply
debug2: input_userauth_info_req
debug2: input_userauth_info_req: num_prompts 1
Password: 
debug3: packet_send2: adding 32 (len 28 padlen 4 extra_pad 64)
debug2: input_userauth_info_req
debug2: input_userauth_info_req: num_prompts 0
debug3: packet_send2: adding 48 (len 10 padlen 6 extra_pad 64)
debug1: Authentication succeeded (keyboard-interactive).
Authenticated to ingrid.ogr.dk ([91.144.248.108]:22).
debug1: channel 0: new [client-session]
debug3: ssh_session2_open: channel_new: 0
debug2: channel 0: send open
debug1: Entering interactive session.
debug2: callback start
debug2: client_session2_setup: id 0
debug2: channel 0: request pty-req confirm 1
debug1: Sending environment.
debug3: Ignored env LESSKEY
debug3: Ignored env MANPATH
debug3: Ignored env NNTPSERVER
debug3: Ignored env SSH_AGENT_PID
debug3: Ignored env KDE_MULTIHEAD
debug3: Ignored env DM_CONTROL
debug3: Ignored env HOSTNAME
debug3: Ignored env XKEYSYMDB
debug3: Ignored env TERM
debug3: Ignored env SHELL
debug3: Ignored env HOST
debug3: Ignored env HISTSIZE
debug3: Ignored env XDG_SESSION_COOKIE
debug3: Ignored env XDM_MANAGED
debug3: Ignored env PROFILEREAD
debug3: Ignored env GTK2_RC_FILES
debug3: Ignored env KONSOLE_DBUS_SERVICE
debug3: Ignored env TMPDIR
debug3: Ignored env GTK_RC_FILES
debug3: Ignored env GS_LIB
debug3: Ignored env WINDOWID
debug3: Ignored env MORE
debug3: Ignored env XSESSION_IS_UP
debug3: Ignored env KDE_FULL_SESSION
debug3: Ignored env USER
debug3: Ignored env JRE_HOME
debug3: Ignored env LS_COLORS
debug3: Ignored env XNLSPATH
debug3: Ignored env ENV
debug3: Ignored env HOSTTYPE
debug3: Ignored env SSH_AUTH_SOCK
debug3: Ignored env FROM_HEADER
debug3: Ignored env SESSION_MANAGER
debug3: Ignored env PAGER
debug3: Ignored env CSHEDIT
debug3: Ignored env XDG_CONFIG_DIRS
debug3: Ignored env MINICOM
debug3: Ignored env DESKTOP_SESSION
debug3: Ignored env PATH
debug3: Ignored env MAIL
debug3: Ignored env CPU
debug3: Ignored env QT_IM_MODULE
debug3: Ignored env JAVA_BINDIR
debug3: Ignored env PWD
debug3: Ignored env INPUTRC
debug3: Ignored env XMODIFIERS
debug3: Ignored env JAVA_HOME
debug1: Sending env LANG = da_DK.UTF-8
debug2: channel 0: request env confirm 0
debug3: Ignored env KDE_SESSION_UID
debug3: Ignored env PYTHONSTARTUP
debug3: Ignored env KONSOLE_DBUS_SESSION
debug3: Ignored env SSH_ASKPASS
debug3: Ignored env QT_SYSTEM_DIR
debug3: Ignored env COLORFGBG
debug3: Ignored env SHLVL
debug3: Ignored env HOME
debug3: Ignored env OSTYPE
debug3: Ignored env KDE_SESSION_VERSION
debug3: Ignored env LANGUAGE
debug3: Ignored env LESS_ADVANCED_PREPROCESSOR
debug3: Ignored env LS_OPTIONS
debug3: Ignored env XCURSOR_THEME
debug3: Ignored env WINDOWMANAGER
debug3: Ignored env LESS
debug3: Ignored env G_FILENAME_ENCODING
debug3: Ignored env LOGNAME
debug3: Ignored env MACHTYPE
debug3: Ignored env DBUS_SESSION_BUS_ADDRESS
debug3: Ignored env XDG_DATA_DIRS
debug3: Ignored env LESSOPEN
debug3: Ignored env USE_FAM
debug3: Ignored env WINDOWPATH
debug3: Ignored env PROFILEHOME
debug3: Ignored env DISPLAY
debug3: Ignored env QT_PLUGIN_PATH
debug3: Ignored env GTK_IM_MODULE
debug3: Ignored env XAUTHLOCALHOSTNAME
debug3: Ignored env LESSCLOSE
debug3: Ignored env QT_IM_SWITCHER
debug3: Ignored env G_BROKEN_FILENAMES
debug3: Ignored env COLORTERM
debug3: Ignored env JAVA_ROOT
debug3: Ignored env mc
debug3: Ignored env _
debug2: channel 0: request shell confirm 1
debug2: fd 3 setting TCP_NODELAY
debug2: callback done
debug2: channel 0: open confirm rwindow 0 rmax 32768

And here it hangs (tried waiting for about 15min, without any result).

If I try sending a command like you suggest, I get the same result.
However normally I can’t kill the process by using ctr+c, but when sending a command with the login, this is possible.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

debug2: channel 0: open confirm rwindow 0 rmax 32768
debug2: channel_input_status_confirm: type 99 id 0
debug2: PTY allocation request accepted on channel 0
debug2: channel 0: rcvd adjust 131072
debug2: channel_input_status_confirm: type 99 id 0
debug2: shell request accepted on channel 0

The next lines from my system are the ones above duplicating (one line so
you could see the boundary easily). I’m not sure what
channel_input_status_confirm means but that’s interesting.

Googling for the last line has found this thread which seems promising:

https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/237894

Good luck.

On 01/05/2011 03:06 PM, Karstenu wrote:
>
> The rather large output:
>
> Code:
> --------------------
> OpenSSH_5.6p1, OpenSSL 1.0.0 29 Mar 2010
> debug1: Reading configuration data /etc/ssh/ssh_config
> debug1: Applying options for *
> debug2: ssh_connect: needpriv 0
> debug1: Connecting to ingrid.ogr.dk [91.144.248.108] port 22.
> debug1: Connection established.
> debug1: identity file /home/karsten/.ssh/id_rsa type -1
> debug1: identity file /home/karsten/.ssh/id_rsa-cert type -1
> debug1: identity file /home/karsten/.ssh/id_dsa type -1
> debug1: identity file /home/karsten/.ssh/id_dsa-cert type -1
> debug1: Remote protocol version 2.0, remote software version OpenSSH_4.6
> debug1: match: OpenSSH_4.6 pat OpenSSH_4*
> debug1: Enabling compatibility mode for protocol 2.0
> debug1: Local version string SSH-2.0-OpenSSH_5.6
> debug2: fd 3 setting O_NONBLOCK
> debug1: SSH2_MSG_KEXINIT sent
> debug1: SSH2_MSG_KEXINIT received
> debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
> debug2: kex_parse_kexinit: ssh-rsa-cert-v01@openssh.com,ssh-dss-cert-v01@openssh.com,ssh-rsa-cert-v00@openssh.com,ssh-dss-cert-v00@openssh.com,ssh-rsa,ssh-dss
> debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
> debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
> debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
> debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
> debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
> debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
> debug2: kex_parse_kexinit:
> debug2: kex_parse_kexinit:
> debug2: kex_parse_kexinit: first_kex_follows 0
> debug2: kex_parse_kexinit: reserved 0
> debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
> debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
> debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
> debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
> debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
> debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
> debug2: kex_parse_kexinit: none,zlib@openssh.com
> debug2: kex_parse_kexinit: none,zlib@openssh.com
> debug2: kex_parse_kexinit:
> debug2: kex_parse_kexinit:
> debug2: kex_parse_kexinit: first_kex_follows 0
> debug2: kex_parse_kexinit: reserved 0
> debug2: mac_setup: found hmac-md5
> debug1: kex: server->client aes128-ctr hmac-md5 none
> debug2: mac_setup: found hmac-md5
> debug1: kex: client->server aes128-ctr hmac-md5 none
> debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
> debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
> debug2: dh_gen_key: priv key bits set: 131/256
> debug2: bits set: 512/1024
> debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
> debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
> debug3: check_host_in_hostfile: host ingrid.ogr.dk filename /home/karsten/.ssh/known_hosts
> debug3: check_host_in_hostfile: host ingrid.ogr.dk filename /home/karsten/.ssh/known_hosts
> debug3: check_host_in_hostfile: match line 1
> debug3: check_host_in_hostfile: host 91.144.248.108 filename /home/karsten/.ssh/known_hosts
> debug3: check_host_in_hostfile: host 91.144.248.108 filename /home/karsten/.ssh/known_hosts
> debug3: check_host_in_hostfile: match line 2
> debug1: Host ‘ingrid.ogr.dk’ is known and matches the RSA host key.
> debug1: Found key in /home/karsten/.ssh/known_hosts:1
> debug2: bits set: 488/1024
> debug1: ssh_rsa_verify: signature correct
> debug2: kex_derive_keys
> debug2: set_newkeys: mode 1
> debug1: SSH2_MSG_NEWKEYS sent
> debug1: expecting SSH2_MSG_NEWKEYS
> debug2: set_newkeys: mode 0
> debug1: SSH2_MSG_NEWKEYS received
> debug1: Roaming not allowed by server
> debug1: SSH2_MSG_SERVICE_REQUEST sent
> debug2: service_accept: ssh-userauth
> debug1: SSH2_MSG_SERVICE_ACCEPT received
> debug2: key: /home/karsten/.ssh/id_rsa ((nil))
> debug2: key: /home/karsten/.ssh/id_dsa ((nil))
> debug1: Authentications that can continue: publickey,keyboard-interactive
> debug3: start over, passed a different list publickey,keyboard-interactive
> debug3: preferred publickey,keyboard-interactive,password
> debug3: authmethod_lookup publickey
> debug3: remaining preferred: keyboard-interactive,password
> debug3: authmethod_is_enabled publickey
> debug1: Next authentication method: publickey
> debug1: Trying private key: /home/karsten/.ssh/id_rsa
> debug3: no such identity: /home/karsten/.ssh/id_rsa
> debug1: Trying private key: /home/karsten/.ssh/id_dsa
> debug3: no such identity: /home/karsten/.ssh/id_dsa
> debug2: we did not send a packet, disable method
> debug3: authmethod_lookup keyboard-interactive
> debug3: remaining preferred: password
> debug3: authmethod_is_enabled keyboard-interactive
> debug1: Next authentication method: keyboard-interactive
> debug2: userauth_kbdint
> debug2: we sent a keyboard-interactive packet, wait for reply
> debug2: input_userauth_info_req
> debug2: input_userauth_info_req: num_prompts 1
> Password:
> debug3: packet_send2: adding 32 (len 28 padlen 4 extra_pad 64)
> debug2: input_userauth_info_req
> debug2: input_userauth_info_req: num_prompts 0
> debug3: packet_send2: adding 48 (len 10 padlen 6 extra_pad 64)
> debug1: Authentication succeeded (keyboard-interactive).
> Authenticated to ingrid.ogr.dk ([91.144.248.108]:22).
> debug1: channel 0: new [client-session]
> debug3: ssh_session2_open: channel_new: 0
> debug2: channel 0: send open
> debug1: Entering interactive session.
> debug2: callback start
> debug2: client_session2_setup: id 0
> debug2: channel 0: request pty-req confirm 1
> debug1: Sending environment.
> debug3: Ignored env LESSKEY
> debug3: Ignored env MANPATH
> debug3: Ignored env NNTPSERVER
> debug3: Ignored env SSH_AGENT_PID
> debug3: Ignored env KDE_MULTIHEAD
> debug3: Ignored env DM_CONTROL
> debug3: Ignored env HOSTNAME
> debug3: Ignored env XKEYSYMDB
> debug3: Ignored env TERM
> debug3: Ignored env SHELL
> debug3: Ignored env HOST
> debug3: Ignored env HISTSIZE
> debug3: Ignored env XDG_SESSION_COOKIE
> debug3: Ignored env XDM_MANAGED
> debug3: Ignored env PROFILEREAD
> debug3: Ignored env GTK2_RC_FILES
> debug3: Ignored env KONSOLE_DBUS_SERVICE
> debug3: Ignored env TMPDIR
> debug3: Ignored env GTK_RC_FILES
> debug3: Ignored env GS_LIB
> debug3: Ignored env WINDOWID
> debug3: Ignored env MORE
> debug3: Ignored env XSESSION_IS_UP
> debug3: Ignored env KDE_FULL_SESSION
> debug3: Ignored env USER
> debug3: Ignored env JRE_HOME
> debug3: Ignored env LS_COLORS
> debug3: Ignored env XNLSPATH
> debug3: Ignored env ENV
> debug3: Ignored env HOSTTYPE
> debug3: Ignored env SSH_AUTH_SOCK
> debug3: Ignored env FROM_HEADER
> debug3: Ignored env SESSION_MANAGER
> debug3: Ignored env PAGER
> debug3: Ignored env CSHEDIT
> debug3: Ignored env XDG_CONFIG_DIRS
> debug3: Ignored env MINICOM
> debug3: Ignored env DESKTOP_SESSION
> debug3: Ignored env PATH
> debug3: Ignored env MAIL
> debug3: Ignored env CPU
> debug3: Ignored env QT_IM_MODULE
> debug3: Ignored env JAVA_BINDIR
> debug3: Ignored env PWD
> debug3: Ignored env INPUTRC
> debug3: Ignored env XMODIFIERS
> debug3: Ignored env JAVA_HOME
> debug1: Sending env LANG = da_DK.UTF-8
> debug2: channel 0: request env confirm 0
> debug3: Ignored env KDE_SESSION_UID
> debug3: Ignored env PYTHONSTARTUP
> debug3: Ignored env KONSOLE_DBUS_SESSION
> debug3: Ignored env SSH_ASKPASS
> debug3: Ignored env QT_SYSTEM_DIR
> debug3: Ignored env COLORFGBG
> debug3: Ignored env SHLVL
> debug3: Ignored env HOME
> debug3: Ignored env OSTYPE
> debug3: Ignored env KDE_SESSION_VERSION
> debug3: Ignored env LANGUAGE
> debug3: Ignored env LESS_ADVANCED_PREPROCESSOR
> debug3: Ignored env LS_OPTIONS
> debug3: Ignored env XCURSOR_THEME
> debug3: Ignored env WINDOWMANAGER
> debug3: Ignored env LESS
> debug3: Ignored env G_FILENAME_ENCODING
> debug3: Ignored env LOGNAME
> debug3: Ignored env MACHTYPE
> debug3: Ignored env DBUS_SESSION_BUS_ADDRESS
> debug3: Ignored env XDG_DATA_DIRS
> debug3: Ignored env LESSOPEN
> debug3: Ignored env USE_FAM
> debug3: Ignored env WINDOWPATH
> debug3: Ignored env PROFILEHOME
> debug3: Ignored env DISPLAY
> debug3: Ignored env QT_PLUGIN_PATH
> debug3: Ignored env GTK_IM_MODULE
> debug3: Ignored env XAUTHLOCALHOSTNAME
> debug3: Ignored env LESSCLOSE
> debug3: Ignored env QT_IM_SWITCHER
> debug3: Ignored env G_BROKEN_FILENAMES
> debug3: Ignored env COLORTERM
> debug3: Ignored env JAVA_ROOT
> debug3: Ignored env mc
> debug3: Ignored env _
> debug2: channel 0: request shell confirm 1
> debug2: fd 3 setting TCP_NODELAY
> debug2: callback done
> debug2: channel 0: open confirm rwindow 0 rmax 32768
>
> --------------------
>
> And here it hangs (tried waiting for about 15min, without any result).
>
> If I try sending a command like you suggest, I get the same result.
> However normally I can’t kill the process by using ctr+c, but when
> sending a command with the login, this is possible.
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.15 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJNJQL8AAoJEF+XTK08PnB5vaYP/AkuD8exOEaXmPeGIJZO616K
IihzaMeITdV/lJeerHEnmNpbUxPVis/NMu8vWWaF0Twex5e6TgBEkKCYKIRa2jlv
99ZKZTlG0CQs7MS+eUz3/m3nyUCXfrBAMG56+cjR/dnPf1QbJxKEWRsgzbMhmKls
cUoJDIoUpUvu2RpNnP8d5nkF3y58Wmo/xDRAqkidcisehqDyAaJFT/letzt32Itj
A9BsLVIYkxf+0qZdxDIL+tweTI212Ff66BNUL1VUj5XYIDNPPNh9NwftmWD6zyes
Ff8Qpf/kOeZnz2WlsIP8ieYSa12dObe5rh0csY9YojsI5+ZxQEViJIlffcgHQydB
dPrQ6vs4GItNGrfnOrkYjRmhpiK4XET2c4MCJJ8vtKqyrqabJXKF45g/Iv71apN/
sFv7/BKU2AEExDJ1kRieIavpBP9RABlFvjXuWmZmOP9Lar3Q5BErz+whUzbjBLzC
NdIhfzkV/4P0FbZHEpnGzHAcPW6b7r/lWIxanyK/HqhwPLCSjdsfoY7Yt3NmZ+3u
dh56/SKcs9xUrfVQa0dY0C+R6Sbc4tZMtyHaMAUSbxPHJN96XbsGBzqgdAJNw5yw
Kifo4/ZGnALis30vCsFtDPDtQ9tGGM8xqi/nFVHNKe3RgoVx/ZJ/n9hS4NUxuugC
t20vtLFBYoGeUdfbPHZL
=dOv/
-----END PGP SIGNATURE-----

I have read a lot of Ubuntu bug reports with similar symptoms.
And the solution always seems to be ‘disable the default Broadcom driver’.
But I have an Intel based wlan :frowning:
(Also note the date on the bug)

I have the same problem. does anybody solved it?
I found this bug in ubuntu https://bugs.launchpad.net/ubuntu/+source/landscape-client/+bug/519930
I have in the remote machine cifs mounted drives so the reason could be the same but the fix does not apply for opensuse

I have the same problem when connecting through the cisco vpn system. On 11.4 it still works on 12.2 it hangs at the very same stage. So far I only could workaround it with “Protocol 1,2” in the sshd_config on the server and connect via “ssh -1”. But that’s bad and I was thinking it has something to do with the reverse DNS lookup but useDNS=no in the sshd_config didn’t help. I’m clueless about this issue too and it’s really anoying