squidguard install (please help a total newbie)

Hi All,

I am just getting into the wonderful world of suse and am loving it.

Sorry to ask dumb newbie questions but was wondering if anyone could help…

I am trying to install squidguard on suse 11.1

I have already installed squid which is up and running fine.

I have installed squidguard from the yast installer which seems to have run fine.

I have been following the suse specific documentation here,

SquidGuard - openSUSE

the first step is to add the following to the squid.conf,

url_rewrite_program /usr/bin/squidGuard
url_rewrite_children 5

However I have no squidGuard in that folder, I do however have the file in /usr/sbin/squidGuard

Restarting squid works fine if I use sbin but obviously not if I use bin as the file isnt found

question 1 - Have I done something above wrong since the file seems to be in the wrong directory and if so should this matter?

When squid is restarted using this config it seems to start fine.

So, following the config, I tried,

squidGuard -c /etc/squidGuard.conf -C all

Which in my very basic understanding (sorry for being lame) should compact the blacklists to Berkley DBs however when I do this the command doesnt seem to complete and the xterm just hangs below the line.

I must have done something wrong and Im sorry if this has been posted before somewhere but Ive honestly tried to search and can find little specifically for suse (especially v11)

Any replies would be MUCH appreciated.


Could this issue be because I dont have BerkeleyDB installed?

Could anyone tell me if this is preinstalled on the default build?