Squid not caching large files

I’ve just setup a box running opensuse 13.1 & squid 3.3… I’ve got the Max_oject_size set to 9 GB so that it would capture dual-layer DVD images and other large files…

The total size of the cache is 50GB, however when I download a 600MB debian image from my ISP’s mirror (http or ftp) its not keeping a copy of it.

Is there anything else that I should change?

just tried clearing and rebuilding the cache & then downloaded a 10MB file which it didn’t cache either… Any ideas?

You might want to check the refresh_pattern option and make one for .iso files with ignore-no-cache as a directive, maybe the web servers are telling squid not to cache the content or it thinks the .iso has changed.

squid : refresh_pattern configuration directive

Google with the keywords squid refresh_pattern ignore-no-cache for a few examples, better than I can explain here :slight_smile:

Ok thanks… I’ve added the below (which I found on another forum), so I’ll give it a test and let you know how it goes.

refresh_pattern -i \.(iso|avi|wav|mp3|mp4|mpeg|swf|flv|x-flv|mpg|wma|ogg|wmv|asx|asf)$ 260000 90% 260009 override-expire ignore-no-cache ignore-no-store
refresh_pattern -i \.(deb|rpm|exe|zip|tar|tgz|ram|rar|bin|ppt|doc|tiff|pdf|uxx)$ 260000 90% 260009 override-expire ignore-no-cache ignore-no-store

No, still no go… Are those refresh rules correct?

When i’m downloading, its showing the file in transit… so I know that its going through the proxy… I’ve also noticed that some of the other files have “cachable” in those tags at the top where this doesnt.

KEY E8C24B9C0C9BAF52D094F580B1D7E3A0
	LV:1386996760 LU:1386996760 LM:1381582617 EX:-1       
	4 locks, 1 clients, 1 refs
	Swap Dir -1, File 0XFFFFFFFF
	GET http://mirror.optusnet.com.au/debian-cd/current/i386/iso-cd/debian-7.2.0-i386-netinst.iso
	inmem_lo: 176755772
	inmem_hi: 176964796
	swapout: 0 bytes queued
	Client #0, (nil)
		copy_offset: 176946076
		copy_size: 4096