SQUID fatal error!

Since I upgraded to newer model of ADSL modem, Squid does not start and gives me this message:

FATAL: Could not determine fully qualified hostname.  Please set 'visible_hostname'

Squid Cache (Version 2.6.STABLE20): Terminated abnormally.
CPU Usage: 0.000 seconds = 0.000 user + 0.000 sys
Maximum Resident Size: 0 KB
Page faults with physical i/o: 11

Can someone explain to me what this means, and how to fix it?

Squid: the definitive guide - Google Books

Duane Wessels is one of the authors of squid.

Thanks for the link.

It is to much reading :). However, I believe that I should not configure squid right now.
This problem actually started when I installed new ADSL modem (Sitecom WL-154).
I still have my old modem (SpeedTouch 570), and when I install it back, the squid starts normally.

The difference is that somehow my Linux hostname is not visible for the LAN.
The old modem has DNS server, which contains the hostname table.
The new modem has no DNS sever. Still, in the modem “DHCP IP Pool Summary” tab, it shows the hostnames of my Windows machines. For Linux machines it only lists IP and MAC addresses. Somehow Windows hostnames are visible for the LAN.

The question is, why Linux does not broadcast its hostname?

When I ping its hostname in Linux, I see only loopback adapter

If the address that squid serves on doesn’t map to a hostname, then declare its hostname with visible_hostname, like the error message suggests.

The problem is solved.

I was playing with my ADSL modem settings and the problem got solved. Squid starts again. :slight_smile:

Unfortunately, I was not able to find out which modem setting did it. I’m also not going to experiment further. It works so I don’t touch it any more.