SQLite header and source version mismatch

I have installed sqlite3 on OpenSuse Leap 42.2 using the following commands as superuser:

zypper addrepo http://download.opensuse.org/repositories/server:database/openSUSE_Leap_42.2/server:database.repo
zypper refresh
zypper install sqlite3

but when I run sqlite3 in the terminal, I get the following error:

SQLite header and source version mismatch
2015-05-20 18:17:19 2ef4f3a5b1d1d0c4338f8243d40a2452cc1f7fe4
2017-08-01 13:24:15 9501e22dfeebdcefa783575e47c60b514d7c2e0cad73b2a496c0bc4b680900a8

When I run which sqlite3 in terminal, it returns the following path:

zypper se -si -v sqlite3

Make sure sqlite3 and sqlite3-devel are the same version and from the same repository.

Run a system update, ordinarily that’ll sync up your versions

From an elevated console,

zypper update

I’d also ask why you even have SQLite headers and source installed in the first place.
Unless you’re modifying the application itself, those aren’t used or needed.

For most typical use,
The database application itself (SQLite here) is <configured> (not modified) to provide a database connection to your application. Configurations are typically detailed in a configuration file and don’t change the database app itself.