Splashy not working

I’ve posted on this topic before but still havent got a solution. I have an old Dell w/i810 chip set. On bootup i get no splash screen only text mode. I have tried vga=ask & several other arguments but still no good. When I do the splashy test I get:
splashy test
linux:# Splashy ERROR: Couldn’t splashy_start_splashy(). Error -2
I also noticed on another computer using the livecd i had an entry for /dev/fb0.On that computer splashy works.On this computer I have no such fb0 device. Does anybody have any ideas on what the problem could be?

/dev/fb0 has to do with the frame buffer. Check out these 2 forum posts and post back .

Getting Splashy To work - openSUSE Forums

Now Low Resolution For Startup - openSUSE Forums

the first post is my first thread. I do have splashy installed and set to run as a service. And according to that grep output these 3 lines would seem to apply to my chipset:
If the first line should be a “y” instead of “m” i have no idea.
The second post i had read several times and have tried all kinds of vga= parameters but always get an “invalid mode” error on bootup if i use any vga= on kernel line in menu.lst. I read in one post how stock kernel doesnt support splashy. But that doesnt seem right cause like I said above I get splashy working fine off of livecd on my other computer and that is a stock kernel no? I just wonder if I even have framebuffering cause how come i dont have a /dev/fb0 entry?

sorry in haste I overlooked that the first posting was from you. Anyways back to your problem. What is the current resolution that your are booting into ?

vga=0x31a (should be in the kernel line of your menu.lst)
also if it is too low for your hardware you can add the right flag to /etc/init.d/boot.local file and the terminal will then be the correct resolution.

ok now to framebuffer. You can make a framebuffer device with ‘mknode’ consult ‘man mknod’ for options. afaik framebuffer device is like a mem type device . This might be tough because you will prolly need to somehow reserve mem to it so it is addressable.

The ‘m’ in your config is that it is loaded as a module. Also could you print out ‘lsmod’ after boot.

here is some more info on framebuffer:
The Linux/m68k Frame Buffer Device

this is your chipset correct?
Information for i810 Users

also maybe try here:

freshmeat.net: Project details for i810 Console Framebuffer

SourceForge.net: i810 Framebuffer Device Driver

I would be surprised though if fb support wasnt already in the suse kernel module for the i810

I have no vga= in my menu.lst:

Modified by YaST2. Last modification on Fri Jun 20 12:25:38 EDT 2008

default 0
timeout 6
##YaST - generic_mbr
gfxmenu (hd0,0)/boot/message
##YaST - activate

###Don’t change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.3 -
root (hd0,0)
kernel /boot/vmlinuz- root=/dev/disk/by-id/scsi-SATA_WDC_WD1600JB-00_WD-WMANM2427772-part1 resume=/dev/sda2 splash=silent showopts
initrd /boot/initrd-
I’ve had tried numerous values for vga= including vga=ask and on reboot I always get an error message stated “unrecognized mode” or something to that effect and all I’m offered is a bunch of text mode resolutions to continue boot with. My lsmod output is:
linux:~> lsmod | sort
Module Size Used by
ac97_bus 6272 1 snd_ac97_codec
af_packet 29064 2
agpgart 35764 2 intel_agp
apparmor 40608 0
ata_piix 21380 3
button 12560 0
cdrom 37020 1 sr_mod
e100 38156 0
edd 12996 0
emu10k1_gp 7808 0
ext3 131848 2
fan 9220 0
firmware_class 13568 2 microcode,snd_emu10k1
fuse 45460 1
gameport 18312 2 emu10k1_gp
i2c_algo_bit 9988 1 i2c_i810
i2c_core 27520 3 i2c_i801,i2c_i810,i2c_algo_bit
i2c_i801 12560 0
i2c_i810 8836 0
iTCO_vendor_support 7812 1 iTCO_wdt
iTCO_wdt 14372 0
intel_agp 27156 1
ip6_tables 17476 3 ip6t_LOG,ip6table_mangle,ip6table_filter
ip6t_LOG 10496 7
ip6t_REJECT 9216 3
ip6table_filter 6784 1
ip6table_mangle 6656 0
ip_tables 16324 3 iptable_mangle,iptable_nat,iptable_filter
ipt_LOG 9984 8
ipt_REJECT 8448 3
iptable_filter 6912 1
iptable_mangle 6784 0
iptable_nat 11140 0
ipv6 268280 17 nf_conntrack_ipv6,ip6t_REJECT,ip6table_mangle
jbd 68148 1 ext3
libata 139216 1 ata_piix
loop 21636 0
mbcache 12292 1 ext3
microcode 15372 0
mii 9344 1 e100
nf_conntrack 61556 5 nf_conntrack_ipv6,xt_state,iptable_nat,nf_nat,nf_conntrack_ipv4
nf_conntrack_ipv4 14856 6 iptable_nat
nf_conntrack_ipv6 22848 4
nf_nat 21912 1 iptable_nat
nfnetlink 9752 4 nf_conntrack_ipv6,nf_nat,nf_conntrack_ipv4,nf_conntrack
parport 37832 1 parport_pc
parport_pc 40764 0
pci_hotplug 33216 1 shpchp
processor 40876 1 thermal
rtc_cmos 12064 0
rtc_core 23048 1 rtc_cmos
rtc_lib 7040 1 rtc_core
scsi_mod 140376 4 sr_mod,sg,sd_mod,libata
sd_mod 31104 4
sg 37036 0
shpchp 35092 0
snd 58164 18 snd_pcm_oss,snd_mixer_oss,snd_seq_midi,snd_emu10k1_synth,snd_emux_synth,snd_seq_virmidi,snd_seq_midi_emul,snd_seq,snd_emu10k1,snd_rawmidi,snd_ac97_codec,snd_pcm,snd_seq_device,snd_timer,snd_util_mem,snd_hwdep
snd_ac97_codec 97060 1 snd_emu10k1
snd_emu10k1 132868 2 snd_emu10k1_synth
snd_emu10k1_synth 11904 0
snd_emux_synth 37760 1 snd_emu10k1_synth
snd_hwdep 13316 2 snd_emux_synth,snd_emu10k1
snd_mixer_oss 20096 1 snd_pcm_oss
snd_page_alloc 14472 2 snd_emu10k1,snd_pcm
snd_pcm 82564 3 snd_pcm_oss,snd_emu10k1,snd_ac97_codec
snd_pcm_oss 50432 0
snd_rawmidi 28416 3 snd_seq_midi,snd_seq_virmidi,snd_emu10k1
snd_seq 54452 5 snd_seq_midi,snd_emux_synth,snd_seq_virmidi,snd_seq_midi_event,snd_seq_midi_emul
snd_seq_device 12172 6 snd_seq_midi,snd_emu10k1_synth,snd_emux_synth,snd_seq,snd_emu10k1,snd_rawmidi
snd_seq_midi 13440 0
snd_seq_midi_emul 10240 1 snd_emux_synth
snd_seq_midi_event 10880 2 snd_seq_midi,snd_seq_virmidi
snd_seq_virmidi 10880 1 snd_emux_synth
snd_timer 26756 3 snd_seq,snd_emu10k1,snd_pcm
snd_util_mem 9088 2 snd_emux_synth,snd_emu10k1
soundcore 11460 1 snd
sr_mod 19492 0
thermal 20872 0
uhci_hcd 27024 0
usbcore 124268 2 uhci_hcd
x_tables 18308 11 ip6t_LOG,xt_pkttype,ipt_LOG,xt_limit,ip6t_REJECT,xt_tcpudp,ipt_REJECT,xt_state,iptable_nat,ip_tables,ip6_tables
xt_limit 6656 15
xt_pkttype 5888 3
xt_state 6528 8
xt_tcpudp 7168 4

In addtion I also notice in one of your links it states “The device is accessed through special device nodes, usually located in the /dev directory, i.e. /dev/fb*.” and I would assume this is a problem seeing as I dont have a /dev/fb0 device node. How would I know if the i810 framebuffer device driver is loaded or even installed?
In regards to my video chipset here is the device section from XF86Config:
Section “Device”
BoardName “82810E CGC”
BusID “0:1:0”
Driver “intel”
Identifier “Device[0]”
Option “usevnc” “no”
Screen 0
VendorName “Intel”

also I Looked in YAST and I see that I have DirectFB 1.0.0. installed. Is that the new equivalent to i810FB?