Splash screen on boot disappeared

After installing nvidia drivers splash on boot disappeared and I see only blinking screen with cursor during boot. Any way to fix this cause splash was very beautiful?! :slight_smile:

Also fonts and buttons on login screen (sddm) become very small for some reason, and I have not found a way to increase them. Any fix for this as well?


The splash issue is possibly the Plymouth core dump issue we’ve been chasing for some time now: openSUSE Bug 1008489.Plymouth doesn’t dump core as often as it used to but, the graphical issue hasn’t been resolved for all hardware configurations.
– on this AMD (pure) desktop it’s OK; on my AMD (pure) laptop the boot splash is still not what it should be . . .

The SDDM issue is possibly due to the NVIDIA graphics unit – as an AMD purist I can’t comment on that issue.

I have the exact same plymouth issue as akontsevich (only plymouth, so issue with sddm), on both my systems with openSUSE Tumbleweed. One is a desktop with AMD graphics, the other is a laptop with intel graphics.
I looked at bug 1008489, but it doesn’t fit: I don’t have any core-dumps.


I had same problem in Mint with NVidia as well.

I still have this issue, it is not fixed: 1008489 – Leap 42.2 RC2 - Plymouth dumps core during booting

Mmm Aleksey I don’t think you have the bug. SIGRTMIN is normal, the bug report talks about core dumps.

Try this at the command line:

sudo journalctl | grep -i plymouth | grep SEGV


sudo journalctl | grep -i plymouth | grep dump

If those command lines don’t return anything you have a different issue (like me).


You are right - returns nothing. So what it the issue about? How to fix?

That’s what I’d like to know, too. :\


Let’s create another bug report?

Well, I thought about it, too. Problem is that I don’t find any error regarding plymouth on my PCs… it’s as if it worked perfectly, but in fact it doesn’t show anything.
But what really stopped me from reporting it until now is that, despite having written about my problem in various areas of this forum, I never got a reply, as if I was the only one with the problem.
At least now we’re two :), so I’m going to try and report it (or you can do it, if you want).


Please report and I’ll add my comments to it too. Could be NVidia bug: why it works fine with noveau?

I found bug 1002875 which seems to be exactly our case.
Please add you own comments so the bug gains some more credibility. Presently it seems that the assignee is not giving it much attention.


Thanks, added my notes there.