SpiderOak incompatible Qt libs in 11.4 after upgrading to KDE 4.6.3

Just a heads up. After upgrading KDE from 4.6.0 to 4.6.3 SpiderOak will fail to run with message

Cannot mix incompatible Qt library (version 0x40703) with this library (version 0x40701)

There’s no more SO package in Non-OSS, apparently due to some support issues. That’s a pity, since Dropbox had conceded access to US agencies, IMO SpiderOak is a really good option, and has been working very nicely until now.

Anyway, Yast tells me that KDE 4.6.0 uses Qt 4.7.1, while 4.6.3 brings in Qt 4.7.3.

A possible solution may be found here, originally for Qt 4.7.2. I’ll try it and report.

OK, linking the three QT libs work. They are either in /usr/lib/ or in usr/lib64, depending on your OS type.

Although yast tells me I have the latest Spider Oak installed (its red, actually) when I run Spider Oak, it says there is a newer version. I download that version but the install fails (with no message) when I click on the rpm. Could these two issues be related?

Yast’s version is not the latest from SO site, but the last version packaged for it, and for 11.3 only, I think. Last time I looked there was no 11.4 package for it in the Non-OSS repos.

The problem I noticed with the site version at the time was that it would install, but give the mentioned error when run (on a terminal). There where no install errors, so your problem is probably something different.

Perhaps if you try to install from yast you’ll get more verbose output on the GUI (I’m not much of a terminal fan myself). To do this I put all RPMs in a directory that I added as a repo in Yast.
Or you could look at yast/zipper logs - I don’t know where, but it shouldn’t be too difficult to find.
Or you could try installing with zipper from a terminal - something I never did as yast works great for me.

Thanks! I never tried this method before, although I heard of it. Now that I tried it, I like it… and the new version of Spider Oak installed.