Spell Checker gives me many false positive

Hi, I run KDE Plasma on Tumbleweed. I have an issue with the spell checker, which underlines (nearly) all the words which end with an accented character: if I right click on one of those words I see an ending “?” character. I notice this behavior in all the applications, not only those which come from KDE, e.g. LibreOffice too. I have the spellchecker on by default in Systemsettings -> Regional Settings -> Spell Check.

Any ideas?
Thank you.

And what language should it check?

Thaks for reply.

cat /etc/locale.conf

Ok, I found the issue: file /usr/share/hunspell/it_IT.dic wasn’t saved in utf-8 format. Now it seems to works!