Speed up Networkmanager daemon startup (get rid of the annoying 30sec countdown)

The networkmanager in openSUSE has a default a timeout to wait before it starts up, which is set to 30sec, because there are some services which may need a valid network setup to startup, not a networkmanager managed one. I don’t know which ones are that services, maybe somebody can light me up.

So this wait is the cause why you see a 30sec countdown in the init process (and need to wait 30 sec if you start your system in runlevel 3), or need to wait to network if your desktop starts up too fast. For me, this cause gnome panel to hang some seconds, while the nm-applet is waiting for the networkmanager to start up.

You can modify the timeout value of this wait my modifying the NM_ONLINE_TIMEOUT variable in /etc/sysconfig/network/config file. By setting it to 0, there will be no wait.

By the way, is in Wiki, or Documentation, or SBL anything about this? I was always a bit confused with the openSUSE documentation, I wish for a wiki as complete and easy to use as the Archlinux’s one, but that’s an another story.


So I gave your modification a try and it did seem to work OK and networkmanager did seem to startup faster for me. When attempting to modify this setting in the sysconfig editor, it would not allow me to change the value of 30 to 0. So I edited the file manually, saved it and did a reboot. To try this modification using KDE, do an Alt-F2 and type the menu Run Command:

kdesu kwrite /etc/sysconfig/network/config

search for the value NM_ONLINE_TIMEOUT and change it from “30” to “0” to look like this:


Save the file and reboot and see what you get.

Thank You,

Well yes, I did not made a very detailed description how to modify the file, my bad, but I presupposed that if somebody starts to modify sysconfig defaults, he/she should know how to edit a file as root :smiley:
I did not found the variable in sysconfig-editor, however I searched it for about a minue only. I found out about this setting while I tried to hack the network init script, because it was really annoying for me to always wait for the networkmanager to start, so I did not played with the sysconfig editor, but with files.
But anyway, I think the easiest way is to modify direct the file.
I’m glad I helped :smiley:

On 06/05/2011 12:36 AM, inp3dance wrote:
> was always a bit confused with the openSUSE documentation, I wish for a
> wiki as complete and easy to use as the Archlinux’s one

i’ve looked at Arch several years back, but have not seen their docs…i
wish the wiki here was better than it is (it was better before it got
“upgraded”, but that is a different story) for now i wanna ask
have you yet found doc.opensuse.org ?

give it a try…

dd CAVEAT: http://is.gd/bpoMD
via NNTP openSUSE 11.4 [] + KDE 4.6.0 + Thunderbird 3.1.10
Acer Aspire One D255, 1.66 GHz Atom, 1 GB RAM, Intel Pineview graphics

  • When your gecko is broken you have a reptile dysfunction! *

I did not know about doc.opensuse.org - Documentation Guides & Manuals, it is a very nice, way easier to use than the official openSuSE documentation, and I think more ample, even if it is a bit outdated.
But it definetely worth the attention.
Well, I think there were two problems solved within this thread, nice :smiley:

I don’t use NetworkManager but Ifup via Yast, but there also seems to be a delay before the network kicks in: Firefox tabs always have to be reloaded manually, and network drives mounted with some delay as a crontab job. Is there a similar setting in Yast network setup that can be used for the same purpose?

Looking at the startup screen, while booting a system which uses NetworkManager, I notice that there is a countdown displayed by NetworkManager.

The first count I saw was 29. Then I saw a 28. Then I saw a 27. And at that point the count ended and booting resumed.

Presumably, that 27 point (3 seconds delay) is when NetworkManager established a connection.

It is looking to me as if the 30 seconds is only a max - a point at which the attempt to connect will timeout, and booting will resume regardless. But if you are connecting more quickly than that, it shouldn’t cause much delay.

In my case, I had a WiFi connection defined as a system connection (setup with the gnome nm-applet as sharable by all users). Apparently, the timeout ended as soon as that connection was established. Presumably for a wired connection, the timeout would end as soon as the DHCP request for an IP address has completed.

As for whether the timeout is really needed - in my case, it probably isn’t. If you are mounting file system shares from the network, then you probably need the delay to avoid a later fail when mounting those file systems.

Look at the /etc/sysconfig/network/config file, as I remember, I saw some similar settings for ifup too.

For me the nm-applet did not connect until the countdown finished, this was mostly the cause why I started to investigate that delay thingy.

I found and played with them, but they didn’t help with my problems, indeed bootup was slowed down by reducing the timeout.