Speed issues with multiple cards/drivers

Some of you may have seen my thread trying to get a RaLink card working. I now have an Atheros (AR5008) based card in here, and have the same speed problem. I’ve put the driver issue to rest (for now), but would like to get more than a few kb/s out of my wireless. It’s embarrassing that my 1’st gen iPod gets 6Mbits/s and my main box only 6Kbits/s.

So, here’s what I’ve got now:

lspci
03:00.0 Network controller: Atheros Communications Inc. AR5008 Wireless Network Adapter (rev 01)

iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan1     IEEE 802.11bgn  ESSID:"CHILAKO"  
          Mode:Managed  Frequency:2.422 GHz  Access Point: 00:18:E7:D4:65:CC   
          Bit Rate=1 Mb/s   Tx-Power=27 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:<snip>
          Power Management:off
          Link Quality=25/70  Signal level=-85 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:349  Invalid misc:1831   Missed beacon:0

As you can see from the above, the Bit Rate is only 1Mb/s. Signal level is not great, but should be enough to get more.

So next I wondered what my router (D-Link DIR-825) is reporting back:

iwlist wlan1 scanning
wlan1     Scan completed :
          Cell 01 - Address: 00:18:E7:D4:65:CC
                    Channel:3
                    Frequency:2.422 GHz (Channel 3)
                    Quality=25/70  Signal level=-85 dBm  
                    Encryption key:on
                    ESSID:"CHILAKO"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=00000000006bd2c4
                    Extra: Last beacon: 50860ms ago
                    IE: Unknown: 00074348494C414B4F
                    IE: Unknown: 010882848B968C129824
                    IE: Unknown: 030103
                    IE: Unknown: 0706434149010B1B
                    IE: Unknown: 200100
                    IE: Unknown: 2A0100
                    IE: Unknown: 3204B048606C
                    IE: Unknown: DD180050F2020101020003A4000027A4000042435E0062322F00
                    IE: Unknown: DD1E00904C334C101BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 2D1A4C101BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: DD1A00904C3403080800000000000000000000000000000000000000
                    IE: Unknown: 3D1603080800000000000000000000000000000000000000
                    IE: Unknown: DD0900037F01010000FF7F
                    IE: Unknown: DD770050F204104A0001101044000102103B00010310470010000000000000100000000018E7D465CC10210006442D4C696E6B1023000D442D4C696E6B20526F75746572102400074449522D383235104200046E6F6E651054000800060050F2040001101100074449522D383235100800020084103C000103
                    IE: Unknown: DD050050F20500

iw wlan1 scan
BSS 00:18:e7:d4:65:cc (on wlan1) -- associated
        TSF: 525440 usec (0d, 00:00:00)
        freq: 2422
        beacon interval: 100
        capability: ESS Privacy ShortPreamble SpectrumMgmt ShortSlotTime (0x0531)
        signal: -84.00 dBm
        last seen: 738 ms ago
        SSID: CHILAKO
        Supported rates: 1.0* 2.0* 5.5* 11.0* 6.0* 9.0 12.0* 18.0 
        DS Parameter set: channel 3
        Country: CA (indoor), data: 01 0b 1b
        Power constraint: 0 dB
        ERP: <no flags>
        Extended supported rates: 24.0* 36.0 48.0 54.0 
        WMM:    * Parameter version 1
                * BE: CW 15-1023, AIFSN 3
                * BK: CW 15-1023, AIFSN 7
                * VI: CW 7-15, AIFSN 2, TXOP 3008 usec
                * VO: acm CW 3-7, AIFSN 2, TXOP 1504 usec
        WPS:     * Version: 1.0
                 * Manufacturer: D-Link
                 * Model: D-Link Router
                 * Device name: DIR-825
                 * Config methods: Label, PBC

At least here I can see 54Mb/s seems to be supported. It should be 108Mb/s since I have 802.11n enabled (and other devices connecting at that speed). I’ll revisit that later when I at least get up into the higher numbers…

So, I poked around a bit more to try and find out why we’re down in the lower registers:

iwlist wlan1 rate
wlan1     unknown bit-rate information.
          Current Bit Rate:1 Mb/s

iw wlan1 station dump
Station 00:18:e7:d4:65:cc (on wlan1)
        inactive time:  11 ms
        rx bytes:       2148294
        rx packets:     13523
        tx bytes:       628659
        tx packets:     3039
        signal:         -85 dBm
        tx bitrate:     1.0 MBit/s

iw wlan1 link
Connected to 00:18:e7:d4:65:cc (on wlan1)
        SSID: CHILAKO
        freq: 2422
        RX: 85004 bytes (584 packets)
        TX: 29190 bytes (116 packets)
        signal: -83 dBm
        tx bitrate: 5.5 MBit/s


Note that the last one had a slightly higher bitrate. I watched that number a few times and noticed that it changes over time, max I saw was 11Mbit/s.

Could this be a signal strength issue? Am I chasing a software problem where none exist perhaps? I would have thought my NIC with 3 external antennas would do a better job than my iPod…

On 06/29/2011 12:36 AM, Elrin wrote:
>
> Some of you may have seen my thread trying to get a RaLink card working.
> I now have an Atheros (AR5008) based card in here, and have the same
> speed problem. I’ve put the driver issue to rest (for now), but would
> like to get more than a few kb/s out of my wireless. It’s embarrassing
> that my 1’st gen iPod gets 6Mbits/s and my main box only 6Kbits/s.
>
> So, here’s what I’ve got now:
>
>
> Code:
> --------------------
> lspci
> 03:00.0 Network controller: Atheros Communications Inc. AR5008 Wireless Network Adapter (rev 01)
>
> iwconfig
> lo no wireless extensions.
>
> eth0 no wireless extensions.
>
> wlan1 IEEE 802.11bgn ESSID:“CHILAKO”
> Mode:Managed Frequency:2.422 GHz Access Point: 00:18:E7:D4:65:CC
> Bit Rate=1 Mb/s Tx-Power=27 dBm
> Retry long limit:7 RTS thr:off Fragment thr:off
> Encryption key:<snip>
> Power Management:off
> Link Quality=25/70 Signal level=-85 dBm
> Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
> Tx excessive retries:349 Invalid misc:1831 Missed beacon:0
>
> --------------------
>
>
> As you can see from the above, the Bit Rate is only 1Mb/s. Signal level
> is not great, but should be enough to get more.
>
> So next I wondered what my router (D-Link DIR-825) is reporting back:
>
>
> Code:
> --------------------
> iwlist wlan1 scanning
> wlan1 Scan completed :
> Cell 01 - Address: 00:18:E7:D4:65:CC
> Channel:3
> Frequency:2.422 GHz (Channel 3)
> Quality=25/70 Signal level=-85 dBm
> Encryption key:on
> ESSID:“CHILAKO”
> Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
> 9 Mb/s; 12 Mb/s; 18 Mb/s
> Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
> Mode:Master
> Extra:tsf=00000000006bd2c4
> Extra: Last beacon: 50860ms ago
> IE: Unknown: 00074348494C414B4F
> IE: Unknown: 010882848B968C129824
> IE: Unknown: 030103
> IE: Unknown: 0706434149010B1B
> IE: Unknown: 200100
> IE: Unknown: 2A0100
> IE: Unknown: 3204B048606C
> IE: Unknown: DD180050F2020101020003A4000027A4000042435E0062322F00
> IE: Unknown: DD1E00904C334C101BFFFF000000000000000000000000000000000000000000
> IE: Unknown: 2D1A4C101BFFFF000000000000000000000000000000000000000000
> IE: Unknown: DD1A00904C3403080800000000000000000000000000000000000000
> IE: Unknown: 3D1603080800000000000000000000000000000000000000
> IE: Unknown: DD0900037F01010000FF7F
> IE: Unknown: DD770050F204104A0001101044000102103B00010310470010000000000000100000000018E7D465CC10210006442D4C696E6B1023000D442D4C696E6B20526F75746572102400074449522D383235104200046E6F6E651054000800060050F2040001101100074449522D383235100800020084103C000103
> IE: Unknown: DD050050F20500
>
> iw wlan1 scan
> BSS 00:18:e7:d4:65:cc (on wlan1) – associated
> TSF: 525440 usec (0d, 00:00:00)
> freq: 2422
> beacon interval: 100
> capability: ESS Privacy ShortPreamble SpectrumMgmt ShortSlotTime (0x0531)
> signal: -84.00 dBm
> last seen: 738 ms ago
> SSID: CHILAKO
> Supported rates: 1.0* 2.0* 5.5* 11.0* 6.0* 9.0 12.0* 18.0
> DS Parameter set: channel 3
> Country: CA (indoor), data: 01 0b 1b
> Power constraint: 0 dB
> ERP:<no flags>
> Extended supported rates: 24.0* 36.0 48.0 54.0
> WMM: * Parameter version 1
> * BE: CW 15-1023, AIFSN 3
> * BK: CW 15-1023, AIFSN 7
> * VI: CW 7-15, AIFSN 2, TXOP 3008 usec
> * VO: acm CW 3-7, AIFSN 2, TXOP 1504 usec
> WPS: * Version: 1.0
> * Manufacturer: D-Link
> * Model: D-Link Router
> * Device name: DIR-825
> * Config methods: Label, PBC
>
> --------------------
>
>
> At least here I can see 54Mb/s seems to be supported. It should be
> 108Mb/s since I have 802.11n enabled (and other devices connecting at
> that speed). I’ll revisit that later when I at least get up into the
> higher numbers…
>
> So, I poked around a bit more to try and find out why we’re down in the
> lower registers:
>
>
> Code:
> --------------------
> iwlist wlan1 rate
> wlan1 unknown bit-rate information.
> Current Bit Rate:1 Mb/s
>
> iw wlan1 station dump
> Station 00:18:e7:d4:65:cc (on wlan1)
> inactive time: 11 ms
> rx bytes: 2148294
> rx packets: 13523
> tx bytes: 628659
> tx packets: 3039
> signal: -85 dBm
> tx bitrate: 1.0 MBit/s
>
> iw wlan1 link
> Connected to 00:18:e7:d4:65:cc (on wlan1)
> SSID: CHILAKO
> freq: 2422
> RX: 85004 bytes (584 packets)
> TX: 29190 bytes (116 packets)
> signal: -83 dBm
> tx bitrate: 5.5 MBit/s
>
>
> --------------------
>
>
> Note that the last one had a slightly higher bitrate. I watched that
> number a few times and noticed that it changes over time, max I saw was
> 11Mbit/s.
>
> Could this be a signal strength issue? Am I chasing a software problem
> where none exist perhaps? I would have thought my NIC with 3 external
> antennas would do a better job than my iPod…

It could very well be a signal-strength issue. The reported values are only
relative, but I doubt if many of my wireless devices would even connect at less
than -80 dBm.

There have been some recent patches to the Atheros code base fixing a problem
with 3 antennas. I don’t know the details, only the titles of the patches. Those
changes will eventually make it into the oS compat-wireless package, but are not
there yet.

We can check the statistics table for the interface with


ADDRESS=$(find /sys -name rc_stats)
cat $ADDRESS

The result will look like


rate     throughput  ewma prob   this prob  this succ/attempt   success    attempts
P  1         0.9       98.9      100.0          0(  0)         49          49
2         0.4       25.0      100.0          0(  0)          1           1
5.5       1.2       25.0      100.0          0(  0)          1           1
11         2.3       25.0      100.0          0(  0)          1           1
6         1.4       25.0      100.0          0(  0)          1           1
9         2.1       25.0      100.0          0(  0)          1           1
12         0.0        0.0        0.0          0(  0)          0           0
t  18         4.0       25.0      100.0          0(  0)          1           1
24         0.0        0.0        0.0          0(  0)          0           0
36         0.0        0.0        0.0          0(  0)          0           0
48         0.0        0.0        0.0          0(  0)          0           0
T   54        40.9       94.3      100.0          1(  1)         87          87

Total packet count::    ideal 135      lookaround 7

Note: The above table was for a device that was just started. Please post your
table inside “code” flags.

Hmmm…

I tried your commands, and got no output.
I also tried:
ADDRESS=$(find /sys -iname rc_stats)
cat $ADDRESS

… and even find /sys | grep rc_stats

There seems to be no file called rc_stats in /sys (or /proc, where I also checked).

Incidentally, I moved my system closer to the modem, and the speed did improve (Woohoo!).

However, I do still get flakey connectivity. I now get:

iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan1     IEEE 802.11bgn  ESSID:"CHILAKO"  
          Mode:Managed  Frequency:2.422 GHz  Access Point: 00:18:E7:D4:65:CC   
          Bit Rate=54 Mb/s   Tx-Power=27 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:6772-6565-6E
          Power Management:off
          Link Quality=34/70  Signal level=-76 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:25  Invalid misc:2541   Missed beacon:0

What are the “Invalid misc” and “Tx excessive retries”?

I also get an average of 30 to 40% packet loss to my AP. Something still fishy? Perhaps to do with the three antennas?

On 06/29/2011 11:36 PM, Elrin wrote:
>
> Hmmm…
>
> I tried your commands, and got no output.
> I also tried:
> ADDRESS=$(find /sys -iname rc_stats)
> cat $ADDRESS
>
> … and even find /sys | grep rc_stats
>
> There seems to be no file called rc_stats in /sys (or /proc, where I
> also checked).

Your system does not have debugging turned on. That is a lousy configuration.

> Incidentally, I moved my system closer to the modem, and the speed did
> improve (Woohoo!).
>
> However, I do still get flakey connectivity. I now get:
>
>
> Code:
> --------------------
> iwconfig
> lo no wireless extensions.
>
> eth0 no wireless extensions.
>
> wlan1 IEEE 802.11bgn ESSID:“CHILAKO”
> Mode:Managed Frequency:2.422 GHz Access Point: 00:18:E7:D4:65:CC
> Bit Rate=54 Mb/s Tx-Power=27 dBm
> Retry long limit:7 RTS thr:off Fragment thr:off
> Encryption key:6772-6565-6E
> Power Management:off
> Link Quality=34/70 Signal level=-76 dBm
> Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
> Tx excessive retries:25 Invalid misc:2541 Missed beacon:0
> --------------------
>
>
> What are the “Invalid misc” and “Tx excessive retries”?

Excessive retries are those that failed completely even with the maximum number
of tries. I do not know what the driver calls “misc” failures. BTW, you just
published the key to your encryption; however, with WEP it doesn’t make much
difference.

> I also get an average of 30 to 40% packet loss to my AP. Something
> still fishy? Perhaps to do with the three antennas?

Yes, with pings, you should not exceed 1% loss. For example, my current system
shows:

finger@larrylap:~> iwconfig wlan0
wlan18 802.11bgn ESSID:“lwfdjf-n” Nickname:“rtl8192E”
Mode:Managed Frequency=2.422 GHz Access Point: XX:XX:XX:XX:XX:XX
Bit Rate=135 Mb/s
Retry:on RTS thr:off Fragment thr:off
Power Management period:0us mode:All packets received
Link Quality=93/100 Signal level=-52 dBm Noise level=-116 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

finger@larrylap:~> ifconfig wlan0
wlan0 Link encap:Ethernet HWaddr 00:24:D2:XX:XX:XX
inet addr:192.168.1.105 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::224:d2ff:XXXX:XXXX/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:13810 errors:0 dropped:0 overruns:0 frame:0
TX packets:10528 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:8234985 (7.8 Mb) TX bytes:1261841 (1.2 Mb)
Interrupt:20 Memory:ffffc90002258000-ffffc90002258100

Note that I have no losses and I can transmit at 51 Mb/s (802.11n connection),
which is nearly as good as a 100Mb/s wire.

I just went back and read the mail thread regarding the third antenna. That user
had a 3x3 device, but only two antennas and wanted to know how to disable the
3rd stream. Obviously, that does not apply to you.

The only other things I can suggest are that you try the 2.6.39 kernel from
http://download.opensuse.org/repositories/Kernel:/HEAD/openSUSE_11.4, or that
you get the compat-wireless package for your 2.6.37 kernel.

I changed over to WPA2 (my original reason for WEP is no longer with me), and at least “officially” have higher speeds now, connecting at 802.11n. However, the packet loss is still at 30-40%.

I checked with another computer to eliminate my AP from the equation, and on two other devices had 0% packet loss. One of these was a borrowed openSUSE box running an atheros based card on openSuSE 11.3!

Also, about “Your system does not have debugging turned on. That is a lousy configuration.”: So the out-of-the-box openSUSE doesn’e have it turned on. How do I get it on? I’m assuming this involves installing the debug version of some packages, but I’m not sure which ones…

I checked - I already have the compat-wireless package installed (I think):

zypper info compat-wireless-kmp-desktop
Loading repository data...
Reading installed packages...


Information for package compat-wireless-kmp-desktop:

Repository: @System
Name: compat-wireless-kmp-desktop
Version: 2.6.38.2_k2.6.37.6_0.5-2.1
Arch: x86_64
Vendor: obs://build.opensuse.org/driver:wireless
Installed: Yes
Status: up-to-date
Installed Size: 10.2 MiB
Summary: Kernel modules for several WLAN adapters from linuxwireless.org
Description: 
This package contains recent kernel modules for several WLAN Adapters from linuxwireless.org
based on the new mac80211-Stack.

The sources are taken from


http://www.linuxwireless.org/en/users/Download/stable/

Update:
I did some searching on packet loss and ath9k, and found a post on ubuntuforums.org/archive/index.php/t-1740056.html that suggests running the ath9k module with nohwcrypt=1 via the command:
echo “options ath9k nohwcrypt=1” > /etc/modprobe.d/ath9k.conf

Obviously, in openSUSE, ath9k.conf is not used, so I tried adding “nohwcrypt=1” to the options in NetworkManager, without success. Any idea what the nohwcrypt option does, and if it still is relevant?

On 07/01/2011 01:36 AM, Elrin wrote:
>
> Update:
> I did some searching on packet loss and ath9k, and found a post on
> ubuntuforums.org/archive/index.php/t-1740056.html that suggests running
> the ath9k module with nohwcrypt=1 via the command:
> echo “options ath9k nohwcrypt=1”> /etc/modprobe.d/ath9k.conf
>
> Obviously, in openSUSE, ath9k.conf is not used, so I tried adding
> “nohwcrypt=1” to the options in NetworkManager, without success. Any
> idea what the nohwcrypt option does, and if it still is relevant?

nohwcrypt means “no hardware encryption”, i.e. do encryption in software. That
option adds a little to the cpu load, but it gets around any problems in the
firmware.

You can test if this option helps with the following


sudo /sbin/modprobe -rv ath9k
sudo /sbin/modprobe -v ath9k options nohwcrypt=1

If that helps, then (as root) create a file /etc/modprobe.d/50-ath9k.conf
containing a line of the following “options ath9k nohwcrypt=1” (no ", of
course). That will apply the option every time the module is loaded.

If you use the command ‘/sbin/modinfo ath9k’, you will see what options
(parameters) the driver will accept and their meanings.

Oops! That killed my Internet connection. Posting from my iPod now.

Modprobe removed the module (and it’s dePendants), but the next one did not load it again, complaining about “Unknown symbol in module”.

I tried just a Plain modprobe, but I only had a connection for about one minute before it stopped responding. Been dead ever since. I do notice that I now have for the first time, also a wifi0 interface showing up that did not do so before.

I’ll try all kinds of things to get the connection back. Wish me luck!

Ok - I’m back online with my openSuse machine, so I can report back on the whole saga:

So when I tried:

/sbin/modprobe -rv ath9k
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/net/mac80211/mac80211.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/compat/compat.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k_common.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k_hw.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/net/wireless/cfg80211.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/kernel/net/rfkill/rfkill.ko
linux-jwdo:/home/elrin # /sbin/modprobe -v ath9k options nohwcrypt=1
insmod /lib/modules/2.6.37.6-0.5-desktop/kernel/net/rfkill/rfkill.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/net/wireless/cfg80211.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k_hw.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k_common.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/compat/compat.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/net/mac80211/mac80211.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k.ko options nohwcrypt=1
FATAL: Error inserting ath9k (/lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k.ko): Unknown symbol in module, or unknown parameter (see dmesg)

After this, I could not get it to re-load even without the “options nohwcrypt=1”, so I rebooted.
Unfortunately that was not the end of it. I checked if we were up - and it seemed to be the case. Note that iwconfig now had a very low connection speed shown, Groaning “not again”, I did a ping:

ifconfig
ath0      Link encap:Ethernet  HWaddr 1C:BD:B9:D6:5C:F0  
          inet addr:192.168.0.112  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::1ebd:b9ff:fed6:5cf0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:264 errors:0 dropped:0 overruns:0 frame:0
          TX packets:499 errors:1 dropped:1 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:24938 (24.3 Kb)  TX bytes:44986 (43.9 Kb)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4504 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4504 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:203561 (198.7 Kb)  TX bytes:203561 (198.7 Kb)

wifi0     Link encap:UNSPEC  HWaddr 1C-BD-B9-D6-5C-F0-00-00-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2157 errors:0 dropped:0 overruns:0 frame:82
          TX packets:948 errors:476 dropped:1 overruns:0 carrier:0
          collisions:0 txqueuelen:280 
          RX bytes:608803 (594.5 Kb)  TX bytes:90297 (88.1 Kb)
          Interrupt:17 

linux-jwdo:/home/elrin # iwconfig
lo        no wireless extensions.

wifi0     no wireless extensions.

ath0      IEEE 802.11g  ESSID:"CHILAKO"  
          Mode:Managed  Frequency:2.417 GHz  Access Point: 00:18:E7:D4:65:CC   
          Bit Rate:6 Mb/s   Tx-Power:19 dBm   Sensitivity=1/1  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:<snip>   Security mode:restricted
          Power Management:off
          Link Quality=24/70  Signal level=-72 dBm  Noise level=-96 dBm
          Rx invalid nwid:362  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

linux-jwdo:/home/elrin # ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.
64 bytes from 192.168.0.1: icmp_req=1 ttl=64 time=75.1 ms
64 bytes from 192.168.0.1: icmp_req=2 ttl=64 time=3.94 ms
64 bytes from 192.168.0.1: icmp_req=3 ttl=64 time=9.45 ms
64 bytes from 192.168.0.1: icmp_req=4 ttl=64 time=11.7 ms
64 bytes from 192.168.0.1: icmp_req=5 ttl=64 time=2.74 ms
64 bytes from 192.168.0.1: icmp_req=6 ttl=64 time=5.51 ms
64 bytes from 192.168.0.1: icmp_req=7 ttl=64 time=1.02 ms
64 bytes from 192.168.0.1: icmp_req=8 ttl=64 time=1.29 ms
64 bytes from 192.168.0.1: icmp_req=9 ttl=64 time=7.74 ms
64 bytes from 192.168.0.1: icmp_req=10 ttl=64 time=23.5 ms
64 bytes from 192.168.0.1: icmp_req=11 ttl=64 time=2.66 ms
64 bytes from 192.168.0.1: icmp_req=12 ttl=64 time=2.73 ms
64 bytes from 192.168.0.1: icmp_req=13 ttl=64 time=61.3 ms
64 bytes from 192.168.0.1: icmp_req=14 ttl=64 time=3.79 ms
64 bytes from 192.168.0.1: icmp_req=15 ttl=64 time=4.93 ms
64 bytes from 192.168.0.1: icmp_req=16 ttl=64 time=2.23 ms
64 bytes from 192.168.0.1: icmp_req=17 ttl=64 time=22.8 ms
64 bytes from 192.168.0.1: icmp_req=18 ttl=64 time=180 ms
64 bytes from 192.168.0.1: icmp_req=19 ttl=64 time=9.90 ms
^C
--- 192.168.0.1 ping statistics ---
78 packets transmitted, 19 received, 75% packet loss, time 77030ms
rtt min/avg/max/mdev = 1.023/22.779/180.126/42.035 ms

Seeing those icmp_req numbers sequentially go up actually looked great, but then it suddenly stopped, and stayed dead indefinitely (100% packet loss). Notice the new wifi0 interface? Where did that come from?

So I tried:

linux-jwdo:/home/elrin # /sbin/modprobe -v ath9k
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k.ko 

Network connected! (checked briefly with ping and 30% packet loss) So, then I tried the modprobe again without the word “options”:

linux-jwdo:/home/elrin # /sbin/modprobe -rv ath9k
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/net/mac80211/mac80211.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/compat/compat.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k_common.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k_hw.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/net/wireless/cfg80211.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/kernel/net/rfkill/rfkill.ko
linux-jwdo:/home/elrin # /sbin/modprobe -v ath9k nohwcrypt=1
insmod /lib/modules/2.6.37.6-0.5-desktop/kernel/net/rfkill/rfkill.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/net/wireless/cfg80211.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k_hw.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k_common.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/compat/compat.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/net/mac80211/mac80211.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k.ko nohwcrypt=1

Hmmmm - seems to have loaded. However, network was down. (100% packet loss)

So I tried:

linux-jwdo:/home/elrin # /sbin/modprobe -rv ath9k
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/net/mac80211/mac80211.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/compat/compat.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k_common.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k_hw.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/net/wireless/cfg80211.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/kernel/net/rfkill/rfkill.ko
linux-jwdo:/home/elrin # /sbin/modprobe -v ath9k
insmod /lib/modules/2.6.37.6-0.5-desktop/kernel/net/rfkill/rfkill.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/net/wireless/cfg80211.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k_hw.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k_common.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/compat/compat.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/net/mac80211/mac80211.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k.ko 

Huh? Loaded differently than before on /sbin/modprobe -v ath9k. Network was still down. Now I got “Destination Host Unreachable”:

ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.
From 192.168.0.112 icmp_seq=1 Destination Host Unreachable
From 192.168.0.112 icmp_seq=4 Destination Host Unreachable
^C
--- 192.168.0.1 ping statistics ---
5 packets transmitted, 0 received, +2 errors, 100% packet loss, time 4001ms

That’s when I posted the above reply from my iPod.

To get back online, in the meantime, I deleted everything from NetworkManager, unloaded all the modules, went back into NetworkManager, deleted them again, exited NetworkManager, went back in and loaded the ath-pci driver. No connection, so I unloaded the driver and deleted the interface from NetworkManager again, and re-tried afresh with the ath9k driver. At least I’m back online, but with the 'ol 30% packet loss…I have to admit I’m kinda scared to try that nohwcrypt option again… Hehe…

Success!

I took a deep breath, and did the modprobe again, without the “options”, and it worked. I now get sweet 0% packet loss! CPU is a bit busier, but I can live with that for now.

linux-jwdo:/home/elrin # /sbin/modprobe -rv ath9k
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/net/mac80211/mac80211.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/compat/compat.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k_common.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k_hw.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/net/wireless/cfg80211.ko
rmmod /lib/modules/2.6.37.6-0.5-desktop/kernel/net/rfkill/rfkill.ko
linux-jwdo:/home/elrin # /sbin/modprobe -v ath9k nohwcrypt=1
insmod /lib/modules/2.6.37.6-0.5-desktop/kernel/net/rfkill/rfkill.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/net/wireless/cfg80211.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k_hw.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k_common.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/compat/compat.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/net/mac80211/mac80211.ko 
insmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k.ko nohwcrypt=1

One question though: You recommended:

If that helps, then (as root) create a file /etc/modprobe.d/50-ath9k.conf
containing a line of the following “options ath9k nohwcrypt=1” (no ", of
course). That will apply the option every time the module is loaded.

If the word “options” screwed up the manual modprobe, should I also omit it in the .conf file? I see most of the other .conf files start with options…

On 07/01/2011 08:06 PM, Elrin wrote:
>
> Success!
>
> I took a deep breath, and did the modprobe again, without the
> “options”, and it worked. I now get sweet 0% packet loss! CPU is a bit
> busier, but I can live with that for now.
>
>
> Code:
> --------------------
> linux-jwdo:/home/elrin # /sbin/modprobe -rv ath9k
> rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k.ko
> rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/net/mac80211/mac80211.ko
> rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/compat/compat.ko
> rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k_common.ko
> rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k_hw.ko
> rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath.ko
> rmmod /lib/modules/2.6.37.6-0.5-desktop/updates/net/wireless/cfg80211.ko
> rmmod /lib/modules/2.6.37.6-0.5-desktop/kernel/net/rfkill/rfkill.ko
> linux-jwdo:/home/elrin # /sbin/modprobe -v ath9k nohwcrypt=1
> insmod /lib/modules/2.6.37.6-0.5-desktop/kernel/net/rfkill/rfkill.ko
> insmod /lib/modules/2.6.37.6-0.5-desktop/updates/net/wireless/cfg80211.ko
> insmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath.ko
> insmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k_hw.ko
> insmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k_common.ko
> insmod /lib/modules/2.6.37.6-0.5-desktop/updates/compat/compat.ko
> insmod /lib/modules/2.6.37.6-0.5-desktop/updates/net/mac80211/mac80211.ko
> insmod /lib/modules/2.6.37.6-0.5-desktop/updates/drivers/net/wireless/ath/ath9k/ath9k.ko nohwcrypt=1
> --------------------
>
>
> One question though: You recommended:
>
>> If that helps, then (as root) create a file
>> /etc/modprobe.d/50-ath9k.conf
>> containing a line of the following “options ath9k nohwcrypt=1” (no ",
>> of
>> course). That will apply the option every time the module is loaded.
>
> If the word “options” screwed up the manual modprobe, should I also
> omit it in the .conf file? I see most of the other .conf files start
> with options…

You need the “options” in the .conf file. Sorry for the wrong advice on the
modprobe command. I always put my options in a .conf file.

Don’t worry about the options mistake - I would’ve made a few more serious ones doing this by myself…

Thanks for the assistance! Without your help it would have taken me a lot longer to figure out.