Spectacle incorrect date format

Spectacle incorrect date format

Anyone else having the same Spectacle problem?
On my computer, the date format is always the same “Screenshot_%Y%M%D_%H%m%S.jpg”.
The language of my computer is Finnish.

Operating System: openSUSE Tumbleweed 20240409
KDE Plasma Version: 6.0.3
KDE Frameworks Version: 6.0.0
Qt Version: 6.7.0
Kernel Version: 6.8.4-rc1-1-default (64-bit)
Graphics Platform: X11
Information for package spectacle:
----------------------------------
Repository     : Pääasennuslähde (OSS)
Name           : spectacle
Version        : 24.02.1-1.3
Arch           : x86_64
Vendor         : openSUSE
Installed Size : 2.1 MiB
Installed      : Yes (automatically)
Status         : up-to-date
Source package : spectacle-24.02.1-1.3.src
Upstream URL   : https://apps.kde.org/spectacle
Summary        : Screen Capture Program
Description    : 
    Spectactle is a screenshot-taking program made by KDE. It allows taking screenshots
    of screens, windows, regions of the screen, and to export them to files or other
    online services.

What is the issue? This is the standard time format for Spectacle which can easily be changed in Spectacle settings. Works here…
Did you ever check the Spectacle settings?

Why isn’t it already right? In other applications I’ve used, the date format is correct.
It should be of the form date: 11.4.2024 time: 16.24.

No. Not every program needs to follow your locale setting. This is the file naming scheme and not a locale related issue.
As you can easily see at the screenshot, a filename does not only contain a date. It can be created out of several placeholders.

If you don’t like it, you can make an upstream change request/bugreport at Kde.org

Alright. I change the Spectacle file naming rules.

Why are you so rude? I felt bad because I thought I asked a valid question. :frowning_face:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.