Special characters in Skype

Typing special characters in skype doesn’t work.

My locale:

LANG=nb_NO.UTF-8
LC_CTYPE=“nb_NO.UTF-8”
LC_NUMERIC=“nb_NO.UTF-8”
LC_TIME=“nb_NO.UTF-8”
LC_COLLATE=“nb_NO.UTF-8”
LC_MONETARY=“nb_NO.UTF-8”
LC_MESSAGES=“nb_NO.UTF-8”
LC_PAPER=“nb_NO.UTF-8”
LC_NAME=“nb_NO.UTF-8”
LC_ADDRESS=“nb_NO.UTF-8”
LC_TELEPHONE=“nb_NO.UTF-8”
LC_MEASUREMENT=“nb_NO.UTF-8”
LC_IDENTIFICATION=“nb_NO.UTF-8”
LC_ALL=

Typing the characters æ ø å gives me æ ø Ã¥
However copy-paste æøå over to skype works fine. It also displays these characters correctly from others.

I have installed Skype 4.1.0.20 on Opensuse 12.3 with the RPM package from Skype. It has installed a bunch of 32bit libraries.

On 05/15/2013 03:26 PM, DJViking wrote:
> Typing the characters æ ø å gives me æ ø Ã¥
> However copy-paste æøå over to skype works fine.

if you type æ ø å into . . . WELL you didn’t mention it but i guess
you use a DE, right? so, if you type into KWrite (if you have it)
do you get the correct letters in it?

and, the person on the other end of Skype, what letter do they see?
that is do they see æ ø å, or æ ø Ã¥, or something else entirely?

btw, if Skype works otherwise i personally wouldn’t mess with it too
much (else break it) and use a work around, like: ae, oe, aa…

please always tell the DE you use.


dd

On 2013-05-15 15:37, dd wrote:
> btw, if Skype works otherwise i personally wouldn’t mess with it too
> much (else break it) and use a work around, like: ae, oe, aa…

Skype is basically a Windows software, currently owned by Microsoft. We
are fortunate that there is a Linux version that is maintained and it
works - don’t ask it for luxuries :-p

Like having a 3 people talk: video goes out. License issue, I believe.

If the keyboard issue can be verified on different desktops, then the
issue should be reported to Microsoft - if they listen. I have someone
nagging me for weeks why he can no longer use his hotmail account with
Thunderbird. Official response from Microsoft (they own hotmail): we do
not support Thunderbird, ask them. Use outlook instead).


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Carlos E. R. wrote:
> I have someone
> nagging me for weeks why he can no longer use his hotmail account with
> Thunderbird. Official response from Microsoft (they own hotmail): we do
> not support Thunderbird, ask them. Use outlook instead).

Sounds like something useful the EU could chase up …

I am using the latest and greatest of KDE 4.10.

Typing these special characters everywhere else in KDE and other Apps works.

When I type æ ø å, both myself and the recipient sees æ ø Ã¥,

I found a hack solution that works for now:

user@machine:~> export LC_ALL=“no_NO.ISO-8859-1”
user@machine:~> skype

Now when I type these characters in Skype it displays correctly both for me and my recipients.

However I don’t like this fix. I want to be able to use my system default locale which is UTF-8

On 05/15/2013 05:26 PM, DJViking wrote:
> Typing these special characters everywhere else in KDE and other Apps
> works.

then i would say/guess the problem is in Skype, and not openSUSE or KDE…

suggest you post to/consult with https://support.skype.com/

on the other hand there are thousands and thousands of folks using
Skype on openSUSE who have not mentioned the problem…

i myself have not seen it and i’m pretty sure i have typed all of
these with no ill effect: Jeg vil købe den næste øl eller ål

if you PM me your skype ID i will skriver til dig.


dd

What locale setting do you use when running Skype?

> What locale setting do you use when running Skype?

in Skype setup i have:
-“Set program language to:” English(English)

my openSUSE system language is set for English (US)
System Country: USA
Clock/Time zone is set to
-Region: Europe
-Time zone: Denmark

Keyboard: Danish


denverd@linux-os114:~> locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=


dd

On 2013-05-15 16:56, Dave Howorth wrote:
> Carlos E. R. wrote:
>> I have someone
>> nagging me for weeks why he can no longer use his hotmail account with
>> Thunderbird. Official response from Microsoft (they own hotmail): we do
>> not support Thunderbird, ask them. Use outlook instead).
>
> Sounds like something useful the EU could chase up …

Dunno… they claim that the failure is inside Thunderbird, not their
fault nor business.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Setting my locale to en_US.UTF-8 didn’t work in respect to skype


username@machine:~> locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=en_US.UTF-8
username@machine:~> skype

It only works with no_NO.ISO-8859-1

On 05/21/2013 12:26 PM, DJViking wrote:
>

> Setting my locale to en_US.UTF-8 didn’t work in respect to skype

i am not at all surprised about that!

six days ago i wrote “suggest you post to/consult with
https://support.skype.com/” and now i wonder what did the Skype
people say?

> It only works with no_NO.ISO-8859-1

does that mean it working ok now?

if not, what happens if you use YaST to create a new test user, then
log out as yourself and back in as the new user–can you then use
æåøÆÅØ in Skype ok??


dd