Speaking with Ventrilo

I got Ventrilo working through wine and I can hear people talk however Ventrilo is using my sound card, Creative XFi. My microphone is a cheap usb microphone, yet it works. I can open up some sound recording software and record just fine. The main problem I am having is making Ventrilo use my headset instead of my sound card. Does anyone know of a command to pass through wine that would make it use my headset instead of my sound card?

See if this works for ya

Copy msgsm32.acm from the C: \Windows\System32 folder

…Paste in /home/myself/.wine/drive_c/windows/system32…Replace “myself” with your login
4.> Open System.ini in /home/myself/.wine/drive_c/windows/ and add the following line MSACM.msgsm610=msgsm32.acm.

Did that, didn’t do anything. The main thing that I need is either something to pass through wine when running Vent to make it use my headset device instead of my sound card.

Was browsing and found some environmental variables for wine.
AUDIODEV=[audio device]
MIXERDEV=[mixer device]
Which I believe would work, im just not sure how to set environmental variables.

did you try winecfg?

Ive ran winecfg I turned on OSS since most of my soundhardware currently isn’t working under ALSA. And I found out how to make wine use my headset. By setting some environmental variables with the command:

env AUDIODEV=/dev/dsp1 MIXERDEV=/dev/mixer1 wine /home/allen/Ventrilo/Ventrilo.exe

After doing that I can hear voices through my headset. The problem that I am having now is that I alternate between people not hearing me but me hearing them and people hearing me but me not hearing them.

From Ventrilo I am getting the errors:
“VoiceCommMixerStart: Invalid voice mux selection.”
“Faled to open input device. Another program might have it open already.”

Im not sure what the first one means and on the second Ventrilo is the only thing that should be open and using the input device.