speaker sound stops after a minute

On a Thinkpad X201, with the soundcard

00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
	Subsystem: Lenovo Device 215e
	Flags: bus master, fast devsel, latency 0, IRQ 27
	Memory at f2520000 (64-bit, non-prefetchable) [size=16]
	Capabilities: [50] Power Management version 2
	Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
	Capabilities: [100] Virtual Channel
	Capabilities: [130] Root Complex Link
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel

the sound stops after around a minute when using speakers and the speaker sound does not return.

Till, as a superuser, the commands

echo 1 | tee /sys/module/snd_hda_intel/parameters/power_save
echo Y | tee /sys/module/snd_hda_intel/parameters/power_save_controller

are invoked and a couple of seconds pass.

Then the sound returns, but stops, as before, after around a minute.

The sound of the headphones works at every moment perfectly.

That the sound stopped neither happened, before upgrading, under OpenSUSE 42.3 nor does it currently happen under Windows 10.

Does anyone have any idea how to fix this issue for good? Thank you very much![/size]

To clarify: speakers referred to the internal speakers of the Notebook.

As explained in https://askubuntu.com/questions/912848/identify-element-requesting-sound-chip-to-sleep the power state of node 0x1f is set from D0 to D3 due to overheating of the audio controller. But why did it work fine under OpenSUSE 42.3 and why does it work fine under Windows 10?

Have you considered making the changes permanent with something like the following (eg /etc/modprobe.d/intel.conf)?

options snd_hda_intel power_save=1 power_save_controller=Y

Then the desired settings will be applied at boot.

FWIW, users are usually looking to to the opposite ie disable power management with

options snd_hda_intel power_save=0 power_save_controller=N