Sounds mutes/unmutes continuously, 11.3 on ASRock M3A770DE

My sound keeps going on and off, with some variation but generally about twice a second. I can watch the speaker icon in the system tray with a red x appearing and going away. When I play anything the sound is very broken.

I’m running on an ASRock M3A770DE uploaded my ALSA information: I’ve tried a number of things to attempt to correct the problem, but nothing I’ve tried makes any difference.

This MB does have two separate sound devices, I think. This shows up in YAST/Hardware/Sound with one entry as “ATI Technologies Inc.” and the other as “SBx00 Azalia (Intel HDA)”. I’ve tried disabling each one separately, but that doesn’t seem to make any difference. The description of the board says it has “7.1 CH Windows® Vista™ Premium Level HD Audio (VIA® VT1708S Audio Codec)”. I don’t run Windows except in VMs, so I don’t know what happens with this in Windows.

Any ideas?

Oh, and here’s the rest of the information:

rpm -qa ‘alsa


rpm -qa ‘pulse


rpm -q libasound2


uname -a

Linux linux 2.6.34-12-desktop #1 SMP PREEMPT 2010-06-29 02:39:08 +0200 i686 athlon i386 GNU/Linux

cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-hda-intel,snd-hda-intel

5Dex.kbbodfW5Eh5:SBx00 Azalia (Intel HDA)

alias snd-card-0 snd-hda-intel

2Oa+.qYUBX0V5Bj8:ATI Technologies Inc

alias snd-card-1 snd-hda-intel

You may be having sound sw conflicts from >1 audio application. I found in 11.3 that Banshee and Totem was playing great one night. The next night, VBox was running, with its windze beeps and little musical prompts. Guess what?? Banshee and Totem were dead then. They were fine the next day once again - when VBox was not running.

This doesn’t have anything to do with applications running. It starts as soon as I boot up, and continues on indefinitely.

Not having audio available is really a nuisance. :frowning:

Note the PCM control can dynamically go to zero at times, when different apps are started. I note this in your mixer:

Simple mixer control ‘Master Front’,0
Capabilities: pvolume pswitch penum
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Front Left: Playback 25 [81%] [3.00dB] [on]
Front Right: Playback 25 [81%] [3.00dB] [on]
Simple mixer control ‘PCM’,0
Capabilities: pvolume penum
Playback channels: Front Left - Front Right
Limits: Playback 0 - 255
Front Left: Playback 20 [8%] -47.00dB]
Front Right: Playback 10 [4%] -49.00dB]You NEED to pay attention to the PCM volume control setting. 8% and 4% is FAR TOO low.

I’ve tried many different settings in an attempt to get this working. The PCM volume controls don’t appear to be a factor, though. I just took another state capture: In this one the PCM volume is 98%/100%, but the problem still occurs.

I can literally watch it happen on the KMix icon on the taskbar. The red mute X flashes on and off continuously (though it’s mostly shown, meaning the sound is muted), averaging about 1-2 cycles per second. It seems like either some sound process is badly confused and keeps flipping the state, or two separate processes are running and one mutes it while the other unmutes. I have no idea what these could be, though.

If nothing works, then the best thing to do is write a bug report on openSUSE component “sound”, which will bring your problem to the attention of an alsa developer (who also packaged the sound for openSUSE). If anyone can sort this, he can.

There is guidance here for that: openSUSE:Submitting bug reports - openSUSE

Please run

/usr/sbin/ --no-upload

and attach to the bug report the file /tmp/alsa-info.txt (look careful toward the bottom of the bug report to see how to add an attachment). There is no benefit added from referencing this thread, as the alsa developer will not read forum threads.

Finally got a hint as to what’s going on with this. I’ve had headphones plugged in the front all this time, even though I haven’t been using them. I unplugged the headphones to use them elsewhere, and noticed the mute/unmute cycling had stopped. Plugging them back in resumes the constant cycling.

So the issue appears to be that some process within the sound system is trying to mute the speakers when headphones are plugged in, but something else is unmuting.