soundproblem in suse 10.3

sound used to work just fine. now gone. :’(

output from posted here.

Please help!

Thanks in advance.


SDB:AudioTroubleshooting - openSUSE


thanks for the tip. already tried that to no avail. in fact that’s how i learned of the script used to post the info about my sound setup.

i tried upgrading to alsa 1.0.19; no sound.

uninstalled all alsa (including tools firmware and utils) and reinstalled, again to no avail.

i know the sound card works because i can boot from a live cd and get sound.

so i am just about at the end of the rope and ready bite the bullet and either reinstall 10.3 or upgrade to 11.1. the headache though of reinstalling all those softwares etc…:bad:

anyway, any help is appreciated.

Sound is not really my ‘Thing’.
Check the obvious too, like the mixer settings. Hopefully one of my colleagues ‘oldcpu’ will see this and offer his expert advice.

I recall seeing some issues post recent kernel update (in 11.1) and some rolled back as I recall to wait for alsa packages to catch up with the main updates.

thanks anyway. am currently trying to reinstall 1.0.19 via yast2 once more. waiting for opdcpu.


upgraded to alsa 1.0.19. Here is the new info.

i don’t know why it says the driver version is 1.0.14. in my yast2 software management, and also using an rpm -q i get alsa-1.0.19.git20090422-1.1.

Hi gweinstein.

Sorry to read of your sound problems. I note the script output. Could you also provide the output of:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Looking at the script, I see you have a 32-bit openSUSE-10.3 with the kernel, and an AD1981a hardware audio codec. I also note, as have you, that your PC has the 1.0.14 driver, despite your efforts to update to the 1.0.19

!!ALSA Version

Driver version:     1.0.14
Library version:    1.0.19
Utilities version:  1.0.19

I suspect the reason for that is you failed to install the alsa-driver-kmp-default that MUST also be installed with the git rpms.

If you look at the troubleshooting guide: SDB:AudioTroubleshooting - openSUSE you will note it refers to this alsa rpm update guide: Alsa-update - openSUSE where it notes the specific commands required if one has the kernel. I suspect you mistakenly tried to install the alsa-driver-kmp-default for the kernel, and hence your problem.

Perhaps you were lead astray by the 10.3 example in the troubleshooting guide, and hence I think I just may remove that example.


Thanks! I’ll try the update commands for my kernel and repost both the script output and the output from the commands you asked.


update successful. not home right now, so can’t check whether there is sound, here in info requested:

rpm -qa | grep alsa


rpm -qa | grep pulse
No output (remotely)
(IS that a sound test?)

rpm -q libasound2


uname -a

Linux yossi #1 SMP 2008-12-18 10:17:03 +0100 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/sound

options snd-intel8x0 enable=1 index=0

# W60f.C59m0999xgD:82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller
alias snd-card-0 snd-intel8x0

Thanks for the help!

OK, thanks for that. I don’t think you have sound as I note this:

!!Amixer output

!!-------Mixer controls for card 0 [I82801DBICH4]

Invalid card number.
Usage: amixer <options> [command]

That does not look healthy.

Did you reboot after that update of alsa? You need to reboot after updating.

If no sound, try running YaST > Hardware > Sound and delete and then re-install your sound card.

If that fails, you can try ‘alsaconf’.

I did reboot. Will try that when I get home.

Assuming your sound is not working, what you could do to try get more information, is immediately after rebooting, with your pc connected to the internet, run this:
dmesg > dmesg.txt
and then open dmesg.txt with a text editor, and copy and paste its contents to a paste bin site ( such as pastebin - Type, paste, share. ) and then post the URL here. Just the URL. Maybe that will give a hint as to that strange mixer error.

Here is the pastebin link:

pastebin - Anonymous - post number 1402364



I don’t know what I did. I used alsaconf and I think I made a mistake and installed some fake legacy sound card. Then deleted it in Yast and used the Yast install to reinstall the other sound card and now I have sound!

Still puzzled but happier. :slight_smile:

Thanks oldcpu for all your help!



A backup suggestion (in case the problem comes back), … make a copy of /etc/modprobe.d/sound (and keep the backup in some OTHER directory than /etc/modprobe.d in a secure backup location).

Also, run the diagnostic script and keep it as a record of your functional sound configuration (for possible future comparison against a reappearance of non-functional sound). You can create a text file with that diagnostic info by:

 wget -O && bash --no-upload

and the script output will be in /tmp/alsa-info.txt. Copy alsa-info.txt to some secure backup location.

took your suggestion.

thanks for all the help!