Soundcard only "Dummy Output"

Hi,
for a few weeks, probably after the update to Leap 15.4, sound doesn’t work anymore. The only device is Dummy Output.
In Yast - Hardware - Audio the sound works, but outside not.

Some system informations:
KDE 5.24.4

sudo lspci  | grep -i audio 
00:1b.0 **Audio** device: Intel Corporation 82801JD/DO (ICH10 Family) HD **Audio** Controller (rev 02)

uname -r 
5.14.21-150400.24.21-default

inxi -A 
**Audio:     Device-1:** Intel 82801JD/DO HD Audio **driver:** snd_hda_intel 
           **Sound Server-1:** ALSA **v:** k5.14.21-150400.24.21-default **running:** yes 
           **Sound Server-2:** PipeWire **v:** 0.3.49 **running:** yes

wpctl status                
PipeWire 'pipewire-0' [0.3.49, doro@pc-doro, cookie:372625750] 
 └─ Clients: 
        31. KMix                                [0.3.49, doro@pc-doro, pid:5019] 
        33. pipewire-pulse                      [0.3.49, doro@pc-doro, pid:6128] 
        34. Plasma-PulseAudio                   [0.3.49, doro@pc-doro, pid:6087] 
        35. xdg-desktop-portal                  [0.3.49, doro@pc-doro, pid:18007] 
        38. Firefox                             [0.3.49, doro@pc-doro, pid:19464] 
        39. Firefox                             [0.3.49, doro@pc-doro, pid:19464] 
        43. QPulse                              [0.3.49, doro@pc-doro, pid:6104] 
        46. wpctl                               [0.3.49, doro@pc-doro, pid:20214] 

Audio 
 ├─ Devices: 
 │   
 ├─ Sinks: 
 │      32. Dummy Output                        [vol: 1.00] 
 │   
 ├─ Sink endpoints: 
 │   
 ├─ Sources: 
 │   
 ├─ Source endpoints: 
 │   
 └─ Streams: 

Video 
 ├─ Devices: 
 │   
 ├─ Sinks: 
 │   
 ├─ Sink endpoints: 
 │   
 ├─ Sources: 
 │   
 ├─ Source endpoints: 
 │   
 └─ Streams: 

Settings 
 └─ Default Configured Node Names:


the output from /usr/sbin/alsa-info.sh is here: [FONT=monospace]http://alsa-project.org/db/?f=78406be34d4bd5f3a2b5f6af78b0d6707804fb92

Any help will be appreciated. It worked for sure with Leap 15.3 and this machine is not the main computer, so the failure wasn’t noticed earlier.

Thanks
Regards Uwe

[/FONT]

@ubecker:

What happens if, you disable Pipewire and, re-enable Pulse?


 > systemctl --user list-unit-files | grep -iE 'puls|pip'
pipewire-media-session.service                                        masked    enabled
pipewire.service                                                      masked    disabled
pulseaudio-x11.service                                                static    -
pulseaudio.service                                                    disabled  disabled
pipewire.socket                                                       masked    enabled
pulseaudio.socket                                                     enabled   enabled
 > 

Is the Intel Audio device associated with a Kernel driver?

 # lspci -k | grep -i 'Audio' -A 3

In YaST, is the Audio Device really enabled?

The OP’s inxi output already showed that snd_hda_intel is loaded.

In YaST, is the Audio Device really enabled?

Again, refer to the inxi output.

[QUOTE=ubecker;3164236]

wpctl status                
PipeWire 'pipewire-0' [0.3.49, doro@pc-doro, cookie:372625750] 
 └─ Clients: 
        31. KMix                                [0.3.49, doro@pc-doro, pid:5019] 
        33. pipewire-pulse                      [0.3.49, doro@pc-doro, pid:6128] 
        34. Plasma-PulseAudio                   [0.3.49, doro@pc-doro, pid:6087] 
        35. xdg-desktop-portal                  [0.3.49, doro@pc-doro, pid:18007] 
        38. Firefox                             [0.3.49, doro@pc-doro, pid:19464] 
        39. Firefox                             [0.3.49, doro@pc-doro, pid:19464] 
        43. QPulse                              [0.3.49, doro@pc-doro, pid:6104] 
        46. wpctl                               [0.3.49, doro@pc-doro, pid:20214] 

I would have expected ‘pipewire-media-session’ to be present in that output as well.

Check

systemctl --user status pipewire-media-session

If necessary, start it with

systemctl --user enable --now  pipewire-media-session
systemctl --user enable --now  pipewire-media-session 
Failed to enable unit: Unit file pipewire-media-session.service does not exist.

The list of the installed pipewire packages:

zypper se -si pulse pipe 
Repository-Daten werden geladen... 
Installierte Pakete werden gelesen... 

S  | Name                       | Type  | Version           | Arch   | Repository 
---+----------------------------+-------+-------------------+--------+--------------------- 
i  | alsa-plugins-pulse-32bit   | Paket | 1.2.6-150400.1.10 | x86_64 | openSUSE-Leap-15.4-1 
i  | alsa-plugins-pulse-32bit   | Paket | 1.2.6-150400.1.10 | x86_64 | Haupt-Repository 
i  | apulse                     | Paket | 0.1.13-bp154.1.41 | x86_64 | openSUSE-Leap-15.4-1 
i  | apulse                     | Paket | 0.1.13-bp154.1.41 | x86_64 | Haupt-Repository 
i  | libKF5PulseAudioQt3        | Paket | 1.3-bp154.1.73    | x86_64 | openSUSE-Leap-15.4-1 
i  | libKF5PulseAudioQt3        | Paket | 1.3-bp154.1.73    | x86_64 | Haupt-Repository 
i  | libpipeline1               | Paket | 1.4.1-1.27        | x86_64 | openSUSE-Leap-15.4-1 
i  | libpipeline1               | Paket | 1.4.1-1.27        | x86_64 | Haupt-Repository 
i  | libpipewire-0_3-0          | Paket | 0.3.49-150400.1.5 | x86_64 | openSUSE-Leap-15.4-1 
i  | libpipewire-0_3-0          | Paket | 0.3.49-150400.1.5 | x86_64 | Haupt-Repository 
i  | libpulse-devel             | Paket | 15.0-150400.2.10  | x86_64 | openSUSE-Leap-15.4-1 
i  | libpulse-devel             | Paket | 15.0-150400.2.10  | x86_64 | Haupt-Repository 
i  | libpulse-mainloop-glib0    | Paket | 15.0-150400.2.10  | x86_64 | openSUSE-Leap-15.4-1 
i  | libpulse-mainloop-glib0    | Paket | 15.0-150400.2.10  | x86_64 | Haupt-Repository 
i  | libpulse0                  | Paket | 15.0-150400.2.10  | x86_64 | openSUSE-Leap-15.4-1 
i  | libpulse0                  | Paket | 15.0-150400.2.10  | x86_64 | Haupt-Repository 
i  | libpulse0-32bit            | Paket | 15.0-150400.2.10  | x86_64 | openSUSE-Leap-15.4-1 
i  | libpulse0-32bit            | Paket | 15.0-150400.2.10  | x86_64 | Haupt-Repository 
i+ | mpg123-pulse               | Paket | 1.26.4-1.15       | x86_64 | openSUSE-Leap-15.4-1 
i+ | mpg123-pulse               | Paket | 1.26.4-1.15       | x86_64 | Haupt-Repository 
i  | pipewire                   | Paket | 0.3.49-150400.1.5 | x86_64 | openSUSE-Leap-15.4-1 
i  | pipewire                   | Paket | 0.3.49-150400.1.5 | x86_64 | Haupt-Repository 
i  | pipewire-lang              | Paket | 0.3.49-150400.1.5 | noarch | openSUSE-Leap-15.4-1 
i  | pipewire-lang              | Paket | 0.3.49-150400.1.5 | noarch | Haupt-Repository 
i  | pipewire-modules-0_3       | Paket | 0.3.49-150400.1.5 | x86_64 | openSUSE-Leap-15.4-1 
i  | pipewire-modules-0_3       | Paket | 0.3.49-150400.1.5 | x86_64 | Haupt-Repository 
i  | pipewire-pulseaudio        | Paket | 0.3.49-150400.1.5 | x86_64 | openSUSE-Leap-15.4-1 
i  | pipewire-pulseaudio        | Paket | 0.3.49-150400.1.5 | x86_64 | Haupt-Repository 
i  | pipewire-spa-plugins-0_2   | Paket | 0.3.49-150400.1.5 | x86_64 | openSUSE-Leap-15.4-1 
i  | pipewire-spa-plugins-0_2   | Paket | 0.3.49-150400.1.5 | x86_64 | Haupt-Repository 
i  | pipewire-spa-tools         | Paket | 0.3.49-150400.1.5 | x86_64 | openSUSE-Leap-15.4-1 
i  | pipewire-spa-tools         | Paket | 0.3.49-150400.1.5 | x86_64 | Haupt-Repository 
i  | pipewire-tools             | Paket | 0.3.49-150400.1.5 | x86_64 | openSUSE-Leap-15.4-1 
i  | pipewire-tools             | Paket | 0.3.49-150400.1.5 | x86_64 | Haupt-Repository 
i  | pulseaudio-bash-completion | Paket | 15.0-150400.2.10  | x86_64 | openSUSE-Leap-15.4-1 
i  | pulseaudio-bash-completion | Paket | 15.0-150400.2.10  | x86_64 | Haupt-Repository 
i  | pulseaudio-setup           | Paket | 15.0-150400.2.10  | x86_64 | openSUSE-Leap-15.4-1 
i  | pulseaudio-setup           | Paket | 15.0-150400.2.10  | x86_64 | Haupt-Repository 
i  | pulseaudio-utils           | Paket | 15.0-150400.2.10  | x86_64 | openSUSE-Leap-15.4-1 
i  | pulseaudio-utils           | Paket | 15.0-150400.2.10  | x86_64 | Haupt-Repository 
i  | pulseaudio-utils-32bit     | Paket | 15.0-150400.2.10  | x86_64 | openSUSE-Leap-15.4-1 
i  | pulseaudio-utils-32bit     | Paket | 15.0-150400.2.10  | x86_64 | Haupt-Repository

systemctl --user list-unit-files | egrep -i "pipe|pulse" 
**pipe**wire-**pulse**.service                                                enabled   disabled 
**pipe**wire.service                                                      enabled   disabled 
**pipe**wire-**pulse**.socket                                                 enabled   enabled 
**pipe**wire.socket                                                       enabled   enabled

I don’t find a software package pipewire-media-session for Leap 15.4

I don’t find a software package pipewire-media-session for Leap 15.4

Based on this article…
https://lwn.net/Articles/905725/
…it has been superseded by wireplumber.

So do

sudo zypper in wireplumber
systemctl --user enable --now wireplumber.service

Then check

wpctl status

On this Leap 15.4 system, “wireplumber” was installed last July:


 # less /var/log/zypp/history | grep -i 'wireplumber'
2022-07-19 14:16:14|install|libwireplumber-0_4-0|0.4.9-150400.1.5|x86_64||repo-oss|468d688624eb224deafe0ac67b92d5a0fe8e268bf24f42b7386879cd97b4f74d|
2022-07-19 14:16:16|install|wireplumber|0.4.9-150400.1.5|x86_64||repo-oss|e673be3e191fa9588dd1eef1caa4c3a0d96d644f51158ed15e11aa5b2c7b2f7e|
 # 

And, this patch also made some changes:


 > LANG=C zypper patch-info openSUSE-SLE-15.4-2022-2866 
Loading repository data...
Reading installed packages...


Information for patch openSUSE-SLE-15.4-2022-2866:
--------------------------------------------------
Repository  : Update repository with updates from SUSE Linux Enterprise 15
Name        : openSUSE-SLE-15.4-2022-2866
Version     : 1
Arch        : noarch
Vendor      : maint-coord@suse.de
Status      : applied
Category    : security
Severity    : moderate
Created On  : Mon Aug 22 15:36:44 2022
Interactive : ---
Summary     : Security update for systemd-presets-common-SUSE
Description : 
    This update for systemd-presets-common-SUSE fixes the following issues:

    - CVE-2022-1706: Fixed accessible configs from unprivileged containers in VMs running on VMware products
    (bsc#1199524).

    The following non-security bugs were fixed:

    - Modify branding-preset-states to fix systemd-presets-common-SUSE
      not enabling new user systemd service preset configuration just
      as it handles system service presets. By passing an (optional)
      second parameter "user", the save/apply-changes commands now
      work with user services instead of system ones (bsc#1200485)

    - Add the wireplumber user service preset to enable it by default
      in SLE15-SP4 where it replaced pipewire-media-session, but keep
      pipewire-media-session preset so we don't have to branch the
      systemd-presets-common-SUSE package for SP4 (bsc#1200485)
Provides    : patch:openSUSE-SLE-15.4-2022-2866 = 1
Conflicts   : [3]
    systemd-presets-common-SUSE < 15-150100.8.17.1
    srcpackage:systemd-presets-common-SUSE < 15-150100.8.17.1
    systemd-presets-common-SUSE.noarch < 15-150100.8.17.1

 > 

Hi,

systemctl --user enable --now wireplumber.service

did the job. Wireplumber was already installed. Now it works again as it should.
Thanks for the help

Glad to have been of guidance. :slight_smile: